Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 10 sur 10
  1. #1
    Candidat au titre de Membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    18
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : janvier 2013
    Messages : 18
    Points : 11
    Points
    11

    Par défaut Paquet impossible à installer

    Bonjour,

    je viens vous demander de l'aide a propos de Linux. Je suis actuellement en stage, vu que je suis en BTS Info et il m'arrive dès le début une erreur qui ne m'est jamais arrivé.

    Voila j'ai un serveur virtuel Ubuntu 10.10 et je me connecte sur ce serveur avec putty.
    Je me connecte en administrateur, et impossible d'installer un seul paquet.



    si vous ne voyez pas bien, il s'agit de :

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package build-essential

    apt-get update me balance une liste d'erreurs...

    Voilà, on vient a peine de me confier une mission, et j'ai déjà une erreur que je n'arrive pas à résoudre.
    Si quelqu'un a un début de réponse, ou une solution

  2. #2
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    Ingénieur Pizzaiolo
    Inscrit en
    septembre 2002
    Messages
    3 128
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Ingénieur Pizzaiolo

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 128
    Points : 5 190
    Points
    5 190

    Par défaut

    Salut,

    Je ne vois pas tes erreurs mais au hasard (lien de l'image mort), je dirais: vérifie dans un premier temps la connexion à internet vu que ces outils se connectent généralement à des dépôts sur internet. Si ce n'est pas le cas, il faudra fournir plus de détails.
    Alea Jacta Test!

  3. #3
    Candidat au titre de Membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    18
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : janvier 2013
    Messages : 18
    Points : 11
    Points
    11

    Par défaut

    Je n'ai pas eu le temps de regarder, mais je crois bien que le serveur linux possède qu'une seule adresse IP. Vu que je me connecte via Putty, je ne peux rajouter une carte réseau, non ?

    J'ai fait d'autres screens avant de repartir chez moi, je ne sais pas si sa peut aider. J'espère que sa va marché cette fois :

    apt-get update ==>



    et en cherchant sur internet, j'ai vu que beaucoup parlait d'un fichier source.list alors je le met. Il m'a pas l'air super...


  4. #4
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    Ingénieur Pizzaiolo
    Inscrit en
    septembre 2002
    Messages
    3 128
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Ingénieur Pizzaiolo

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 128
    Points : 5 190
    Points
    5 190

    Par défaut

    Re,

    Non tu n'as pas besoin d'interface supplémentaire. Tu dois juste vérfier que ton serveur peut se connecter à internet.

    Tu peux pinguer dans un premier temps www.google.fr et voir si ça répond. si c'est le cas, c'est que ton serveur peut se connecter à internet.

    Cependant dans ce cas-ci, je vois que tu uitlises une version d'ubuntu qui n'est plus supportée depuis avril 2012 et il se peut que les dépôts officiels ne soit plus disponibles. D'où la 404 (not found) lors du apt-get update.

    http://doc.ubuntu-fr.org/maverick

    Fin de vie depuis le 10 avril 2012
    Depuis le 10 avril 2012, Ubuntu 10.10 est en fin de vie (end of life, EOL). Elle ne profite plus de nouvelle mise à jour de sécurité et les paquets logiciels pour cette version sont déplacés dans des serveurs d'archive. Pour continuer à recevoir des mises à jour de sécurité, veuillez mettre à niveau votre version d'Ubuntu vers une version activement soutenue.
    Tu peux cependant utiliser des dépôts d'archives qui sont spécifiés dans le lien que je t'ai donné et mettre en commentaire les les url que tu as ton fichier source.lst actuel.

    Obtenir et utiliser Ubuntu 10.10



    Veuillez noter qu'Ubuntu 10.10 n'est plus une version activement soutenue depuis le 10 avril 2012. Ceci signifie que plus aucune mise à jour de sécurité n'est publiée pour cette version d'Ubuntu. Il est vivement conseillé de mettre à niveau Ubuntu vers une version ultérieure, toujours activement soutenue.

    Néanmoins, il n'y a pas de date d'arrêt de fonctionnement à votre système Ubuntu : les versions d'Ubuntu arrivées en fin de vie sont toujours techniquement fonctionnelles. Il n'y a pas de mécanisme bloquant artificiellement le fonctionnement de votre système Ubuntu, et vous pouvez continuer à l'utiliser en connaissance de cause, jusqu'à ce que vous décidiez à mettre à niveau votre système d'exploitation. Notez que les dépôts officiels ne proposeront bientôt plus de paquets/logiciels pour Ubuntu 10.10. Ceux-ci seront migrés vers un dépôt d'archives, destinés à contenir les logiciels des versions obsolètes d'Ubuntu. Les paquets de ces dépôts ne sont évidemment plus mis à jour; ils vous permettent seulement de continuer à utiliser la Logithèque ou tout autre système d'installation de logiciels.

    Pour récupérer un CD-ROM d'installation d'Ubuntu 10.10, accédez au serveur de téléchargement des versions archivées.
    Pour installer des logiciels, modifiez votre fichier de sources de logiciels (/etc/apt/sources.list) afin de le faire pointer vers les serveurs d'archives:
    deb http://old-releases.ubuntu.com/ubuntu/ maverick main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick main restricted universe multiverse

    deb http://old-releases.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse

    deb http://old-releases.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse

    deb http://old-releases.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse

    deb http://old-releases.ubuntu.com/ubuntu/ maverick-proposed main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-proposed main restricted universe multiverse
    Alea Jacta Test!

  5. #5
    Candidat au titre de Membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    18
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : janvier 2013
    Messages : 18
    Points : 11
    Points
    11

    Par défaut

    Merci de ton aide. Il faut donc que je mette les liens url de base du fichier source.list en commentaire, et rajouter celles ci :

    deb http://old-releases.ubuntu.com/ubuntu/ maverick main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick main restricted universe multiverse

    deb http://old-releases.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse

    deb http://old-releases.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse

    deb http://old-releases.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse

    deb http://old-releases.ubuntu.com/ubuntu/ maverick-proposed main restricted universe multiverse
    #deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-proposed main restricted universe multiverse

    par la suite je vais devoir utiliser cacti, sa pose pas de problème ?

  6. #6
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    Ingénieur Pizzaiolo
    Inscrit en
    septembre 2002
    Messages
    3 128
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Ingénieur Pizzaiolo

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 128
    Points : 5 190
    Points
    5 190

    Par défaut

    Oui c'est bien ça.

    Concernant cacti, je ne vois pas en quoi ça poserait problème.
    Alea Jacta Test!

  7. #7
    Candidat au titre de Membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    18
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : janvier 2013
    Messages : 18
    Points : 11
    Points
    11

    Par défaut

    Bonjour, alors je viens de reprendre a 8h ce matin, j'ai testé le ping sur google.com, sa ping bien.

    J'ai modifié le fichier, je lance un apt-get update et sa fonctionne parfaitement. A voir avec d'autres installations de paquets mais normalement c'est bon

    Pour cacti je posais la question car je n'ai jamais utilisé ce logiciel. J'ai fait un gros TP sur nagios en BTS mais c'est tout. Donc j'aurai a mon avis besoin a nouveau d'aide ^^

    Dois je créer un nouveau toic dans ce cas là ? En tout cas merci de ton aide

  8. #8
    Responsable 2D/3D/Jeux

    Avatar de LittleWhite
    Homme Profil pro Alexandre Laurent
    Ingénieur développement logiciels
    Inscrit en
    mai 2008
    Messages
    15 577
    Détails du profil
    Informations personnelles :
    Nom : Homme Alexandre Laurent
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 15 577
    Points : 71 929
    Points
    71 929

    Par défaut

    Bonjour,

    Si vous avez des problèmes avec cacti, oui il faudra créer une nouvelle discussion, car il faut garder une discussion par problème (sinon ça devient un peu le foutoir et on n'arrive pas à suivre).
    A propos de build-essential, je pense qu'il manque un 's'. Mais il est certain qu'un moment, le problème était la connectivité de la machine.

    Si ce problème est résolu, n'hésitez pas à cliquer sur le bouton en bas de la page
    Vous souhaitez participer à la rubrique 2D / 3D / Jeux ? Contactez-moi
    La rubrique a aussi un blog !

    Ma page sur DVP
    Mon Portfolio

    Qui connaît l'erreur, connaît la solution.

  9. #9
    Candidat au titre de Membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    18
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : janvier 2013
    Messages : 18
    Points : 11
    Points
    11

    Par défaut

    Probleme résolu.

    Je m'empresse de créer un nouveau topic pour cacti, je suis bloqué...

  10. #10
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    Ingénieur Pizzaiolo
    Inscrit en
    septembre 2002
    Messages
    3 128
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Ingénieur Pizzaiolo

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 128
    Points : 5 190
    Points
    5 190

    Par défaut

    Hello,

    Citation Envoyé par LittleWhite Voir le message
    Bonjour,
    A propos de build-essential, je pense qu'il manque un 's'.
    Non, il n'y a pas de 's' à la fin pour le package build-essential.

    Code :
    1
    2
    3
    4
    5
     
    apt-cache search build-essential
    devscripts - scripts to make the life of a Debian Package maintainer easier
    build-essential - Liste informative des paquets de construction essentiels
    sbuild - Tool for building Debian binary packages from Debian sources
    Alea Jacta Test!

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •