p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Nouveau Membre du Club

    Homme Profil pro
    Expert-comptable
    Inscrit en
    septembre 2007
    Messages
    26
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Expert-comptable
    Secteur : Conseil

    Informations forums :
    Inscription : septembre 2007
    Messages : 26
    Points : 31
    Points
    31

    Par défaut DELPHI, EXCEL : Erreur OLE avec fonction SOMME.SI

    Bonsoir à tous !

    Je travaille sur un programme qui crée un classeur EXCEL : il crée des feuilles vierges avec des formats et des formules de calcul. J'ai un problème avec la fonction SOMME.SI, en effet alors que toutes les formules que j'insère dans ma feuille de calcul fonctionnent, l'usage de SOMME.SI ou de SUMIF engendre systématiquement une erreur OLE de la part de DELPHI.

    Exemple :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
     cellule.formula:='=SUMIF(Détentions!C$2:C$50;Entités!B2;Détentions!D$2:D$50)';
    Quelqu'un a-t-il une idée pour résoudre mon problème ?

    Merci d'avance,

    Cdlt,

    Benoît

  2. #2
    Modérateur
    Avatar de tourlourou
    Homme Profil pro
    Biologiste ; Progr(amateur)
    Inscrit en
    mars 2005
    Messages
    2 437
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : Biologiste ; Progr(amateur)

    Informations forums :
    Inscription : mars 2005
    Messages : 2 437
    Points : 5 845
    Points
    5 845
    Delphi 5 Pro - CodeTyphon 5.20 sous Win 7 et Ubuntu 14.04

  3. #3
    Nouveau Membre du Club

    Homme Profil pro
    Expert-comptable
    Inscrit en
    septembre 2007
    Messages
    26
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Expert-comptable
    Secteur : Conseil

    Informations forums :
    Inscription : septembre 2007
    Messages : 26
    Points : 31
    Points
    31

    Par défaut

    Bonjour,
    Merci pour votre réponse mais je n'ai pas trouvé de réponse satisfaisante même en remplaçant le .formula par .value.
    J'ai encore effectué des recherche sur Google mais en vain.
    Cdlt,
    Benoît

  4. #4
    Modérateur
    Avatar de tourlourou
    Homme Profil pro
    Biologiste ; Progr(amateur)
    Inscrit en
    mars 2005
    Messages
    2 437
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : Biologiste ; Progr(amateur)

    Informations forums :
    Inscription : mars 2005
    Messages : 2 437
    Points : 5 845
    Points
    5 845

    Par défaut

    quid en remplaçant les ';' par des ',' ?
    Delphi 5 Pro - CodeTyphon 5.20 sous Win 7 et Ubuntu 14.04

  5. #5
    Nouveau Membre du Club

    Homme Profil pro
    Expert-comptable
    Inscrit en
    septembre 2007
    Messages
    26
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Expert-comptable
    Secteur : Conseil

    Informations forums :
    Inscription : septembre 2007
    Messages : 26
    Points : 31
    Points
    31

    Par défaut

    Ah !!!!! Merci beaucoup Tourlourou, avec les virgules je n'ai plus de messages d'erreurs !!!! Ca fonctionne à merveille. Comme quoi il suffit de pas grand'chose pour rester bloquer pendant des heures !!!

    Est-ce qu'il existe un livre ou une documentation en ligne qui traite de la programmation DELPHI et EXCEL ? Je connais déjà les tutos de base, j'aurais plutôt besoin de tuto plus pointus. J'ai vraiment galéré pour programmer les TCD...

    Encore merci.

    Bonne journée,

    Benoît

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [D7-MSXML2_TLB] Erreur xPath avec fonctions avancées
    Par dacid dans le forum Débutant
    Réponses: 1
    Dernier message: 19/03/2008, 14h12
  2. Réponses: 5
    Dernier message: 25/01/2008, 11h15
  3. [VBA][EXCEL]Erreur '1004' avec "Application.Run"
    Par Ania dans le forum Macros et VBA Excel
    Réponses: 1
    Dernier message: 16/01/2006, 10h50
  4. [Excel] Erreur 1004 avec un search
    Par Rakham dans le forum Macros et VBA Excel
    Réponses: 1
    Dernier message: 23/12/2005, 13h54

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo