1. #1
    Invité de passage
    Inscrit en
    janvier 2013
    Messages
    6
    Détails du profil
    Informations forums :
    Inscription : janvier 2013
    Messages : 6
    Points : 0
    Points
    0

    Par défaut Je ne trouve pas la fonction adequate

    Bonjour,
    je vous explique mon problème.
    J'ai un tableau pour suivre le chiffre d'affaire des clients. Je cherche une fonction qui pourra me faire ressortir le nombre de contrats dont le CA est positif et qui n'est pas un avenant. Je pense que SOMMEPROD doit pouvoir me sortir d'affaire mais je n'arrive pas à m'en servir.
    Si joint le tableau test

    Merci pour votre aide


    test.zip

  2. #2
    Expert Confirmé Sénior Avatar de mercatog
    Homme Profil pro
    Inscrit en
    juillet 2008
    Messages
    8 366
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2008
    Messages : 8 366
    Points : 27 220
    Points
    27 220

    Par défaut

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMMEPROD((B5:B11<>"x")*(D5:D11>0))
    Cordialement.

  3. #3
    Invité de passage
    Inscrit en
    janvier 2013
    Messages
    6
    Détails du profil
    Informations forums :
    Inscription : janvier 2013
    Messages : 6
    Points : 0
    Points
    0

    Par défaut

    On y est presque, mais je voudrais exclure pas seulement les "x" mais tout type de texte.

  4. #4
    Expert Confirmé Sénior

    Profil pro
    Conseil, Formation, Développement - Indépendant
    Inscrit en
    février 2010
    Messages
    2 637
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Conseil, Formation, Développement - Indépendant

    Informations forums :
    Inscription : février 2010
    Messages : 2 637
    Points : 4 686
    Points
    4 686

    Par défaut

    Bonjour
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMMEPROD((D5:D11>0)*(B5:B11=""))
    Chris

    Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
    Confucius

    ----------------------------------------------------------------------------------------------
    En cas de résolution, n'hésitez pas cliquer sur c'est toujours apprécié...

  5. #5
    Invité de passage
    Inscrit en
    janvier 2013
    Messages
    6
    Détails du profil
    Informations forums :
    Inscription : janvier 2013
    Messages : 6
    Points : 0
    Points
    0

    Par défaut

    Merci c'est exactement ce que je voulais !!!
    =)

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 2
    Dernier message: 25/02/2015, 22h12
  2. Ne trouve pas les fonctions math
    Par lucaordi dans le forum C
    Réponses: 11
    Dernier message: 07/07/2009, 15h16
  3. Réponses: 3
    Dernier message: 19/05/2008, 13h51
  4. Je ne trouve pas la fonction _fseeki64()
    Par uriotcea dans le forum C++Builder
    Réponses: 3
    Dernier message: 07/12/2007, 17h07
  5. Réponses: 24
    Dernier message: 30/05/2007, 18h29

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo