p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Futur Membre du Club
    Inscrit en
    décembre 2012
    Messages
    67
    Détails du profil
    Informations forums :
    Inscription : décembre 2012
    Messages : 67
    Points : 16
    Points
    16

    Par défaut Traitement de mon formulaire

    Salut !
    J'ai un soucis, c'est lors du traitement de mon formulaire.
    http://pastebin.com/uFCX5s7Q
    Lorsque le champ "pseudo" ou "mot" est vide, cela doit rediriger le membre sur la page du formulaire avec une erreur $_GET.

    Le soucis c'est que j'ai rajouté la partie qui vérifie si le pseudo est dispo ($req3).
    Maintenant, je n'ai plus d'erreur signalant si le champ "pseudo est vide" (enfin si mais j'ai 0 comme valeur) et de plus, $_GET["pseudo_disponible"] est vide.
    D'où ça vient ? Merci.

  2. #2
    Responsable Développement Web


    Avatar de Bovino
    Homme Profil pro
    Développeur Web
    Inscrit en
    juin 2008
    Messages
    23 788
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 45
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juin 2008
    Messages : 23 788
    Points : 91 310
    Points
    91 310
    Billets dans le blog
    20

    Par défaut

    Il faut revoir l'utilisation des opérateurs...
    = c'est une affectation dont l'équivalent booléen est true, du coup, tu rentres systématiquement dans cette condition !
    Pour une comparaison, c'est == ou ===.
    Pas de question technique par MP !
    Tout le monde peut participer à developpez.com, vous avez une idée, contactez-moi !
    Mes formations video2brain : La formation complète sur JavaScriptJavaScript et le DOM par la pratiquePHP 5 et MySQL : les fondamentaux
    Mon livre sur jQuery
    Module Firefox / Chrome d'intégration de JSFiddle et CodePen sur le forum

  3. #3
    Futur Membre du Club
    Inscrit en
    décembre 2012
    Messages
    67
    Détails du profil
    Informations forums :
    Inscription : décembre 2012
    Messages : 67
    Points : 16
    Points
    16

    Par défaut

    Ah oui, merci.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 7
    Dernier message: 26/03/2006, 16h46
  2. ie ne retrouve pas un element de mon formulaire
    Par duge dans le forum JavaScript
    Réponses: 2
    Dernier message: 28/02/2006, 09h50
  3. la date et heure sur mon formulaire
    Par azde7015 dans le forum Access
    Réponses: 11
    Dernier message: 07/02/2006, 10h40
  4. [Debutant(e)]mise à jour de mon formulaire via JSP
    Par kouadjalain dans le forum Servlets/JSP
    Réponses: 4
    Dernier message: 11/08/2004, 15h43

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo