p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Nouveau Membre du Club
    Inscrit en
    août 2002
    Messages
    99
    Détails du profil
    Informations forums :
    Inscription : août 2002
    Messages : 99
    Points : 39
    Points
    39

    Par défaut Désactiver message de sécurité

    Bonjour,

    Dans la petite application que je développe, il est possible de sélectionner, enregistrer puis ouvrir un lien hypertexte pdf pour en visualiser le contenu.
    Je cherche depuis plusieurs jours le moyen de désactiver le message de sécurité qui s'affiche
    "Certains fichiers peuvent contaminer ou endommager...
    Voulez-vous ouvrir ce fichier ?"
    J'ai trouvé plusieurs pistes :
    http://support.microsoft.com/kb/925757/fr
    http://www.developpez.net/forums/d12...chier-interne/
    Mais aucune d'entre elles ne fonctionne.

    Le message est toujours présent avant l'ouverture du PDF.
    Cela reste gérable de cliquer dessus pour l'accepter mais au bout d'une matinée, cela devient usant.
    Je ne sais plus quoi faire.

    Je vous remercie des conseils que vous saurez me donner.
    Cordialement.

  2. #2
    Membre Expert
    Avatar de minot83
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    mars 2006
    Messages
    939
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 43
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : mars 2006
    Messages : 939
    Points : 1 339
    Points
    1 339

    Par défaut

    sous Access 2010, je ne suis pas certain, mais tu peux essayer d'ajouter
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    DoCmd.SetWarnings = false
    avant d'executer, puis remettre à
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    DoCmd.SetWarnings = true
    après.
    Autre piste, faire confiance au contenu de ton appli via signature de celle-ci approuvée. (2010)
    Ou en mettant niveau securite faible dans l’exécution des macros de ton appli.

  3. #3
    Expert Confirmé Sénior
    Avatar de jimbolion
    Homme Profil pro
    Moulticien
    Inscrit en
    janvier 2013
    Messages
    2 592
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Moulticien
    Secteur : Santé

    Informations forums :
    Inscription : janvier 2013
    Messages : 2 592
    Points : 5 482
    Points
    5 482

    Par défaut macakou99

    bonjour,

    Insère dans le registre l'approbation de ton applicatif

    Editer le fichier (bloc notes), modifie le nom de ton répertoire et exécute le fichier .reg

    A l'issue de l'opération tu ne devrais plus avoir le message !

    Jimbolion

  4. #4
    Expert Confirmé Sénior
    Avatar de jimbolion
    Homme Profil pro
    Moulticien
    Inscrit en
    janvier 2013
    Messages
    2 592
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Moulticien
    Secteur : Santé

    Informations forums :
    Inscription : janvier 2013
    Messages : 2 592
    Points : 5 482
    Points
    5 482

    Par défaut avec le fichier

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Access\Security\Trusted Locations\location]
    @=""
    "Path"="C:\\Dossier"


    Enregistre çà dans un fichier .reg

    Sous access 2007 vérifie le dossier ! (peut etre 12.0 en lieu et place du 14.0)

  5. #5
    Nouveau Membre du Club
    Inscrit en
    août 2002
    Messages
    99
    Détails du profil
    Informations forums :
    Inscription : août 2002
    Messages : 99
    Points : 39
    Points
    39

    Par défaut

    Bonsoir et Merci pour vos réponses,

    minot83, j'ai tenté cette solution
    DoCmd.SetWarnings = false
    Mais en vain car le message est toujours présent. Merci d'avoir tenté de m'aider.

    jimbolion, les deux solutions dont la dernière ne sont malheureusement pas efficaces. Merci également.

    Mais j'avoue que je ne comprends pas les échecs successifs de toutes nos tentatives car :
    • le répertoire de la base est approuvé

    • Le niveau de sécurité dans Access est abaissé au minimum.

    • L'affichage des messages de sécurité est désactivé.

    • Les modifications proposées par Microsoft ont toutes été effectuées (voir liens de mon 1er message)


    Croyez-vous qu'il soit possible de continuer à m'aider car j'ai l'impression d'avoir personnellement épuré toutes les solutions.
    Sauf une peut-être, du moins je l'espère.
    Je vous remercie de l'attention que vous porterez à la résolution de ce supposé Bug, qui, sans nul doute, rendra service à Tous.

  6. #6
    Membre Expert
    Avatar de minot83
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    mars 2006
    Messages
    939
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 43
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : mars 2006
    Messages : 939
    Points : 1 339
    Points
    1 339

  7. #7
    Nouveau Membre du Club
    Inscrit en
    août 2002
    Messages
    99
    Détails du profil
    Informations forums :
    Inscription : août 2002
    Messages : 99
    Points : 39
    Points
    39

    Par défaut

    Oui, je te remercie.
    C'est un lien que j'indique dans mon message de départ.
    J'ai modifié, j'ai créé des clés, j'ai suivi à la lettre les différentes procédures et autres méthodes.

    Voici que dit Microsoft :
    Remarque:
    Il se peut que vous receviez malgré tout un message d'avertissement de Microsoft Windows. Si vous continuez à recevoir des messages d'avertissement après avoir appliqué les procédures décrites dans cet article, utilisez l'une des méthodes suivantes pour résoudre ce problème.
    Par contre, la solution qu'a adopté antoinev2, dans son post, est très très très intéressante.
    Cela étant, le problème est contourné mais pas résolu.
    minot83, As-tu essayé d'ouvrir un lien acrobat dans une appli Access pour simuler le problème.
    J'en suis à me demander pourquoi toutes les solutions ne marchent pas.
    Je m'engage à faire un tuto si avec votre aide, nous parvenons à désactiver ce message.
    La discussion reste donc plus que jamais ouverte. Si vous souhaitez vous y confronter, je lance un challenge parce que là franchement, je comprends pas.

    Toutes vos suggestions seront plus que les bienvenues.
    Bien cordialement.

Discussions similaires

  1. [AC-2010] Désactiver affichage Message de sécurité
    Par franckb74 dans le forum Sécurité
    Réponses: 2
    Dernier message: 05/09/2013, 01h01
  2. Message de sécurité Access
    Par climz dans le forum Sécurité
    Réponses: 3
    Dernier message: 15/06/2006, 10h58
  3. Message de sécurité Outloock
    Par Pierren dans le forum Access
    Réponses: 3
    Dernier message: 28/04/2006, 16h27
  4. [ActiveX] Message de sécurité dans page Web
    Par Mescalito dans le forum MFC
    Réponses: 3
    Dernier message: 21/02/2006, 16h15
  5. [VBA-E]Eviter un message de sécurité
    Par em79 dans le forum Macros et VBA Excel
    Réponses: 5
    Dernier message: 01/02/2006, 12h42

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo