Soutenez-nous
Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Membre du Club
    Inscrit en
    avril 2011
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : avril 2011
    Messages : 231
    Points : 58
    Points
    58

    Par défaut Problème postback site ASP.net

    Bonjour,

    Alors voilà j'ai un problème étrange que je n'arrive pas à résoudre et dont je ne sais même pas comment chercher des solutions sur internet !

    J'ai développé un site web avec visual studio 2012 et depuis quelque temps je me suis aperçu que au bout d'un certain nombre de clique (variable) le site envoie une requête sur le serveur qui n'est jamais traité !! Je ne peux alors plus interagir sur mon site car il est toujours en attente du postback et celui ci tourne dans le vide !

    Par exemple, au bout du 6ème clique sur un bouton qui provoque donc un post back, je n'ai plus aucune réponse de mon site internet !

    La réaction est la même que se soit avec IIS Express de visual studio ou IIS de mon ordinateur. J'ai d'autre sites web qui tourne d'ailleurs très bien.
    Avec Fiddler je peux constater qu'un appel au serveur est envoyé mais jamais de réponse n'est retournée !
    Et lorsque je met un point d’arrêt sur le constructeur de la page et le page Load, je n'y rentre jamais !

    Je ne sais vraiment pas quoi faire pour détecter d'où viens le problème. Si vous avez des idées...

    Merci d'avance

  2. #2
    Membre du Club
    Inscrit en
    avril 2011
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : avril 2011
    Messages : 231
    Points : 58
    Points
    58

    Par défaut

    J'ai aussi pu remarqué que souvent lorsque je lance Fiddler en parallèle de mon site web, celui ci ne bug plus ou très très rarement.

    Puis en fermant Fiddler le site continue de fonctionner normalement pendant un certain temps (sa peut varier entre 10 minutes et toute une journée) jusqu’à ce que PAF ! Le comportement étrange réapparaisse soudainement !

  3. #3
    Membre du Club
    Inscrit en
    avril 2011
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : avril 2011
    Messages : 231
    Points : 58
    Points
    58

    Par défaut

    J'ai enfin réussi à retracer le problème avec Fiddler d'ouvert quand même et voici ce que sa donne au niveau des statistiques :

    This session is not yet complete. Press F5 to refresh when session is complete for updated statistics.
    Request Count: 1
    Bytes Sent: 405 (headers:405; body:0)
    Bytes Received: 0 (headers:0; body:0)

    ACTUAL PERFORMANCE
    --------------
    ClientConnected: 14:05:43.307
    ClientBeginRequest: 14:05:43.307
    GotRequestHeaders: 14:05:43.307
    ClientDoneRequest: 14:05:43.307
    Determine Gateway: 0ms
    DNS Lookup: 0ms
    TCP/IP Connect: 0ms
    HTTPS Handshake: 0ms
    ServerConnected: 14:05:43.308
    FiddlerBeginRequest: 14:05:43.308
    ServerGotRequest: 14:05:43.308
    ServerBeginResponse: 00:00:00.000
    GotResponseHeaders: 00:00:00.000
    ServerDoneResponse: 00:00:00.000
    ClientBeginResponse: 00:00:00.000
    ClientDoneResponse: 00:00:00.000

  4. #4
    Membre du Club
    Inscrit en
    avril 2011
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : avril 2011
    Messages : 231
    Points : 58
    Points
    58

    Par défaut

    Le problème était dans IIS j'avais des processus qui ne se fermait jamais et occupés toute la place.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •