Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Invité de passage
    Femme Profil pro
    Étudiant
    Inscrit en
    octobre 2011
    Messages
    19
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : octobre 2011
    Messages : 19
    Points : 4
    Points
    4

    Par défaut [Tomcat] Port et page introuvable

    Bonjour à tous!

    J'ai créé un projet test1 sous eclipse, j'ai bien suivi les règles pour le configurer avec Tomcat. Mais là quand je clique droit sur le titre du projet et que je clique sur: Run as --> Run on Server, j'obtiens ceci:


    J'ai changé le port ici: server.xml par 8181

    Mais là j'obtiens "This program cannot display the webpage"

    Merci de m'aider.

  2. #2
    vinou92340
    Invité(e)

    Par défaut

    Hum, tu devrais peut-être passer par l'interface d'eclipse pour changer le port. Tu doubles cliques sur ton serveur tomcat dans la vue servers et tu verras une page s'ouvrir. Dedans, tu changes la valeur de HTTP/1:1.

    Et pour ton projet, normalement, on fait un "add and remove" via un clique droit sur le serveur dans la vue servers. Si ton projet est bien un projet web, il devrait apparaître dans la page qui s'ouvre et tu n'auras plus qu'à le déplacer de gauche à droite en cliquant sur le projet en question et puis "Add".

    Après, est ce une simple page que tu veux afficher ou un projet web complet ? (généralement, un dynamic web project).

  3. #3
    Invité de passage
    Femme Profil pro
    Étudiant
    Inscrit en
    octobre 2011
    Messages
    19
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : octobre 2011
    Messages : 19
    Points : 4
    Points
    4

    Par défaut

    Merci pour ta réponse.
    Donc j'ai essayé de changer la valeur de http/1.1 et enregistré les modifications.
    Mais toujours les même pages qui s'affichent.


    Et pour mon projet que j'ai créé et qui est un dynamic web project,il s'affiche bel et bien à droite, dans la fenêtre Add and Remove.


    Merci de m'aider.

  4. #4
    Membre habitué
    Inscrit en
    septembre 2008
    Messages
    260
    Détails du profil
    Informations forums :
    Inscription : septembre 2008
    Messages : 260
    Points : 136
    Points
    136

    Par défaut

    Salut,

    En regardant ta première capture, tu tapes bien sur ton tomcat sur le port 8080. La 404 est une réponse de tomcat sur ce port.

    A ta place, j'ajouterais une page index.jsp ou html, je sais pas ce que tu fais, et l'intégrerais au niveau du webcontent, et ferai ensuite un run as- run on server, directement dessus

    Quant au port, au niveau du server.xml, c'est à ce niveau
    Code :
        <Connector connectionTimeout="20000" port="8080" protocol="HTTP/1.1" redirectPort="8443"/>

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •