+ Répondre à la discussion
Affichage des résultats 1 à 11 sur 11
  1. #1
    Futur Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2010
    Messages
    73
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2010
    Messages : 73
    Points : 17
    Points
    17

    Par défaut Fonction suivant/précédent dans champ html via une base

    Bonsoir à tous

    J'explique vite fait mon cas.

    J'ai une table avec des noms et des définitions. Lors que j'entre un nom dans ma barre de saisie, la définition du mot rechercher s'affiche dans un champ html.

    Je cherche le code pour pouvoir allez aux définitions précédentes et suivant qui on été rechercher.

    J'ai tester dans le bouton suivant et dans le bouton précédent:
    Code :
    1
    2
    HTMLNavigue(HTM_HTML1, htmlSuivant)
    HTMLNavigue(HTM_HTML1, htmlPrécédent)
    Mais cela na eu aucun effet. Comment je peu définir c'est paramètres par rapport à la base sans passer au définitions avant ou après se trouvant dans la base mais que ceux qui on été rechercher. Si aucune définition chercher le champ reste en grisé.

    Amicalement

  2. #2
    Futur Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2010
    Messages
    73
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2010
    Messages : 73
    Points : 17
    Points
    17

    Par défaut

    Bonjour à tous

    Personne aurais une petite idée ?

    Amicalement

  3. #3
    Membre expérimenté
    Homme Profil pro
    Inscrit en
    avril 2005
    Messages
    186
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2005
    Messages : 186
    Points : 530
    Points
    530

    Par défaut

    Bonjour,

    A part gérer la liste des définitions recherchées dans une variable tableau et parcourir "manuellement" ce tableau, je ne vois pas trop...

    Cordialement.

  4. #4
    Membre Expert Avatar de miripesage
    Homme Profil pro
    pesage electronique
    Inscrit en
    novembre 2009
    Messages
    709
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Algérie

    Informations professionnelles :
    Activité : pesage electronique
    Secteur : Industrie

    Informations forums :
    Inscription : novembre 2009
    Messages : 709
    Points : 1 094
    Points
    1 094

    Par défaut

    Citation Envoyé par squall049 Voir le message
    Bonsoir à tous

    J'explique vite fait mon cas.

    J'ai une table avec des noms et des définitions. Lors que j'entre un nom dans ma barre de saisie, la définition du mot rechercher s'affiche dans un champ html.

    Je cherche le code pour pouvoir allez aux définitions précédentes et suivant qui on été rechercher.

    J'ai tester dans le bouton suivant et dans le bouton précédent:
    Code :
    1
    2
    HTMLNavigue(HTM_HTML1, htmlSuivant)
    HTMLNavigue(HTM_HTML1, htmlPrécédent)
    Mais cela na eu aucun effet. Comment je peu définir c'est paramètres par rapport à la base sans passer au définitions avant ou après se trouvant dans la base mais que ceux qui on été rechercher. Si aucune définition chercher le champ reste en grisé.

    Amicalement
    Bonjour, ton champ HTML est il relié à une rubrique? Quant tu entre un nom dans la barre de saisie, la définition du mot rechercher s'affiche dans le champ HTML. Quel est ce code ?
    Au travail, le plus difficile, c'est d'allumer la petite lampe du cerveau. Après, ça brûle tout seul!

  5. #5
    Futur Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2010
    Messages
    73
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2010
    Messages : 73
    Points : 17
    Points
    17

    Par défaut

    Bonsoir miripesage

    Non mon champ html n'est pas relié à une rubrique. Pour expliquer simplement j'ai une base "noms" et "définitions"

    Dans ma table les "noms" s'affiche. Si je clique un noms, la définition s'affiche directement dans le champ html.

    Ma table :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    sRepExe est une chaîne 
    SI EnModeTest() ALORS 
    	sRepExe = fRepEnCours()
    SINON
    	sRepExe = Remplace(ExeInfo(exeRépertoire),"\","/")
    FIN
    
    HLitRecherche(Base,Noms,TABLE_Base[TableSelect(TABLE_Base)])
    
    SI HTrouve(Base) ALORS
    	FEN_Accueil..Plan = 2
    	HTM_HTML1=Remplace(Base.Définitions,"*Chemin*",sRepExe+"/Medias")
    FIN
    Mon champ de recherche :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    HLitRecherche(Base,Noms,[TableSelect(TABLE_Base)])
    TableSelectPlus(TABLE_Base,TableCherche(COL_Noms,SansEspace(SAI_Saisie1),Faux))
    
    SI HTrouve(Base) ALORS
    	ExécuteTraitement(TABLE_Base,trtSélection)
    FIN
    
    Recherche()
    La procédure recherche () me sert a envoyer un ..plan = 3 si aucun mot trouver dans la base.

    Dans la base, les définitions sont directement enregistrer en code html se qui me permet d'avoir directement la présentation voulu.

    Amicalement

  6. #6
    Membre Expert Avatar de miripesage
    Homme Profil pro
    pesage electronique
    Inscrit en
    novembre 2009
    Messages
    709
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Algérie

    Informations professionnelles :
    Activité : pesage electronique
    Secteur : Industrie

    Informations forums :
    Inscription : novembre 2009
    Messages : 709
    Points : 1 094
    Points
    1 094

    Par défaut

    Bonjour, pas besoin de "HTMLNavigue"

    BTN_Suivant :
    Code :
    1
    2
    3
    4
    5
    6
    HLitRecherche(Base,Noms,[TableSelect(TABLE_Base)+1])
    TableSelectPlus(TABLE_Base,TableCherche(COL_Noms,SansEspace(SAI_Saisie1),Faux))
    
    SI HTrouve(Base) ALORS
    	ExécuteTraitement(TABLE_Base,trtSélection)
    FIN
    Btn_Précedent
    Code :
    1
    2
    3
    4
    5
    6
    HLitRecherche(Base,Noms,[TableSelect(TABLE_Base)-1])
    TableSelectPlus(TABLE_Base,TableCherche(COL_Noms,SansEspace(SAI_Saisie1),Faux))
    
    SI HTrouve(Base) ALORS
    	ExécuteTraitement(TABLE_Base,trtSélection)
    FIN
    Au travail, le plus difficile, c'est d'allumer la petite lampe du cerveau. Après, ça brûle tout seul!

  7. #7
    Futur Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2010
    Messages
    73
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2010
    Messages : 73
    Points : 17
    Points
    17

    Par défaut

    Bonjour miripesage

    Je viens de tester les 2 bouton et je n'est aucun effets. Rien ne se passe.

    Amicalement

  8. #8
    Membre Expert Avatar de miripesage
    Homme Profil pro
    pesage electronique
    Inscrit en
    novembre 2009
    Messages
    709
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Algérie

    Informations professionnelles :
    Activité : pesage electronique
    Secteur : Industrie

    Informations forums :
    Inscription : novembre 2009
    Messages : 709
    Points : 1 094
    Points
    1 094

    Par défaut

    je n'ai pas bien fait attention à ton "executeTraitement(Table....)"

    BTN_Suivant :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    HLitRecherche(Base,Noms,[TableSelect(TABLE_Base)+1])
    TableSelectPlus(TABLE_Base,TableCherche(COL_Noms,SansEspace(SAI_Saisie1),Faux))
    
    SI HTrouve(Base) ALORS
    	
    sRepExe est une chaîne 
    SI EnModeTest() ALORS 
    	sRepExe = fRepEnCours()
    SINON
    	sRepExe = Remplace(ExeInfo(exeRépertoire),"\","/")
    FIN
    
    
    
    
    	FEN_Accueil..Plan = 2
    	HTM_HTML1=Remplace(Base.Définitions,"*Chemin*",sRepExe+"/Medias")
    FIN
    FIN
    Btn_Précedent
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    HLitRecherche(Base,Noms,[TableSelect(TABLE_Base)-1])
    TableSelectPlus(TABLE_Base,TableCherche(COL_Noms,SansEspace(SAI_Saisie1),Faux))
    
    SI HTrouve(Base) ALORS
    	
    sRepExe est une chaîne 
    SI EnModeTest() ALORS 
    	sRepExe = fRepEnCours()
    SINON
    	sRepExe = Remplace(ExeInfo(exeRépertoire),"\","/")
    FIN
    
    
    
    
    	FEN_Accueil..Plan = 2
    	HTM_HTML1=Remplace(Base.Définitions,"*Chemin*",sRepExe+"/Medias")
    FIN
    FIN
    [/quote]
    Au travail, le plus difficile, c'est d'allumer la petite lampe du cerveau. Après, ça brûle tout seul!

  9. #9
    Nouveau Membre du Club
    Homme Profil pro
    Analyste programmeur
    Inscrit en
    mai 2011
    Messages
    17
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Antarctique

    Informations professionnelles :
    Activité : Analyste programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2011
    Messages : 17
    Points : 39
    Points
    39

    Par défaut

    Bonjour,

    Normal, HTMLNavigue() ne fonctionne correctement qu'avec une connexion, internet ou local..

    Si j'ai bien compris, ce que tu voulais faire c'est quelque chose genre l'aide intégré de Windev, ce qui lui même utilise une connexion locale pour afficher des pages html via des appels comme "wdhlp://......./"... etc

    c'est la propriété "..Valeur" du champs HTML qui est utilisée par les HTMLNavigue() pour stocker l'historique (normalement il sauvegarde l'adresse de la page et non pas son contenu)

    essai d'affecter ton champs HTML comme ceci
    Code :
    HTML..valeur =  Remplace(Base.Définitions,"*Chemin*",sRepExe+"/Medias")
    et tu verra que tes boutons Précédent et Suivant marchent, mais pas avec le contenu souhaité

    autre solution c'est de passer par un tableau temporaire pour stocker les indices des définitions affichées, et de naviguer dans ce tableau via les boutons Suivant et Précédent.

    Voila, 2 pistes a suivre

  10. #10
    Futur Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2010
    Messages
    73
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2010
    Messages : 73
    Points : 17
    Points
    17

    Par défaut

    Bonjour miripesage et channibal

    Je viens de tester et sa gère mal se que je cherche.

    Je vais essayer de voir coté variables qui me stocke mes recherche dans un tableau pour les ressortir par les bouton souhaité.

    Amicalement

  11. #11
    Futur Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2010
    Messages
    73
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2010
    Messages : 73
    Points : 17
    Points
    17

    Par défaut

    Bonjour miripesage et channibal

    Je viens de tester et sa gère mal se que je cherche.

    Je vais essayer de voir coté variables qui me stocke mes recherche dans un tableau pour les ressortir par les boutons souhaité.

    Amicalement

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •