p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Invité
    Invité(e)

    Par défaut Exécution automatique non fonctionnelle

    Bonjour,
    Quand j'insère une clé USB, l’exécution automatique ne se lance pas.
    Pourtant, j'ai fait beaucoup de forum, et j'ai changé les paramètres dans "panneau de configuration/Exécution automatique", j'ai vérifié les deux registres: "NoDriveTypeAutoRun". Et tout est bien programmé.
    Mais ça ne marche pas.
    Qui pourrai m'aider svp ?

    Merci,

  2. #2
    Expert Confirmé Sénior
    Avatar de JML19
    Homme Profil pro
    Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Inscrit en
    décembre 2010
    Messages
    8 624
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corrèze (Limousin)

    Informations professionnelles :
    Activité : Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Secteur : Transports

    Informations forums :
    Inscription : décembre 2010
    Messages : 8 624
    Points : 13 151
    Points
    13 151
    Billets dans le blog
    6

    Par défaut

    Bonjour

    Et lorsque tu mets un CD ou un DVD ?

  3. #3
    Invité
    Invité(e)

    Par défaut

    Une clé Usb/ ou un CD

  4. #4
    Expert Confirmé Sénior
    Avatar de JML19
    Homme Profil pro
    Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Inscrit en
    décembre 2010
    Messages
    8 624
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corrèze (Limousin)

    Informations professionnelles :
    Activité : Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Secteur : Transports

    Informations forums :
    Inscription : décembre 2010
    Messages : 8 624
    Points : 13 151
    Points
    13 151
    Billets dans le blog
    6

    Par défaut

    Donc l'exécution ne fonctionne jamais ?

    Pour quelle fonctionne il faut un fichier autorun sur la clé USB ou le CD.

    Essais ceci AutoRuns (ICI).

  5. #5
    Invité
    Invité(e)

    Par défaut

    Au début, sa marchait, maintenant, non, pourtant j'ai tout vérifié comme j'ai dit au dessus, alors je ne comprends pas, sinon merci pour le logiciel, mais sa ne marche pas, j'ai tout fait (ouvrir ; décompresser; etc) Mais ils disent aussi qu'il est compatible qu'avec windows xp.
    D'ailleurs, sa me fait pareil avec Intel RST (il n'est pas en cours d’exécution) , j'ai cherché mais rien affaire, se sont les 2 "trucs" qui ne marches pas. (seven me dit qu'ils marche correctement)
    Alors, je ne sais pas quoi faire !
    (dans "service" l'exécution est pourtant automatique)

  6. #6
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    janvier 2013
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : janvier 2013
    Messages : 27
    Points : 16
    Points
    16

    Par défaut

    Est ce que Windows a détecté ta clée ou ton CD ?

    Pour voir va dans ordinateur et regarde si ils apparaissent parmi tes périphériques

  7. #7
    Expert Confirmé Sénior

    Inscrit en
    août 2006
    Messages
    3 623
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 3 623
    Points : 4 768
    Points
    4 768

    Par défaut

    Fie,

    C'est plutôt une bonne nouvelle, cette %#@\$£ d'exécution automatique est une des grandes portes d'entrée d'un tas de bestioles malveillantes, et n'aurait jamais dû exister.
    Il court en ce moment une espèce de grippe, mais elle ne court pas très vite, car on peut l'attraper sans courir.

  8. #8
    Invité
    Invité(e)

    Par défaut

    Oui, il détecte tout périphérique, mais à chaque fois je dois aller à "ordinateur". J'ai vu plein de forum, j'ai tout fait ce qu'ils disent (registre, services, exécution automatique, help windows) mais sa ne marche toujours pas !

  9. #9
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    janvier 2013
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : janvier 2013
    Messages : 27
    Points : 16
    Points
    16

    Par défaut Essaye de faire tout ça ...

    Pour lecteur cd ou dvd
    * Faire menu démarrer ,puis exécuter . Dans la fenêtre tapez regedit et OK
    * Aller chercher
    * HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
    * faîtes un clique droit sur Autorun selectionner modifier, passer la valeur 0 à 1
    * Edition de la valeur DWORD entrez la valeur 1 puis OK
    * puis dans la clé : HKEY_CURRENT_USER\Software\Microsoft\Windows\CudrrentVersion\Policies\Explorer\NoDriveTypeAutorun
    * remplacer la valeur héxadécimale95 ou 91selon votre système pour activer la fonction d'exécution automatique
    * faîtes un clique droit sr cette clé et cliquez sur modifier, remplacer la valeur existante par 91 00 00 00(héxadécimale) puis OK
    * si cela ne donne toujours rien, essayer avec la valeur suivante : 95 00 00 00
    * fermez votre éditeur de registre
    * redémarrer pour machine pour que les modifications soient prises en compte

    Pour les ports usb
    Windows - Exécution automatique à l'insertion d'un CD / clé USB
    En temps normal, sous Windows 2000, XP, Vista, 7. une fenêtre s'ouvre automatiquement lors de l'insertion d'un cd, d'un DVD, d'une clé USB ou d'une carte mémoire afin de proposer différentes actions à effectuer ("ouvrir le dossier", "copier avec...", "lire avec,...", "ne rien faire...", etc.).

    Si cette option est désactivée, il est possible de suivre les pistes suivantes :

    1) Sélectionner le lecteur concerné dans le Poste de Travail (par exemple E, faire un clic droit, puis propriété / exécution automatique et cocher "Me demander"

    2) Cliquer Démarrer/Exécuter, puis saisir la commande suivante :
    gpedit.msc

    - Cliquer sur Configuration Ordinateur/Modèles d'administration/Système
    - Double-cliquer sur "Désactiver le lecteur automatique"
    - Vérifier que la valeur par défaut est "Non configuré" ou adaptez la à votre goût.
    - Valider en cliquant sur OK

    Néanmoins, il n'est pas possible par ce biais de désactiver l'option en fonction du type de média.

    3) Editer la base de registre (Démarrer/Exécuter/ regedit), puis chercher les deux valeurs suivantes :
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    NoDriveTypeAutoRun = 0x00000095

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    NoDriveTypeAutoRun = 0x00000095


    La valeur correcte pour chacune de ces clés est 0x00000095

    4) Si aucune des solutions précédentes ne fonctionne, il est possible d'utiliser AutoFix (Windows XP seulement) :
    http://www.microsoft.com/...

  10. #10
    Invité
    Invité(e)

    Par défaut

    Merci beaucoup, mais pour l'USB, quand je fais propriété, il n'y a pas exécution automatique (j'ai regardé de partout)
    Il y a que le changement du registre qui marche, enfin que j'ai trouvé.
    Pour désactivé ... , il n'y été pas, j'ai cherché dans TOUT les dossiers et sous dossiers.
    J'ai changé le registre, mais sa ne marche toujours pas !
    Merci pour votre patience

  11. #11
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    janvier 2013
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : janvier 2013
    Messages : 27
    Points : 16
    Points
    16

    Par défaut

    Et pour le CD ça a marché ?

    Je te dirai vendredi d'autres manipulations à faire pour la clé USB

  12. #12
    Invité
    Invité(e)

    Par défaut

    L'ordinateur n'a pas de CD, car c'est l'ordinateur de La Région. Mais pour ce qui est du registre, j'y suis retourné et il a encore changé en prenant la valeur "ff" et "43" ! J'y pensais une chose, si je prends et le logiciel pour xp, et que je le programme pour windows 7, c'est possible ?

  13. #13
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    janvier 2013
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : janvier 2013
    Messages : 27
    Points : 16
    Points
    16

    Par défaut

    j'ai peut-être trouvé une autre solution :

    Ouvrir le registre (Menu Démarrer-> Exécuter , puis tu tapes regedit ) , puis déployer la la branche :

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\

    Puis laisser une capture d'écran du volet de droite dans ta réponse.

  14. #14
    Invité
    Invité(e)

    Par défaut

    Je pense que la capture a marché
    Images attachées Images attachées  

  15. #15
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    janvier 2013
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : janvier 2013
    Messages : 27
    Points : 16
    Points
    16

    Par défaut

    Le problème ne vient pas non plus de là ...

    Vérifie aussi dans la branche

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USBSTOR

    que la valeur Start a bien comme donnée 0x00000003 (3)

  16. #16
    Invité
    Invité(e)

    Par défaut

    C'est malheureusement la bonne valeur, mais j'ai remarqué que pour l'autre, il change tout le temps, dans la capture, je l'ai remis à 95, sinon il était encore en "ff"

  17. #17
    Invité
    Invité(e)

    Par défaut

    Euh , j'ai capté un truc.
    Dans le registre Users Défaut => NoDriveTypeAutoRun, n'est pas dans Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\

    Mais dans : HKEY_USERS\S-1-5-21-405198665-3630731821-256785810-1001\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\

  18. #18
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    janvier 2013
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : janvier 2013
    Messages : 27
    Points : 16
    Points
    16

    Par défaut

    Je pense pas que ce soit très important, ça doit dépendre des ordinateurs.



    dans le panneau de configuration tu as une icône "Exécution automatique" as tu été voir ici ?
    clic avant sur "affichage classique" sur la gauche.

    et dans l'aide de windows tu as:

    L’Exécution automatique ne démarre pas lorsque j’insère un disque ou branche un périphérique.

    Il y a plusieurs explications à ce problème. La fonctionnalité Lecture automatique est peut-être restreinte par la stratégie de groupe, elle peut être annulée par un programme en cours d’exécution, ou le service que la fonctionnalité Lecture automatique doit démarrer n’est pas en cours d’exécution.

    Voici quelques opérations que vous pouvez tenter :

    Demandez à votre administrateur réseau si l’Exécution automatique est restreinte par la stratégie de groupe, et si tel est le cas, que faire.

    Fermez les autres programmes susceptibles d’interférer en accédant directement au périphérique ou au média.

    Procédez comme suit :

    Cliquez sur le bouton Démarrer , sur Tous les programmes, sur Accessoires, cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu’administrateur. Si vous êtes invité à fournir un mot de passe administrateur ou une confirmation, fournissez le mot de passe ou la confirmation.

    À l’invite de commandes, tapez net start shellhwdetection, puis appuyez sur Entrée.

    Redémarrez votre ordinateur

  19. #19
    Invité
    Invité(e)

    Par défaut

    C'est bon sa marche ! Merci beaucoup pour ton aide et ta patiente

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [XL-2010] Appel d'exécution de plusieurs macros non fonctionnel
    Par capi81 dans le forum Macros et VBA Excel
    Réponses: 2
    Dernier message: 07/06/2015, 15h34
  2. [LabVIEW 8.2] Exécutable non fonctionnel
    Par hackerman dans le forum LabVIEW
    Réponses: 3
    Dernier message: 09/04/2009, 19h54
  3. [REPORTS] Order BY non fonctionnel
    Par sdiack dans le forum Reports
    Réponses: 2
    Dernier message: 10/02/2006, 18h10
  4. Exécution automatique de requete
    Par jfphan dans le forum Access
    Réponses: 1
    Dernier message: 07/02/2006, 12h33
  5. exécution automatique d'une macro
    Par faayy dans le forum Access
    Réponses: 12
    Dernier message: 15/06/2005, 14h52

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo