1. #1
    Membre du Club
    Homme Profil pro
    Inscrit en
    juin 2012
    Messages
    180
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juin 2012
    Messages : 180
    Points : 40
    Points
    40

    Par défaut Utilisation de la fonction http_build_url()

    salut,

    je travail sous windows 7 avec WampServer Version 2.2 qui utilise php5.3.13

    je met mon projet sous www de wamp

    et lors de l'exécution de mon projet cette erreur est affiché
    Fatal error: Call to undefined function http_build_url() in C:\wamp\www
    dans le code de mon projet j'utilise ce syntaxe

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    $url = http_build_url($url);
    je pense que je dois configurer wamp

    merci d'avance

  2. #2
    Expert Confirmé Sénior Avatar de Séb.
    Profil pro
    Inscrit en
    mars 2005
    Messages
    3 224
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations professionnelles :
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2005
    Messages : 3 224
    Points : 4 173
    Points
    4 173

    Par défaut

    Doc de la fonction ( http://fr2.php.net/manual/en/functio...-build-url.php ) :

    (PECL pecl_http >= 0.21.0)
    Il faut activer l'extension HTTP, doit y avoir un menu pour ça quelque part sur WampServer.
    Un problème exposé clairement est déjà à moitié résolu
    Keep It Smart and Simple

  3. #3
    Membre du Club
    Homme Profil pro
    Inscrit en
    juin 2012
    Messages
    180
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juin 2012
    Messages : 180
    Points : 40
    Points
    40

    Par défaut

    merci pour votre réponse,

    en fait j'ai téléchargé pecl-5.2.6-Win32 et j'ai met les fichier .dll sous C:\wamp\bin\php\php5.3.13\ext

    et j'ai ajouter cette ligne dans le fichier php.in
    mais lors de test même erreur est affichée et en plus cette ligne est affichée :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    SCREAM: Error suppression ignored for
    Fatal error: Call to undefined function http_build_url() in C:\wamp\www 
    ...

  4. #4
    Expert Confirmé Sénior Avatar de Séb.
    Profil pro
    Inscrit en
    mars 2005
    Messages
    3 224
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations professionnelles :
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2005
    Messages : 3 224
    Points : 4 173
    Points
    4 173

    Par défaut

    Fais un phpinfo( ) pour vérifier que le module HTTP est bien chargé.
    Un problème exposé clairement est déjà à moitié résolu
    Keep It Smart and Simple

  5. #5
    Membre du Club
    Homme Profil pro
    Inscrit en
    juin 2012
    Messages
    180
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juin 2012
    Messages : 180
    Points : 40
    Points
    40

    Par défaut

    le contenu de fichier phpinfo est :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    <?php
    /* vim: set expandtab sw=4 ts=4 sts=4: */
    /**
     * phpinfo() wrapper to allow displaying only when configured to do so.
     * @package PhpMyAdmin
     */
     
    /**
     * Gets core libraries and defines some variables
     */
    require_once './libraries/common.inc.php';
     
     
    /**
     * Displays PHP information
     */
    if ($GLOBALS['cfg']['ShowPhpInfo']) {
        phpinfo();
    }
    ?>
    l'emplacement de phpinfo est :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    C:\wamp\apps\phpmyadmin3.5.1

  6. #6
    Expert Confirmé Sénior Avatar de Séb.
    Profil pro
    Inscrit en
    mars 2005
    Messages
    3 224
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations professionnelles :
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2005
    Messages : 3 224
    Points : 4 173
    Points
    4 173

    Par défaut

    Hum non. Exécute phpinfo( ) dans une page vierge.

    http://www.php.net/phpinfo
    Un problème exposé clairement est déjà à moitié résolu
    Keep It Smart and Simple

Discussions similaires

  1. [LG]Utilisation de la fonction time
    Par kmitz dans le forum Langage
    Réponses: 4
    Dernier message: 08/04/2005, 13h05
  2. Utilisation de la fonction de déploiement
    Par mchicoix dans le forum XMLRAD
    Réponses: 4
    Dernier message: 01/03/2005, 14h35
  3. [LG]Utilisation de la fonction Random
    Par chloe95 dans le forum Langage
    Réponses: 1
    Dernier message: 01/03/2005, 14h20
  4. Utilisation de la fonction qsort
    Par Jsmeline dans le forum C
    Réponses: 8
    Dernier message: 28/01/2005, 12h40
  5. [LG]librairies : utiliser seulement quelques fonctions
    Par wwwroom dans le forum Langage
    Réponses: 13
    Dernier message: 14/05/2004, 22h50

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo