p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Futur Membre du Club
    Inscrit en
    mars 2009
    Messages
    95
    Détails du profil
    Informations forums :
    Inscription : mars 2009
    Messages : 95
    Points : 17
    Points
    17

    Par défaut Actualisation site web

    Bonjour à tous,
    Je viens vers vous car je n'arrive pas à comprendre le problème.
    J'ai des modifications à faire sur un site internet d'un client.
    Sa page de listing / détail est contenu dans un fichier index.cgi.
    Pour plus de sécurité, j'ai télécharger les fichiers nécessaires afin d'effectuer les modifications sur le fichier en question.
    N'ayant jamais fait de perl aupavant, je suis tout de même parvenu à installer sur wamp le module perl.
    J'ai également réussi à effectuer les modifications demandés et c'est là que le problème survient.

    Je souhaite donc mettre à jour les fichier sur le serveur, mais si je remplace le fichier index.cgi par le nouveau, j'ai une erreur 500 internal server error,
    J'ai donc bien vérifié que le chemin "vers le perl" était identique que l'index original à savoir

    mais cela ne fonctionnait toujours pas.
    Je me suis donc prété au test d'affichage d'un "hello world" et toujours rien

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    #!/usr/bin/perl
     
    print "Content-type: text/html\n\n";
     
    print "Hello, world!\n";
    Pourtant ce code fonctionne en local.

    Dernier test effectué, un copie colle du code contenu dans l'index.cgi original vers un fichier lambda test.cgi.
    Et la surprise, le test.cgi affiche une erreur 500 alors que les code sont identiques o_0

    Je n'ai pas accès au fichier log de server.
    La personne anciennement responsable du site a précisé "que c'est de l'environnement d'utilisation et que si ça plante, le site plante", je suppose qu'il parler du fichier cgi

    Je n'arrive donc pas a comprendre ou l'erreur pourrais provenir, auriez vous une idée ?

  2. #2
    Futur Membre du Club
    Inscrit en
    mars 2009
    Messages
    95
    Détails du profil
    Informations forums :
    Inscription : mars 2009
    Messages : 95
    Points : 17
    Points
    17

    Par défaut

    2 heures pour enfin trouver la solution...
    Les droits d'accès au fichier n'était pas assez fort, en mettant le fichier en 755, cela fonctionne....enfin

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Créer un site web - en quel langage ?
    Par Thierry92 dans le forum Débuter
    Réponses: 90
    Dernier message: 13/04/2015, 14h42
  2. Script php pour actualiser page d'accueil d'un site web
    Par nitro06 dans le forum Général Conception Web
    Réponses: 4
    Dernier message: 31/01/2014, 02h36
  3. Avec quel éditeur concevez-vous vos site web ?
    Par Marc-xhtml dans le forum Outils
    Réponses: 263
    Dernier message: 06/05/2009, 14h43
  4. Actualisation automatique site web
    Par Sparco dans le forum Général Conception Web
    Réponses: 1
    Dernier message: 28/01/2007, 20h08
  5. site web sur le Haskell
    Par ab_sam dans le forum Langages de programmation
    Réponses: 2
    Dernier message: 30/09/2003, 12h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo