1. #1
    Invité de passage
    Inscrit en
    novembre 2012
    Messages
    4
    Détails du profil
    Informations forums :
    Inscription : novembre 2012
    Messages : 4
    Points : 0
    Points
    0

    Par défaut [Axis 2 / Juno] Erreur "java.lang.reflect.InvocationTargetException" utilisation Axis2_Codegen_Wizard_1.3.0

    Bonjour,

    Je souhaiterais générer une classe Java d'un WSDL de Web Service (ici Magento), via le plugin Axis2_Codegen_Wizard_1.3.0.

    Cependant lorsque je clique sur Finish l'erreur s'affiche :
    java.lang.reflect.InvocationTargetException
    Quelqu'un saurait-il m'indiquer d'où peut venir le problème ?

    Malgré mes recherches, je n'ai rien trouvé.

    Merci d'avance pour votre aide.
    Images attachées Images attachées  

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 382
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 382
    Points : 17 753
    Points
    17 753

    Par défaut

    Bonjour,

    As-tu vu ceci http://wso2.org/library/1719#comment-15052 ? Il est question de l'erreur java.lang.reflect.InvocationTargetException à un endroit, donc peut-être cela correspond-il à ton problème...
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  3. #3
    Invité de passage
    Inscrit en
    novembre 2012
    Messages
    4
    Détails du profil
    Informations forums :
    Inscription : novembre 2012
    Messages : 4
    Points : 0
    Points
    0

    Par défaut

    Merci pour ce lien, je l'ai étudié depuis ce matin en installant Apache Ant, Axis2, Maven, et en changeant la version du plugin mais rien y fait, toujours la même erreur.
    Cependant, j'ai essayé avec un autre WSDL que celui de Magento et cela fonctionne.

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo