Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité de passage
    Homme Profil pro Sosuke Jin
    Étudiant
    Inscrit en
    décembre 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Nom : Homme Sosuke Jin
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : décembre 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut Importer un Jar + un dossier image

    Bonjour,

    J'ai un fichier jar qui me sert d'affichage graphique et qui prend en compte un dossier d'images que je peux modifier.

    Sur Linux tout fonctionne parfaitement mais sur Eclipse (Windows), la fenêtre s'affiche mais celle-ci reste vide, comme sur l'image ci-dessous :


    Le chemin que j'ai dans mon dossier est celui-ci:


    Le fichier jar est bien importé car je n'ai aucune erreur dans mon code.
    Sous Linux, s'il est lancé depuis le terminal, il fonctionne parfaitement bien.
    Ce que je n'arrive pas à faire fonctionner est l'affichage des images.

    Quelqu'un saurait-il m'indiquer comment résoudre ce problème ?

    Merci d'avance pour votre aide.
    Images attachées Images attachées

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro Laurent Barbareau
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 242
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Barbareau
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 242
    Points : 14 914
    Points
    14 914

    Par défaut

    Bonjour,

    Le problème est sûrement lié au répertoire de travail. Ton code doit faire référence à un chemin relatif et comme tu n'as pas paramétré le répertoire de travail dans ta configuration d'exécution, celui par défaut ne correspond pas à ce à quoi ton programme s'attend.

    Je te suggère d'externaliser le paramétrage du chemin vers les images, dans un fichier properties par exemple.

    Sinon, c'est simple, il faut adapter le répertoire de travail en allant dans les propriétés du projet, au niveau du menu Run/Debug Settings > nom de ta config, onglet Arguments, paramètre Working directory.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Pensez à cliquer sur le bouton une fois votre problème solutionné, merci.

  3. #3
    Invité de passage
    Homme Profil pro Sosuke Jin
    Étudiant
    Inscrit en
    décembre 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Nom : Homme Sosuke Jin
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : décembre 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut

    Citation Envoyé par Laurent.B Voir le message
    Sinon, c'est simple, il faut adapter le répertoire de travail en allant dans les propriétés du projet, au niveau du menu Run/Debug Settings > nom de ta config, onglet Arguments, paramètre Working directory.
    Bonsoir,
    Merci beaucoup de ton aide, il fallait juste modifier le répertoire du travail comme tu me l'a dit plus haut et tout fonctionne très bien.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •