+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité de passage
    Homme Profil pro
    Étudiant
    Inscrit en
    décembre 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : décembre 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut Importer un Jar + un dossier image

    Bonjour,

    J'ai un fichier jar qui me sert d'affichage graphique et qui prend en compte un dossier d'images que je peux modifier.

    Sur Linux tout fonctionne parfaitement mais sur Eclipse (Windows), la fenêtre s'affiche mais celle-ci reste vide, comme sur l'image ci-dessous :


    Le chemin que j'ai dans mon dossier est celui-ci:


    Le fichier jar est bien importé car je n'ai aucune erreur dans mon code.
    Sous Linux, s'il est lancé depuis le terminal, il fonctionne parfaitement bien.
    Ce que je n'arrive pas à faire fonctionner est l'affichage des images.

    Quelqu'un saurait-il m'indiquer comment résoudre ce problème ?

    Merci d'avance pour votre aide.
    Images attachées Images attachées

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 290
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 290
    Points : 16 816
    Points
    16 816

    Par défaut

    Bonjour,

    Le problème est sûrement lié au répertoire de travail. Ton code doit faire référence à un chemin relatif et comme tu n'as pas paramétré le répertoire de travail dans ta configuration d'exécution, celui par défaut ne correspond pas à ce à quoi ton programme s'attend.

    Je te suggère d'externaliser le paramétrage du chemin vers les images, dans un fichier properties par exemple.

    Sinon, c'est simple, il faut adapter le répertoire de travail en allant dans les propriétés du projet, au niveau du menu Run/Debug Settings > nom de ta config, onglet Arguments, paramètre Working directory.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire dont il nous faut prendre soin en l'alimentant soigneusement, par nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  3. #3
    Invité de passage
    Homme Profil pro
    Étudiant
    Inscrit en
    décembre 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : décembre 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut

    Citation Envoyé par Laurent.B Voir le message
    Sinon, c'est simple, il faut adapter le répertoire de travail en allant dans les propriétés du projet, au niveau du menu Run/Debug Settings > nom de ta config, onglet Arguments, paramètre Working directory.
    Bonsoir,
    Merci beaucoup de ton aide, il fallait juste modifier le répertoire du travail comme tu me l'a dit plus haut et tout fonctionne très bien.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •