p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Nouveau Membre du Club Avatar de zentaf
    Inscrit en
    mars 2007
    Messages
    122
    Détails du profil
    Informations personnelles :
    Âge : 28

    Informations forums :
    Inscription : mars 2007
    Messages : 122
    Points : 34
    Points
    34

    Par défaut Problème syslog dans un module PAM

    Bonjour à tous,

    je suis entrain d'écrire un module pam d'authentification en C, et pour les logs d'erreur j'utilise syslog. Le problème c'est que je ne trouve rien de ces messages quand je fais tail /var/log/syslog !!!

    Pour info, mon module tourne bien et fait le nécessaire sauf pour les logs.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    ...
    # include <syslog.h>
    ...
    syslog(LOG_ERR,"error message");
    ...
    Pour le test, j'ai mis ce même code dans un simple programme C et ça a fonctionné !!! mais sans succès dans le .so

    Merci pour vos réponses.

  2. #2
    Nouveau Membre du Club Avatar de zentaf
    Inscrit en
    mars 2007
    Messages
    122
    Détails du profil
    Informations personnelles :
    Âge : 28

    Informations forums :
    Inscription : mars 2007
    Messages : 122
    Points : 34
    Points
    34

    Par défaut

    toujours pas de réponses !!!
    Les hommes sont des caisses fermées dont la clé est l'épreuve..

  3. #3
    Nouveau Membre du Club Avatar de zentaf
    Inscrit en
    mars 2007
    Messages
    122
    Détails du profil
    Informations personnelles :
    Âge : 28

    Informations forums :
    Inscription : mars 2007
    Messages : 122
    Points : 34
    Points
    34

    Par défaut

    Citation Envoyé par zentaf Voir le message
    toujours pas de réponses !!!
    J'ai besoin de vos contributions svp..
    Les hommes sont des caisses fermées dont la clé est l'épreuve..

Discussions similaires

  1. [OCaml]Problème dans un module: je vois pas..
    Par lucky84 dans le forum Caml
    Réponses: 2
    Dernier message: 21/01/2009, 14h03
  2. Problème de variables dans un module
    Par "Rone" dans le forum Macros et VBA Excel
    Réponses: 17
    Dernier message: 14/10/2008, 11h46
  3. [ez Publish] Problème dans le module de recherche
    Par tamiii dans le forum eZ Publish
    Réponses: 3
    Dernier message: 09/04/2008, 20h13
  4. problème d'écriture dans un module
    Par sebac dans le forum IHM
    Réponses: 2
    Dernier message: 05/07/2007, 17h10
  5. Réponses: 5
    Dernier message: 23/05/2007, 17h48

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo