Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Membre régulier
    Homme Profil pro
    Etudiant
    Inscrit en
    octobre 2011
    Messages
    300
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Etudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2011
    Messages : 300
    Points : 76
    Points
    76

    Par défaut Afficher les projets Index of

    Bonjour à tous,

    J'ai refait mon système et j'installe tout à nouveau, et le problème c'est que je n'arrive pas à afficher la liste de mes projets sur localhost, j'ai essayé d'ajouter

    Code :
    1
    2
    3
    4
    <Directory /var/www/>
    Options Indexes FollowSymLinks
    </Directory>
    dans le fichier /etc/apache2/apache2.conf
    mais sa donne rien.

    Je suis sous Ubuntu.

    Merci d'avance

  2. #2
    Rédacteur/Modérateur
    Avatar de _Mac_
    Inscrit en
    août 2005
    Messages
    9 417
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 9 417
    Points : 10 972
    Points
    10 972

    Par défaut

    Visiblement, tu es sur une installation de type Debian, donc la configuration que tu as faite, il faut plutôt la placer dans le bon hôte virtuel, i.e. dans un des fichiers linkés dans /etc/apache2/sites-enabled.

    Du détail, du détail, du détail !!!
    Revenons à la source : lisons la documentation et les fichiers de trace, la réponse à notre problème s'y trouve sans doute

  3. #3
    Membre régulier
    Homme Profil pro
    Etudiant
    Inscrit en
    octobre 2011
    Messages
    300
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Etudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2011
    Messages : 300
    Points : 76
    Points
    76

    Par défaut

    Citation Envoyé par _Mac_ Voir le message
    Visiblement, tu es sur une installation de type Debian, donc la configuration que tu as faite, il faut plutôt la placer dans le bon hôte virtuel, i.e. dans un des fichiers linkés dans /etc/apache2/sites-enabled.
    Voilà le contenu du fichier default du répertoire site-enabled

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    
    	DocumentRoot /var/www
    	<Directory />
    		Options FollowSymLinks
    		AllowOverride None
    	</Directory>
    	<Directory /var/www/>
    		Options Indexes FollowSymLinks MultiViews
    		AllowOverride None
    		Order allow,deny
    		allow from all
    	</Directory>
    
    	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    	<Directory "/usr/lib/cgi-bin">
    		AllowOverride None
    		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    		Order allow,deny
    		Allow from all
    	</Directory>
    
    	ErrorLog ${APACHE_LOG_DIR}/error.log
    
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
    
    	CustomLog ${APACHE_LOG_DIR}/access.log combined
    	
    </VirtualHost>
    et pour le fichier hosts du répertoire /etc

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    127.0.0.1	localhost.localdomain localhost mamachine
    #127.0.1.1	mamachine
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    c'est dont ça que vous parliez

  4. #4
    Rédacteur/Modérateur
    Avatar de _Mac_
    Inscrit en
    août 2005
    Messages
    9 417
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 9 417
    Points : 10 972
    Points
    10 972

    Par défaut

    Ca semble correct, donc je ne comprends pas trop le problème. 2 idées :
    • Retire le / à la fin du chemin du répertoire dans <Directory> : <Directory /var/www>
    • Regarde dans le répertoire /var/www s'il y a un fichier .htaccess : dans ce fichier, il se pourrait qu'il y ait Options -Indexes

    Du détail, du détail, du détail !!!
    Revenons à la source : lisons la documentation et les fichiers de trace, la réponse à notre problème s'y trouve sans doute

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •