Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Membre actif
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    691
    Détails du profil
    Informations personnelles :
    Localisation : France, Seine Maritime (Haute Normandie)

    Informations forums :
    Inscription : décembre 2007
    Messages : 691
    Points : 150
    Points
    150

    Par défaut Remplacer RouteLink en framework 4.5

    Bonjour,

    J'essaie de réaliser un site web avec un système de localisation. Je suis ce très bon tutoriel de Hinault Romaric DONFACK.

    Cependant j'ai un petit problème avec cette fontion :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    public static MvcHtmlString LanguageSelectorLink(this HtmlHelper helper,
               string cultureName, string selectedText, string unselectedText,
               IDictionary htmlAttributes, string languageRouteName = "lang", bool strictSelected = false)
            {
                var language = helper.LanguageUrl(cultureName, languageRouteName, strictSelected);
                var link = helper.RouteLink(language.IsSelected ? selectedText : unselectedText,
                    "LocalizedDefault", language.RouteValues);
                return link;
            }
    Je suis en framework 4.5, mvc 4.
    La fonction "RouteLink" n'est pas accessible. Que puis-je faire ?

    Merci.

  2. #2
    Membre actif
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    691
    Détails du profil
    Informations personnelles :
    Localisation : France, Seine Maritime (Haute Normandie)

    Informations forums :
    Inscription : décembre 2007
    Messages : 691
    Points : 150
    Points
    150

    Par défaut

    c'est ma faute, j'ai oublié un using. Dsl.

  3. #3
    Invité de passage
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2010
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : août 2010
    Messages : 1
    Points : 1
    Points
    1

    Par défaut

    Citation Envoyé par thor76160 Voir le message
    c'est ma faute, j'ai oublié un using. Dsl.
    J'ai eu le même problème. Le using à déclarer est le suivant :
    using System.Web.Mvc.Html;

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •