Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Futur Membre du Club
    Profil pro Fred GIROD
    Inscrit en
    mars 2010
    Messages
    28
    Détails du profil
    Informations personnelles :
    Nom : Fred GIROD

    Informations forums :
    Inscription : mars 2010
    Messages : 28
    Points : 15
    Points
    15

    Par défaut Le service wampapache ne démarre pas avec les drivers de sql serveur

    Bonjour,

    J'ai installé Wamp serveur 2.2-php5.4.3-httpd2.2.22-mysql5.5.24-32b.

    Comme recommandé sur la plupart des forums je cherche à utiliser les drivers SQL serveur fournis par microsoft ici http://www.microsoft.com/en-us/downl....aspx?id=20098 que j'ai bien installé sous C:\wamp\bin\php\php5.4.3\ext.

    J'ai lu également qu'il était nécessaire d'installer la ntwdblib.dll sous les répertoires C:\wamp\bin\php\php5.4.3 ainsi que C:\wamp\bin\apache\apache2.2.22\bin

    Mais lorsque j'active les extensions php_pdo_sqlsrv_53_ts_vc9.dll ou php_sqlsrv_53_ts_vc9.dll correspondant à ma version php compilée (voir 2eme poste), eh bien mon serveur apache ne démarre plus => Icone Wamp orange, service wampapache en état Démarrage et je n'ai aucun message dans le Apache error log, j'ai juste un message systeme dans l'observatoire windows Le service wampapache s'est terminé de façon inattendue pour la 15ème fois.

    Je vous remercie d'avance pour toute aide précieuse

  2. #2
    Futur Membre du Club
    Profil pro Fred GIROD
    Inscrit en
    mars 2010
    Messages
    28
    Détails du profil
    Informations personnelles :
    Nom : Fred GIROD

    Informations forums :
    Inscription : mars 2010
    Messages : 28
    Points : 15
    Points
    15

    Par défaut Version PHP

    De nouveau bonjour,

    Alors voilà... tu cherches la solution pendant des jours, tu testes milles choses... et c'est le jour où tu postes un appel à l'aide que tu trouves la solution... désolé.

    Alors voici d'où venait visiblement mon problème : les extensions php_pdo_sqlsrv_53_ts_vc9 et php_sqlsrv_53_ts_vc9 sont prévues pour PHP 5.3 comme il est dit dans le nom... bien sur que je le savais... mais de là à ne pas fonctionner avec PHP 5.4 rrrrrrr....

    Bref j'ai réinstallé WAMP avec PHP 5.3 et ca fonctionne.

    Par contre j'ai cherché s'il existait les mêmes drivers pour PHP 5.4, effectivement ils existent dans le package SQLSRV30 or celui ci semble prévu pour 64bit...

    Celà voudrait il dire que l'on ne peut faire fonctionner PHP 5.4 avec ces drivers que sous du windows 64 bits ???? il me semble...

    A suivre si d'autres personnes ont des infos....

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •