+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Membre régulier Avatar de ziad.shady
    Homme Profil pro
    Inscrit en
    mai 2008
    Messages
    201
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 29
    Localisation : France, Hauts de Seine (Île de France)

    Informations forums :
    Inscription : mai 2008
    Messages : 201
    Points : 92
    Points
    92

    Par défaut Problème mémoire Eclipe Juno

    Bonjour,

    J'ai installé Eclipse Juno afin de l'essayer, et je me retrouve avec ces deux soucis:
    1. Une pop-up indique que Maven doit tourner avec un JDK alors qu'actuellement il tourne avec un JRE (voir pj_1).
    2. J'ai fait un checkout d'un projet depuis SVN, dès que je double-clique un fichier, Eclipse rame, ne répond plus et mon processeur tourne bruyamment.

    Voici le contenu de mon fichier eclipse.ini :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    -startup plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
    --launcher.library plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20120522-1813
    -product org.eclipse.epp.package.jee.product
    --launcher.defaultAction openFile
    -showsplash org.eclipse.platform
    --launcher.defaultAction openFile
    -Dosgi.requiredJavaVersion=1.5
    -Dhelp.lucene.tokenizer=standard
    --launcher.XXMaxPermSize 256m
    -Xms256m
    -Xmx1024m
    -vm D:\developpemen\MyDev\Java\jdk1.6.0\bin\javaw.exe
    -vmargs
    Ma machine contient 2Go RAM.

    1. Concernant le 1er point, est-ce que l'attribut "vm" n'est pas suffisant pour définir le chemin vers le JDK ?
    2. Concernant le 2ème point, est-ce qu'il manque un attribut de configuration dans mon eclipse.ini afin d'augmenter la mémoire requise ?
    Est-ce que la version Juno d'Eclipse demande plus de RAM que ce que j'ai dans ma machine ?

    Merci d'avance pour vos réponse.
    Images attachées Images attachées

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 290
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 290
    Points : 16 911
    Points
    16 911

    Par défaut

    Bonjour,

    Le fichier eclipse.ini est un fichier de configuration très tatillon, qui n'autorise pas beaucoup les mises en forme personnelles...

    Cf. http://eclipse.developpez.com/faq/?p...eform#autreJDK

    L'ordre et la façon d'indiquer les arguments est donc très important, surtout pour la vm et les vmargs.

    A ma connaissance, Juno n'a rien de particulier par rapport à ses prédécesseurs à ce niveau-là.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire dont il nous faut prendre soin en l'alimentant soigneusement, par nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  3. #3
    Membre régulier Avatar de ziad.shady
    Homme Profil pro
    Inscrit en
    mai 2008
    Messages
    201
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 29
    Localisation : France, Hauts de Seine (Île de France)

    Informations forums :
    Inscription : mai 2008
    Messages : 201
    Points : 92
    Points
    92

    Par défaut

    Mr Laurent,
    Merci beaucoup de votre réponse.
    Effectivement cela a été dû à la mise en forme que j'ai apporté au fichier eclipse.ini.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •