+ Répondre à la discussion
Page 1 sur 2 12 DernièreDernière
Affichage des résultats 1 à 20 sur 26

Discussion: Connexion BD

  1. #1
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut Connexion BD

    bonsoir
    je suis en train de développer une application java (sous eclipse ) avec une base de donnée (MySQl)
    bon , avant d'exécuter la requete j'ai voulu tester la connexion à cette base de donnée avec le code suivant

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    // Connexion à la base 
     try
    		   {Class.forName("com.mysql.jdbc.Driver");
    		    connect = DriverManager.getConnection("jdbc:mysql://localhost/g_r_h","","");
    		      System.out.println("Connexion établie !!!! ");   }      
     
    		   	catch (Exception e1)
    		   	{System.err.print("Erreur"+ e1.getMessage());}  }
    mais , il ne peut pas connecter à cette base , et voilà le message d'erreur qui apparaît :

    Code :
    1
    2
    3
    4
     
    Erreur Communications link failure
     
    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    j'ai pas compris ce problème !?? sachant que j'ai installer le driver JDBC dans la bibliothèque

    voilà comment j'ai ajouter le driver dans la bibliothèque :

    project --> properties --> java Build Path --> librairies --> add externels Jars --> mysql-connector-java-5.1.22-bin-jar (le driver JBDC )

    Quelle est la solution selon vous !!?? et merci

  2. #2
    Membre éclairé
    Homme Profil pro
    Inscrit en
    octobre 2011
    Messages
    204
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : octobre 2011
    Messages : 204
    Points : 317
    Points
    317

    Par défaut

    Il y a plusieurs causes possibles comme le fait que ton serveur écoute sur l'adresse 127.0.0.1 et pas sur localhost.
    Peux-tu faire un e1.printStackTrace() dans ton catch, tu aurais plus de détails.

  3. #3
    Modérateur
    Avatar de wax78
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2006
    Messages
    2 685
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Belgique

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2006
    Messages : 2 685
    Points : 5 109
    Points
    5 109

    Par défaut

    Citation Envoyé par NoClassDefFound Voir le message
    Il y a plusieurs causes possibles comme le fait que ton serveur écoute sur l'adresse 127.0.0.1 et pas sur localhost.
    Cela dit en passant : 127.0.0.1=localhost ou ::1 en ipv6 , du moins en général.

    Mais sinon au pire mettre 127.0.0.1 a la place de localhost au cas ou le système n'aurait pas localhost bien assigné.

  4. #4
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    avec le system.err.print(e1.printStackTrace()); , il y avait une erreur de syntaxe sur le .print (aussi sur le println)

  5. #5
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro
    Responsable de service informatique
    Inscrit en
    avril 2007
    Messages
    21 890
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 21 890
    Points : 41 481
    Points
    41 481

    Par défaut

    Citation Envoyé par NoClassDefFound Voir le message
    Il y a plusieurs causes possibles comme le fait que ton serveur écoute sur l'adresse 127.0.0.1 et pas sur localhost.
    localhost c'est 127.0.0.1
    La cause la plus probable est que mysql n'écoute pas sur le port réseau, voir dans la config mysql si sa couche réseau est active.
    Tchize (Чиз) faq java, cours java, javadoc. Pensez à et

  6. #6
    Modérateur
    Avatar de wax78
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2006
    Messages
    2 685
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Belgique

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2006
    Messages : 2 685
    Points : 5 109
    Points
    5 109

    Par défaut

    Citation Envoyé par zied_m Voir le message
    avec le system.err.print(e1.printStackTrace()); , il y avait une erreur de syntaxe sur le .print (aussi sur le println)
    Logique c'est avec S majuscule System :

    Code :
    System.err.print(e); // e étant ton exception
    sans mettre qui en fait fait la même chose que le code ci joint.

  7. #7
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    pardon , mais comment je le trouve ce config mysql !!!
    et merci

  8. #8
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    Citation Envoyé par wax78 Voir le message
    Logique c'est avec S majuscule System :

    Code :
    System.err.print(e); // e étant ton exception
    sans mettre qui en fait fait la même chose que le code ci joint.
    même erreur que toute à l'heure
    cette exception n'a rien ajouter

  9. #9
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro
    Responsable de service informatique
    Inscrit en
    avril 2007
    Messages
    21 890
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 21 890
    Points : 41 481
    Points
    41 481

    Par défaut

    Citation Envoyé par zied_m Voir le message
    pardon , mais comment je le trouve ce config mysql !!!
    et merci
    dans la

    et documentation officielle mysql

    http://dev.mysql.com/doc/refman/5.0/...ion-files.html
    Tchize (Чиз) faq java, cours java, javadoc. Pensez à et

  10. #10
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    Citation Envoyé par tchize_ Voir le message
    malheureusement , ça ne marche pas

  11. #11
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro
    Responsable de service informatique
    Inscrit en
    avril 2007
    Messages
    21 890
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 21 890
    Points : 41 481
    Points
    41 481

    Par défaut

    Montre ton fichier de config.
    Tchize (Чиз) faq java, cours java, javadoc. Pensez à et

  12. #12
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    Citation Envoyé par tchize_ Voir le message
    Montre ton fichier de config.
    le Contenu du fichier my.ini

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    129
    130
    131
    132
    133
    134
    135
    136
    137
    138
    139
    140
    141
    142
    143
    144
    145
    146
    147
    148
    149
    150
    151
    152
    153
    154
    155
    156
    157
    158
    159
    160
    161
    162
    163
    164
     
    # Example MySQL config file for medium systems.
    #
    # This is for a system with little memory (32M - 64M) where MySQL plays
    # an important part, or systems up to 128M where MySQL is used together with
    # other programs (such as a web server)
    #
    # You can copy this file to
    # /etc/my.cnf to set global options,
    # mysql-data-dir/my.cnf to set server-specific options (in this
    # installation this directory is C:\mysql\data) or
    # ~/.my.cnf to set user-specific options.
    #
    # In this file, you can use all long options that a program supports.
    # If you want to know which options a program supports, run the program
    # with the "--help" option.
     
    # The following options will be passed to all MySQL clients
    [client]
    #password	= your_password
    port		= 3306
    socket		= /tmp/mysql.sock
     
    # Here follows entries for some specific programs
     
    # The MySQL server
    [wampmysqld]
    port		= 3306
    socket		= /tmp/mysql.sock
    key_buffer = 16M
    max_allowed_packet = 1M
    table_cache = 64
    sort_buffer_size = 512K
    net_buffer_length = 8K
    read_buffer_size = 256K
    read_rnd_buffer_size = 512K
    myisam_sort_buffer_size = 8M
    basedir=E:/wamp/bin/mysql/mysql5.5.24
    log-error=E:/wamp/logs/mysql.log
    datadir=E:/wamp/bin/mysql/mysql5.5.24/data
     
    # Don't listen on a TCP/IP port at all. This can be a security enhancement,
    # if all processes that need to connect to mysqld run on the same host.
    # All interaction with mysqld must be made via Unix sockets or named pipes.
    # Note that using this option without enabling named pipes on Windows
    # (via the "enable-named-pipe" option) will render mysqld useless!
    # 
    skip-networking
     
    # Disable Federated by default
    #skip-federated
     
    # Replication Master Server (default)
    # binary logging is required for replication
    log-bin=mysql-bin
     
    # binary logging format - mixed recommended
    binlog_format=mixed
     
    # required unique id between 1 and 2^32 - 1
    # defaults to 1 if master-host is not set
    # but will not function as a master if omitted
    server-id	= 1
     
    # Replication Slave (comment out master section to use this)
    #
    # To configure this host as a replication slave, you can choose between
    # two methods :
    #
    # 1) Use the CHANGE MASTER TO command (fully described in our manual) -
    #    the syntax is:
    #
    #    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
    #    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
    #
    #    where you replace <host>, <user>, <password> by quoted strings and
    #    <port> by the master's port number (3306 by default).
    #
    #    Example:
    #
    #    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
    #    MASTER_USER='joe', MASTER_PASSWORD='secret';
    #
    # OR
    #
    # 2) Set the variables below. However, in case you choose this method, then
    #    start replication for the first time (even unsuccessfully, for example
    #    if you mistyped the password in master-password and the slave fails to
    #    connect), the slave will create a master.info file, and any later
    #    change in this file to the variables' values below will be ignored and
    #    overridden by the content of the master.info file, unless you shutdown
    #    the slave server, delete master.info and restart the slaver server.
    #    For that reason, you may want to leave the lines below untouched
    #    (commented) and instead use CHANGE MASTER TO (see above)
    #
    # required unique id between 2 and 2^32 - 1
    # (and different from the master)
    # defaults to 2 if master-host is set
    # but will not function as a slave if omitted
    #server-id       = 2
    #
    # The replication master for this slave - required
    #master-host     =   <hostname>
    #
    # The username the slave will use for authentication when connecting
    # to the master - required
    #master-user     =   <username>
    #
    # The password the slave will authenticate with when connecting to
    # the master - required
    #master-password =   <password>
    #
    # The port the master is listening on.
    # optional - defaults to 3306
    #master-port     =  <port>
    #
    # binary logging - not required for slaves, but recommended
    #log-bin=mysql-bin
     
    # Point the following paths to different dedicated disks
    #tmpdir		= /tmp/		
    #log-update 	= /path-to-dedicated-directory/hostname
     
    # Uncomment the following if you are using InnoDB tables
    #innodb_data_home_dir = C:\mysql\data/
    #innodb_data_file_path = ibdata1:10M:autoextend
    #innodb_log_group_home_dir = C:\mysql\data/
    #innodb_log_arch_dir = C:\mysql\data/
    # You can set .._buffer_pool_size up to 50 - 80 %
    # of RAM but beware of setting memory usage too high
    #innodb_buffer_pool_size = 16M
    #innodb_additional_mem_pool_size = 2M
    # Set .._log_file_size to 25 % of buffer pool size
    #innodb_log_file_size = 5M
    #innodb_log_buffer_size = 8M
    #innodb_flush_log_at_trx_commit = 1
    #innodb_lock_wait_timeout = 50
     
    [mysqldump]
    quick
    max_allowed_packet = 16M
     
    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates
     
    [isamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M
     
    [myisamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M
     
    [mysqlhotcopy]
    interactive-timeout
     
    [mysqld]
    port=3306

  13. #13
    Modérateur
    Avatar de wax78
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2006
    Messages
    2 685
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Belgique

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2006
    Messages : 2 685
    Points : 5 109
    Points
    5 109

    Par défaut

    A première vue, skip-networking semble activé, donc on en revient a ce que tchize a suggeré,.

  14. #14
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    Citation Envoyé par wax78 Voir le message
    A première vue, skip-networking semble activé, donc on en revient a ce que tchize a suggeré,.
    j'ai désactivé le skip-networking

    en plus , dans le document où monsieur tchize m'a donné , il s'est écrit :
    Code :
    Désactivez également l'option bind-address 127.0.0.1.
    je ne savais pas comment la désactiver ,dans le fichier de configuration j'ai trouvé ce bind-address

  15. #15
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro
    Responsable de service informatique
    Inscrit en
    avril 2007
    Messages
    21 890
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 21 890
    Points : 41 481
    Points
    41 481

    Par défaut

    Citation Envoyé par zied_m Voir le message
    j'ai désactivé le skip-networking
    Pas dans ce que tu nous montre en tout cas
    en plus , dans le document où monsieur tchize m'a donné , il s'est écrit :
    Code :
    Désactivez également l'option bind-address 127.0.0.1.
    Ca, c'est uniquement si ton client et le serveur sont sur des machines différentes. De toutes façons comme cette ligne n'existe pas dans ton fichier, c'est désactivé
    Tchize (Чиз) faq java, cours java, javadoc. Pensez à et

  16. #16
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    Citation Envoyé par tchize_ Voir le message
    Pas dans ce que tu nous montre en tout cas

    Ca, c'est uniquement si ton client et le serveur sont sur des machines différentes. De toutes façons comme cette ligne n'existe pas dans ton fichier, c'est désactivé
    oui , j'ai désactivé le skip-networking en mettant un #

    et alors quelle est la solution !!!?

  17. #17
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro
    Responsable de service informatique
    Inscrit en
    avril 2007
    Messages
    21 890
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 21 890
    Points : 41 481
    Points
    41 481

    Par défaut

    et bien, tu désactive le skip networking, comme on te la dit, tu redémarre ton serveur sql et tu nous donne ton nouveau message d'erreur.
    Tchize (Чиз) faq java, cours java, javadoc. Pensez à et

  18. #18
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    Citation Envoyé par tchize_ Voir le message
    et bien, tu désactive le skip networking, comme on te la dit, tu redémarre ton serveur sql et tu nous donne ton nouveau message d'erreur.
    le message d'erreur ,c'est : Erreur com.mysql.jdbc.driver

  19. #19
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro
    Responsable de service informatique
    Inscrit en
    avril 2007
    Messages
    21 890
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 21 890
    Points : 41 481
    Points
    41 481

    Par défaut

    affiche le message complet (e1.printStackTrace());
    Tchize (Чиз) faq java, cours java, javadoc. Pensez à et

  20. #20
    Invité de passage
    Inscrit en
    décembre 2010
    Messages
    78
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 78
    Points : 1
    Points
    1

    Par défaut

    Citation Envoyé par tchize_ Voir le message
    affiche le message complet (e1.printStackTrace());
    lorsque j'utilise e1.printStackTrace()
    (system.err.print(e1.printStackTrace()); , il m'affiche un message d'erreur au niveau du println ou print
    voilà le message :

    Code :
    The method println(boolean) in the type PrintStream is not applicable for the arguments (void)
    mais lorsque j'utilise uniquement e1.printStackTrace() ; il m'affiche cette erreur
    Code :
    java.lang.ClassNotFoundException: com.mysql.jdbc.driver

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •