Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 5 sur 5
  1. #1
    Invité régulier
    Profil pro kiki kiki
    Inscrit en
    octobre 2009
    Messages
    20
    Détails du profil
    Informations personnelles :
    Nom : kiki kiki

    Informations forums :
    Inscription : octobre 2009
    Messages : 20
    Points : 7
    Points
    7

    Par défaut Probème <listener-class> web.xml

    Salut,
    Je suis entrain d'écrire une application web avec JEE et j'ai un problème que je n'arrive pas a comprendre.
    Tout marche bien, jusqu'a ce que je crée une classe listener pour les DB
    Et quant j'ajoute a web.xm. comme ceci:
    Code :
    1
    2
    3
    <listener>
       <listener-class>config.InitialisationDaoFactory</listener-class>
    </listener>
    L'application n'est plus accessible
    Si je regarde dans Tomcat, je vois que la valeur est mise a false sur run
    Quelqu'un a une idée?
    Merci

  2. #2
    Membre Expert
    Homme Profil pro Mathieu
    Ingénieur développement logiciels
    Inscrit en
    avril 2004
    Messages
    1 181
    Détails du profil
    Informations personnelles :
    Nom : Homme Mathieu
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : avril 2004
    Messages : 1 181
    Points : 1 674
    Points
    1 674

    Par défaut

    Bonjours,
    2 points à vérifier :
    - La classe config.InitialisationDaoFactory est dans le classpath
    - La classe config.InitialisationDaoFactory implémente la bonne interface

    Tu dois avoir une trace dans les logs de ton serveur qui t'indique quel est le problème.

  3. #3
    Invité régulier
    Profil pro kiki kiki
    Inscrit en
    octobre 2009
    Messages
    20
    Détails du profil
    Informations personnelles :
    Nom : kiki kiki

    Informations forums :
    Inscription : octobre 2009
    Messages : 20
    Points : 7
    Points
    7

    Par défaut

    Merci Moderateur,
    J'ai verifie la class est dans le path
    et elle implement ServletContextListener
    Dans les log je trouve a rien
    Toujours au meme point
    Merci

  4. #4
    Expert Confirmé Sénior
    Avatar de tchize_
    Homme Profil pro
    Responsable de service informatique
    Inscrit en
    avril 2007
    Messages
    21 220
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 21 220
    Points : 34 913
    Points
    34 913

    Par défaut

    Si il n'y a rien, c'est que tu ne regarde pas où il faut, c'est très verbeux un tomcat au démarrage
    Tchize (Чиз) faq java, cours java, javadoc. Pensez à et
    Laisse entrer le jour après une nuit sombre. Si tu es toujours là, tu n'es pas faite pour mourir.

  5. #5
    Invité régulier
    Profil pro kiki kiki
    Inscrit en
    octobre 2009
    Messages
    20
    Détails du profil
    Informations personnelles :
    Nom : kiki kiki

    Informations forums :
    Inscription : octobre 2009
    Messages : 20
    Points : 7
    Points
    7

    Par défaut

    Vous avez raison Mr le Modérateur
    J'ai trouve, c'est la classe listener qui ne trouve pas les donnes parce que le fichier indiqué n'est pas le bon. Du coup ca bloque toute l'application
    Merci

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •