+ Répondre à la discussion
Affichage des résultats 1 à 5 sur 5
  1. #1
    Futur Membre du Club
    Profil pro
    Inscrit en
    juin 2007
    Messages
    55
    Détails du profil
    Informations personnelles :
    Âge : 26
    Localisation : Maroc

    Informations forums :
    Inscription : juin 2007
    Messages : 55
    Points : 17
    Points
    17

    Par défaut Authentification SSL JBoss 7.1

    Bonjour,
    Je souhaite ajouter une authentification SSL pour ma web-app.
    J'ai modifié le fichier standalone.xml de jboss, en ajoutant le connector https comme suit:
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false">
                <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
                <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true">
                    <ssl name="ssl" password="mdp" certificate-key-file="C:\Users\Administrator\Desktop\jboss-as-7.1.1.Final\standalone\configuration\test.keystore" protocol="TLSv1" verify-client="true" ca-certificate-file="C:\Users\Administrator\Desktop\jboss-as-7.1.1.Final\standalone\configuration\test.keystore"/>
                </connector>
                <virtual-server name="default-host" enable-welcome-root="true">
                    <alias name="localhost"/>
                    <alias name="example.com"/>
                </virtual-server>
            </subsystem>
    Sachant que j'ai créé le test.keystore à l'aide de l'outil Keytool.
    Jboss démarre sans problème, mais quand j'essaye d'accéder à l'appli via le https, un certificat m'est demandé.
    Je voulais savoir ce qui me manque? comment pourrais-je générer ce certificat pour l'ajouter dans le navigateur?

    Merci d'avance.

  2. #2
    Invité régulier
    Inscrit en
    mai 2005
    Messages
    14
    Détails du profil
    Informations forums :
    Inscription : mai 2005
    Messages : 14
    Points : 5
    Points
    5

    Par défaut

    La question est un peu ancienne, mais bon on sait jamais...
    Essaye avec verify-client="false" au lieu de "true", dans ce cas un certificat client ne sera pas nécessaire.

    Citation Envoyé par miss_poopoucy Voir le message
    Bonjour,
    Je souhaite ajouter une authentification SSL pour ma web-app.
    J'ai modifié le fichier standalone.xml de jboss, en ajoutant le connector https comme suit:
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false">
                <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
                <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true">
                    <ssl name="ssl" password="mdp" certificate-key-file="C:\Users\Administrator\Desktop\jboss-as-7.1.1.Final\standalone\configuration\test.keystore" protocol="TLSv1" verify-client="true" ca-certificate-file="C:\Users\Administrator\Desktop\jboss-as-7.1.1.Final\standalone\configuration\test.keystore"/>
                </connector>
                <virtual-server name="default-host" enable-welcome-root="true">
                    <alias name="localhost"/>
                    <alias name="example.com"/>
                </virtual-server>
            </subsystem>
    Sachant que j'ai créé le test.keystore à l'aide de l'outil Keytool.
    Jboss démarre sans problème, mais quand j'essaye d'accéder à l'appli via le https, un certificat m'est demandé.
    Je voulais savoir ce qui me manque? comment pourrais-je générer ce certificat pour l'ajouter dans le navigateur?

    Merci d'avance.

  3. #3
    Membre éprouvé
    Inscrit en
    juin 2007
    Messages
    383
    Détails du profil
    Informations forums :
    Inscription : juin 2007
    Messages : 383
    Points : 462
    Points
    462

    Par défaut

    En tout cas avec un certificat auto-signé il est normal d'avoir un message de warning dans le navigateur. Il faut ignorer ce message en sélectionnant "Je comprends les risques".
    Consultant freelance expert Java EE

  4. #4
    Nouveau Membre du Club Avatar de Mednet
    Homme Profil pro
    Consultant informatique
    Inscrit en
    juillet 2011
    Messages
    53
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2011
    Messages : 53
    Points : 38
    Points
    38

    Par défaut

    Héy miss_poopoucy,

    Je pense que vous devez importer ton certificat sous ton navigateur :

    Sous Firefox :

    Outils > Options > Avancé > Chiffrement > Afficher les certificats > Importer

    Bonne journée,

  5. #5
    Nouveau Membre du Club Avatar de Mednet
    Homme Profil pro
    Consultant informatique
    Inscrit en
    juillet 2011
    Messages
    53
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2011
    Messages : 53
    Points : 38
    Points
    38

    Par défaut

    Je pense que ce lien vous serez d'une grande utilité
    http://ictpourtous.com/fr/tech/soft/...signed-and-ca/

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •