+ Répondre à la discussion
Affichage des résultats 1 à 5 sur 5
  1. #1
    Invité de passage
    Inscrit en
    décembre 2005
    Messages
    4
    Détails du profil
    Informations forums :
    Inscription : décembre 2005
    Messages : 4
    Points : 1
    Points
    1

    Par défaut lancer un .exe sur le serveur depuis wamp

    Bonjour.

    Je suis sur windows 7 x64

    Je cherche à lancer un fichier .exe (notepad par exemple) sur le serveur depuis un script php.

    Seul problème à la place c'est une notification qui se lance disant qu'un programme requiert mon attention ...

    y aurait il moyen de lancer cet exe sur la session graphique courante ?

    Merci ^^

  2. #2
    Modérateur
    Avatar de sabotage
    Homme Profil pro
    Inscrit en
    juillet 2005
    Messages
    21 577
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2005
    Messages : 21 577
    Points : 31 445
    Points
    31 445

    Par défaut

    Je viens de faire le test
    Code :
    exec('c:\windows\system32\notepad.exe');
    et j'obtiens bien une fenêtre notepad (même si l'interet de le faire est douteux).

  3. #3
    Invité de passage
    Inscrit en
    décembre 2005
    Messages
    4
    Détails du profil
    Informations forums :
    Inscription : décembre 2005
    Messages : 4
    Points : 1
    Points
    1

    Par défaut

    Alors la configuration que tu as pour ton wamp m'intéresse
    (ou pour ton windows remarque ^^)

    En effet moi quand je fais ça, ça me lance un notepad + un cmd + un conhost

    si je modifie services.msc et que je mets "autoriser à interagir avec le bureau" j'ai cette fenêtre


    ça aurait quelque chose à voir avec le fait que c'est un windows 7 pro ?

    et pour la petite explication c'est pour lancer des films sur mon PC depuis une interface web

  4. #4
    Modérateur
    Avatar de sabotage
    Homme Profil pro
    Inscrit en
    juillet 2005
    Messages
    21 577
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2005
    Messages : 21 577
    Points : 31 445
    Points
    31 445

    Par défaut

    Pour le windows 7, il est tout frais sorti de la boite ; pour le serveur j'ai fais le test avec Xampp.

    Tu pourrais essayer de désactiver l'UAC de Windows pour voir (bien que sur mon poste, il soit activé).
    Mais est-ce que tu as le même problème si tu lances ton lecteur vidéo ?

  5. #5
    Invité de passage
    Inscrit en
    décembre 2005
    Messages
    4
    Détails du profil
    Informations forums :
    Inscription : décembre 2005
    Messages : 4
    Points : 1
    Points
    1

    Par défaut

    Bah en fait j'ai le même problème avec un VLC par exemple :/

    ça m'affiche la fenêtre que j'ai marquée plus haut.
    (bon si je click dedans ça s'affiche mais bon j'aimerais bien passer cette étape)

    J'ai essayé de lancer wampapache avec ma session et là le processus se lance mais en tache de fond

    EDIT : bon autant pour moi VLC dispose d'une interface WEB pour faire ça.
    je vais creuser plus par là du coup

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •