+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Membre éclairé
    Homme Profil pro
    Responsable Maintenance
    Inscrit en
    août 2012
    Messages
    335
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Responsable Maintenance

    Informations forums :
    Inscription : août 2012
    Messages : 335
    Points : 328
    Points
    328

    Par défaut VS 2012 net framework

    Bonjour,

    Je vous explique mon problème donc je fais un peu d'historique :

    - J'ai commencé a prog une maquette lié avec une base de données access sur la version 2010.
    - Puis j'ai migré sur la version 2012.
    A l'époque j'ai galeré pour trouver le bon driver ACE oledb pour access. J'ai finit par l'installer et tout fut nickel.

    Mon ancien PC commencer sérieusement a ramer maison , et le taffe m'ont fournit un New Pc ( Oh il est beau ça brille Bling Bling, geek attitude)

    J'ai réinstallé VS 2012. Recup le backup de mon projet. Installer le bon vieux pilote qui marchait bien ACEOLEDB...
    Le test de connexion est ok mais au moment de valider j'ai l'erreur suivante :

    " Le Fournisseur de données .Net Framework demandé est introuvable. Il n'est peut être pas installé".

    Je regarde dans le projet je ne retrouve pas la Réference System.data.oleDB.

    Le pilote est pourtant installé. Office 2010 également avec access.

    J'ai testé en créant un nouveau projet , j'ai toujours le même message donc je pense qu' jai un element manquant dans la machine.

    De plus je me rappelle d'avoir vu cohabiter plusieurs .net framework sur mon ancienne machine , la je n'arrive pas a installer les anciennes versions antérieur à la 4.5

    Si un pro a une idée car je me retrouve bloqué dans mon développement.

    Merci

  2. #2
    Membre Expert
    Homme Profil pro
    Développeur .NET
    Inscrit en
    juillet 2006
    Messages
    863
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2006
    Messages : 863
    Points : 1 360
    Points
    1 360

    Par défaut

    par defaut VS2012 install uniqument la version 4.5 du framework.
    Si tu veux avoir les autres framework il faut que tu les install.

    Regarde du coté de MSDN, il y a peu être une procedure spécifique pour VS 2012 pour qu'il puisse récuperer les framework que tu as installé.
    ___________________________________________________________________________________________________________
    Si mon message t'a aidé - Si au contraire, je suis hors sujet - Quand vous avez la réponse à votre question.
    Est notre ami

  3. #3
    Membre éclairé
    Homme Profil pro
    Responsable Maintenance
    Inscrit en
    août 2012
    Messages
    335
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Responsable Maintenance

    Informations forums :
    Inscription : août 2012
    Messages : 335
    Points : 328
    Points
    328

    Par défaut

    J'ai desinstallé completement VS2012 , repris mon ancien VS2010 tout recharger toujours le même problème du coup je pense que le framework qui travaillé avec le OLEDB etait plus ancienne.

    Dans le framework 4.5 system.data.oleDb existe t'il toujours ?

  4. #4
    Membre éclairé
    Homme Profil pro
    Responsable Maintenance
    Inscrit en
    août 2012
    Messages
    335
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Responsable Maintenance

    Informations forums :
    Inscription : août 2012
    Messages : 335
    Points : 328
    Points
    328

    Par défaut

    Bon j'ai regardé d'autre forums du site j'ai utilise le cleanup fournit sur le site Cro$oft , virés Tous les frameworks , refait toutes les installa a zero, passer la plateforme de Dev en X86 et rechoper le bon OleDb.
    Et ouf tous refonctionne comme sur l'ancien.
    Pourquoi faire facile quand on peut faire compliquer ... Merci Cro$oft...

    Merci à Tous je mets en Resolu

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •