1. #1
    Membre régulier
    Inscrit en
    septembre 2006
    Messages
    209
    Détails du profil
    Informations forums :
    Inscription : septembre 2006
    Messages : 209
    Points : 74
    Points
    74

    Par défaut Bibliothèque Boost Asio

    Bonjour,

    J'utilise Eclipse CDT Juno sous XP avec MinGW.

    En tentant de compiler l'exemple de Boost client/serveur (http://gwenael-dunand.developpez.com...ost/asio/#LI-A), je tombe sur une erreur :
    'tcp' has not been declared
    Alors que mes autres exemples fonctionnent.

    J'en déduis que je ne joins pas la bonne bibliothèque Boos au linkage (option -l). Mais après avoir mis à peu près toutes les librairies, j'ai toujours la même erreur.

    Quelqu'un aurait-il une piste, une idée ?

    Merci d'avance pour votre aide.

  2. #2
    Membre régulier
    Inscrit en
    septembre 2006
    Messages
    209
    Détails du profil
    Informations forums :
    Inscription : septembre 2006
    Messages : 209
    Points : 74
    Points
    74

    Par défaut

    En fait, il faut ajouter la lib ws2_32 (-lws2_32) et, dans le fichier source mettre :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    using boost::asio::ip::tcp;

+ Répondre à la discussion
Cette discussion est résolue.

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo