Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Nouveau Membre du Club
    Homme Profil pro Innocent SORO
    Étudiant
    Inscrit en
    mars 2012
    Messages
    91
    Détails du profil
    Informations personnelles :
    Nom : Homme Innocent SORO

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mars 2012
    Messages : 91
    Points : 31
    Points
    31

    Par défaut QuickReport 5.0.5 et Delphi XE2

    Salut!
    J'ai un projet fait sous Delphi 7.0 Entreprise que je veux reprendre et améliorer avec Delphi XE2.
    Le problème, c'est que j'ai dans ce projet des états faits avec QuickReport. Il me faut donc QuickReport sur mon Delphi XE2. J'ai télécharger le QuickReport 5.0.5.
    Avant l'installation, mes composants QuickReport sont inconnus par Delphi XE2 (ce qui est "tout à fait" normal). Mais après l'installation, c'est encore pire : Delphi ne reconnait même plus les unités qui sont dans le Uses. J'ai réinstallé le <delphi plusieurs fois mais c'est la même chose : avant QuickReport ok , après, KO . Je pense que c'est dû aux variables d'environnement mais je n'en suis pas sûr, et de toutes les façons, je ne sais pas les manipuler.
    Pourrais-je avoir une idée sur le moyen de résoudre ce problème?

  2. #2
    Nouveau Membre du Club
    Homme Profil pro Innocent SORO
    Étudiant
    Inscrit en
    mars 2012
    Messages
    91
    Détails du profil
    Informations personnelles :
    Nom : Homme Innocent SORO

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mars 2012
    Messages : 91
    Points : 31
    Points
    31

    Par défaut

    J'ai trouvé une solution ici.
    En fait, en installant QuickReport, les chemins des bibliotèques sont toutes supprimées et remplacés par les chemins de QuickReport (je ne sais pas à quoi c'est dû). Du coup, toutes les autres unités sont introuvables.
    J'ai donc commencé (avant l'installation de QuickReport) par récupérer tous les chemins des bibliothèques, et après l'installation de QuickReport, j'ai rajouté les chemins précédemment récupérés aux chemins ajouté pas QuickReport.
    Et ça fonctionne!

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •