Discussion: Modifier la version de Java [Xtext]

  1. #1
    Membre expert
    Avatar de Samuel_
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2012
    Messages
    377
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : août 2012
    Messages : 377
    Points : 3 309
    Points
    3 309
    Billets dans le blog
    1

    Par défaut Modifier la version de Java

    Bonjour à tous,

    J'utilise xText pour la première fois.
    Après avoir créé mon fichier ecore, je crée un projet xText (lié au fichier ecore).

    La génération se passe bien, mais il y a de nombreuses erreurs dans le fichier .xtext.

    Ma théorie est la suivante :
    J'ai Java 6 sur ma machine et je pense que xText prend par défaut Java 7. D'où ma question comment modifier les propriétés de xText pour qu'il utilise Java 6.

    Merci

    Ne pas oublier mais aussi

    "L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai "

  2. #2
    Membre expert
    Avatar de Hephaistos007
    Profil pro
    Enseignant Chercheur
    Inscrit en
    décembre 2004
    Messages
    2 259
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Enseignant Chercheur
    Secteur : Enseignement

    Informations forums :
    Inscription : décembre 2004
    Messages : 2 259
    Points : 3 621
    Points
    3 621

    Par défaut

    Citation Envoyé par Samuel_ Voir le message
    La génération se passe bien, mais il y a de nombreuses erreurs dans le fichier .xtext.
    C'est vague...

    Citation Envoyé par Samuel_ Voir le message
    Ma théorie est la suivante :
    J'ai Java 6 sur ma machine et je pense que xText prend par défaut Java 7. D'où ma question comment modifier les propriétés de xText pour qu'il utilise Java 6.
    Si c'est vraiment lié à cela, je pense que c'est plutôt au niveau des propriétés du genmodel qu'il faut agir (Compliance level, ...).
    Il vaut mieux mobiliser son intelligence sur des conneries que mobiliser sa connerie sur des choses intelligentes --- devise SHADOKS

    Kit de survie Android : mon guide pour apprendre à programmer sur Android, mon tutoriel sur les web services et enfin l'outil en ligne pour vous faire gagner du temps - N'oubliez pas de consulter la FAQ Android

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Quelle version de java utilisez vous ?
    Par Scorpyosis dans le forum Langage
    Réponses: 115
    Dernier message: 06/11/2006, 21h16
  2. [Débutant] Changer de version de java
    Par sunchai dans le forum Langage
    Réponses: 2
    Dernier message: 07/04/2006, 22h52
  3. [Shell]Détecter la version de java dans un script
    Par sc_wizard29 dans le forum Général Java
    Réponses: 4
    Dernier message: 01/07/2005, 11h00
  4. [DOM] Problème entre différentes versions de java
    Par scorpiwolf dans le forum XML
    Réponses: 3
    Dernier message: 17/03/2005, 12h40

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo