p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Invité régulier
    Inscrit en
    avril 2002
    Messages
    89
    Détails du profil
    Informations forums :
    Inscription : avril 2002
    Messages : 89
    Points : 6
    Points
    6

    Par défaut Sous C#, 2008, Pb avec Internet Explorer

    BOnjour,

    Dans une appli windows sous Visual Studio 2008, j'inclus le composant Webbrowser. Cependant quand je charge la page, j'ai une erreur de script .js et la page ne s'affiche pas normalement. Or, avec IE 8, la page n'a aucun soucis. Que dois-je changer au niveau de mon composant ?

    D'avance merci

  2. #2
    Expert Confirmé Sénior Avatar de Graffito
    Inscrit en
    janvier 2006
    Messages
    5 992
    Détails du profil
    Informations forums :
    Inscription : janvier 2006
    Messages : 5 992
    Points : 7 767
    Points
    7 767

    Par défaut

    Quelques indices ici : http://www.west-wind.com/weblog/post...the-IE-Version

    Extrait du site:
    There are two different sets of keys for 32 bit and 64 bit applications.
    32 bits :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION
    64 bits :HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION


    The value to set this key to is (taken from MSDN here) as decimal values:
    9999 (0x270F) Internet Explorer 9. Webpages are displayed in IE9 Standards mode, regardless of the
    !DOCTYPE directive.
    9000 (0x2328)
    Internet Explorer 9. Webpages containing standards-based !DOCTYPE directives are displayed in IE9 mode.
    8888 (0x22B8) Webpages are displayed in IE8 Standards mode, regardless of the
    !DOCTYPE directive.
    8000 (0x1F40)
    Webpages containing standards-based !DOCTYPE directives are displayed in IE8 mode.
    7000 (0x1B58) Webpages containing standards-based
    !DOCTYPE directives are displayed in IE7 Standards mode.
    " Le croquemitaine ! Aaaaaah ! Où ça ? " ©Homer Simpson

  3. #3
    Invité régulier
    Inscrit en
    avril 2002
    Messages
    89
    Détails du profil
    Informations forums :
    Inscription : avril 2002
    Messages : 89
    Points : 6
    Points
    6

    Par défaut

    Merci beaucoup pour cette réponse... Mais je ne comprends pas tout à 100% à l'anglais, (environ 50% :p)
    Je dois modifier quelque chose dans la base de registre ça d'accord, mais je n'ai pas du tout ce qui est indiqué.
    Du genre lui dans la capture d'écran, on peut voir :
    - prevosh.exe
    - vfp.exe
    - wfpapplication1

    Dans ma registry pour la même clé de la base de registré, j'ai juste
    - skype.exe
    - sllauncher.exe

    Du coup j'ose pas trop touché, et je ne comprends pas trop quoi rajouté... ?

  4. #4
    Expert Confirmé Sénior Avatar de Graffito
    Inscrit en
    janvier 2006
    Messages
    5 992
    Détails du profil
    Informations forums :
    Inscription : janvier 2006
    Messages : 5 992
    Points : 7 767
    Points
    7 767

    Par défaut

    Dans ma registry pour la même clé de la base de registré, j'ai juste
    - skype.exe
    - sllauncher.exe
    Rajoute simplement dans cette clé une nouvelle valeur DWORD avec comme nom celui de ton programme et comme valeur une de celles indiquées sur le lien, par exemple "MonProg.exe" comme nom et 9999 comme valeur.
    " Le croquemitaine ! Aaaaaah ! Où ça ? " ©Homer Simpson

  5. #5
    Invité régulier
    Inscrit en
    avril 2002
    Messages
    89
    Détails du profil
    Informations forums :
    Inscription : avril 2002
    Messages : 89
    Points : 6
    Points
    6

    Par défaut

    Impec, Génial, ça marche !!!!!

    merci beaucoup !

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. "Enregistrer Sous" avec Internet Explorer en local
    Par faloulau dans le forum Général Conception Web
    Réponses: 0
    Dernier message: 25/11/2014, 10h03
  2. Forcer une page à s'ouvrir avec Internet Explorer
    Par alexbubs dans le forum Balisage (X)HTML et validation W3C
    Réponses: 7
    Dernier message: 31/10/2005, 10h32
  3. Truc mystique avec internet explorer
    Par Death83 dans le forum Balisage (X)HTML et validation W3C
    Réponses: 4
    Dernier message: 13/08/2005, 12h25
  4. Pb avec Internet explorer
    Par wareq dans le forum IE
    Réponses: 31
    Dernier message: 28/04/2005, 17h33
  5. [W3C] pb avec Internet Explorer
    Par magic8392 dans le forum Balisage (X)HTML et validation W3C
    Réponses: 2
    Dernier message: 04/03/2005, 15h02

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo