p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    juillet 2012
    Messages
    140
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2012
    Messages : 140
    Points : 20
    Points
    20

    Par défaut phpmailer ne fonctionne pas

    Bonjour,

    J'ai découvert PHPmailer et je suis en train d'essayé de l'intégrer a mon site cependant l'envoi de mail ne fonctionne pas du tout:
    J'ai même tester une page avec juste cela dedans et toujours rien
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    <?php
     
     
       // On va chercher la définition de la classe
       require('phpmailer/class.phpmailer.php');
     
       // On créé une nouvelle instance de la classe
       $mail = new PHPMailer();
     
       // De qui vient le message, e-mail puis nom
       $mail->From = "votre-mail@hotmail.fr";
       $mail->FromName = "Nom Prénom";
     
       // Définition du sujet/objet
       $mail->Subject = "Mon mail!";
     
       // On définit le corps du message
       $mail->Body = "Bonjour";
     
       // Il reste encore à ajouter au moins un destinataire
       // (ou plus, par plusieurs appel à cette méthode)
       $mail->AddAddress("mon-mail@hotmail.fr", "Moi");
     
       // Pour finir, on envoi l'e-mail
       $mail->send();
     
    ?>
    je tiens a préciser que je n'ai aucune erreur php (Firebug)

    Est ce quelqu'un a une idée??
    Merci d'avance

  2. #2
    Membre actif
    Homme Profil pro
    Développeur Web
    Inscrit en
    mars 2009
    Messages
    116
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : mars 2009
    Messages : 116
    Points : 163
    Points
    163

    Par défaut

    Tu as bien configuré le serveur smtp ou tu passe par mail?

    Sinon tu peux utiliser ça pour voir l'erreur de phpmailer

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    if(!$mail->Send()){ 
    	  echo $mail->ErrorInfo;
    	}
    	else{	  
    	  echo 'Mail envoyé avec succès';
    	}

  3. #3
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    juillet 2012
    Messages
    140
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2012
    Messages : 140
    Points : 20
    Points
    20

    Par défaut

    Je viens d'ajouter votre code test et j'ai Bien Mail Envoyé...
    Je suis en mail pas en smtp j'ai mi le Ismail

  4. #4
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    juillet 2012
    Messages
    140
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2012
    Messages : 140
    Points : 20
    Points
    20

    Par défaut

    C'est bon j'ai enfin réussi a a envoyé un mail, le soucis venait des mon adresse de messagerie, les adresse hotmail ne fonctionnent pas...

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [phpmailer] Envoi d'e-mail ne fonctionne pas
    Par _jey_ dans le forum Bibliothèques et frameworks
    Réponses: 3
    Dernier message: 03/09/2009, 15h28
  2. Réponses: 6
    Dernier message: 27/01/2004, 11h14
  3. UNION qui ne fonctionne pas
    Par r-zo dans le forum Langage SQL
    Réponses: 7
    Dernier message: 21/07/2003, 10h04
  4. Un Hint sur un PopupMenu ne fonctionne pas !!??
    Par momox dans le forum C++Builder
    Réponses: 6
    Dernier message: 26/05/2003, 16h48
  5. ca ne fonctionne pas (generateur auto-incrémentant)
    Par tripper.dim dans le forum SQL
    Réponses: 7
    Dernier message: 26/11/2002, 00h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo