Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2006
    Messages
    228
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2006
    Messages : 228
    Points : 24
    Points
    24

    Par défaut JBoss AS7 ne trouve pas mon JAVA_HOME

    Bonjour,

    Depuis que j'ai installé le JDK 6 de SUN, JBoss ne retrouve plus mon JAVA_HOME.

    Il fonctionnait très bien avec OpenJDK et depuis que je suis passé au JDK 6 32 bit de SUN, il ne démarre plus.

    Quelqu'un saurait-il m'indiquer comment résoudre ce problème ?

    Merci d'avance pour votre aide.

  2. #2
    Futur Membre du Club
    Homme Profil pro Thony Ng
    Développeur Web
    Inscrit en
    mai 2012
    Messages
    23
    Détails du profil
    Informations personnelles :
    Nom : Homme Thony Ng
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2012
    Messages : 23
    Points : 16
    Points
    16

    Par défaut

    Bonjour,

    T'es sur Eclipse Juno ? Normalement il utilise c:\Users\Username comme répertoire par défaut.
    Si ça ne te convient pas, tu as juste à indiquer le chemin que tu as toujours eu.

  3. #3
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro Laurent Barbareau
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 253
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Barbareau
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 253
    Points : 16 148
    Points
    16 148

    Par défaut

    Citation Envoyé par ranly Voir le message
    T'es sur Eclipse Juno ? Normalement il utilise c:\Users\Username comme répertoire par défaut.
    Si ça ne te convient pas, tu as juste à indiquer le chemin que tu as toujours eu.
    Quel est le rapport avec la question posée ?!

    Citation Envoyé par Klemsy78 Voir le message
    Depuis que j'ai installé le JDK 6 de SUN, JBoss ne retrouve plus mon JAVA_HOME.
    Ce n'est sans doute pas à cause de l'installation du JDK 6 mais plus parce que t'as du désinstallé l'ancien JDK.

    Donc, il te faut mettre à jour la variable d'environnement JAVA_HOME.
    Cf. ce document http://java.developpez.com/livres/ja...ogramme#LIII-A
    A partir de la phrase :
    A l'étape suivante de l'installation, tu dois définir deux variables système....
    Celui-ci concerne les variables PATH et CLASSPATH mais le principe est exactement le même pour JAVA_HOME.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Pensez à cliquer sur le bouton une fois votre problème solutionné, merci.

  4. #4
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2006
    Messages
    228
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2006
    Messages : 228
    Points : 24
    Points
    24

    Par défaut

    merci pour votre reponse.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •