Publicité
+ Répondre à la discussion Actualité déjà publiée
Affichage des résultats 1 à 2 sur 2
  1. #1
    Expert Confirmé Sénior

    Avatar de dourouc05
    Homme Profil pro Thibaut Cuvelier
    Étudiant
    Inscrit en
    août 2008
    Messages
    19 295
    Détails du profil
    Informations personnelles :
    Nom : Homme Thibaut Cuvelier
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 19 295
    Points : 69 548
    Points
    69 548

    Par défaut Sortie de Joomla! 3.0.0

    Voilà qui est fait, six mois après la sortie de Joomla! 2.5 : la version 3.

    Tout d’abord, un mot sur le release cycle : la version 2.5 est une LTS (long term support), pas la 3.0. Cette dernière permet de casser pas mal de choses et ne sera donc pas supportée à long terme : il faudra attendre la 3.5 pour cela (au rythme d’une version mineure tous les six mois). La 2.5 sera supportée jusqu’à la sortie de la 3.5, au moins : il est toujours sûr de l’utiliser, elle sera toujours supportée… mais ne verra pas d’évolution technique. Avec la sortie de cette version 3.0, par contre, c’est le support de la vieillissante 1.5 qui est arrêté.
    La migration de la 2.5 vers la 3.0 devrait se passer sans heurts, sauf en cas d’utilisation intensive d’extensions (quelques modifications ont été apportées à la Joomla! Platform, ce qui rend les extensions incompatibles en partie mais facilement corrigibles).

    Quelques choses ont été cassées avec cette version : d’un côté, la compatibilité avec PHP 5.2 (dont le support a été arrêté fin 2010), seul PHP 5.3.1 et supérieurs sont supportés (de même, MySQL 5.0 n’est plus supporté – cette version n’est d’ailleurs plus maintenue depuis belle lurette) ; de l’autre, l’interface d’administration, entièrement repensée, suite aux recherches du groupe JUX.

    Dans les nouveautés, on compte l’intégration de Bootstrap, le framework JavaScript de Twitter ; il est utilisé pour deux designs dits responsive (l’un pour la partie utilisateur, l’autre pour les administrateurs), optimisés pour les mobiles. L’installation a été simplifiée, elle se déroule maintenant en trois étapes tout en supportant PostgreSQL. Un nouveau module de statistiques est aussi disponible.

    Également, des tests unitaires ont été introduits pour le CMS.

    Au niveau des statistiques de cette version : 34 nouvelles fonctionnalités (dont 15 ont été intégrées dans les versions 2.5.1 à 2.5.7) et 491 bogues.

    Sources : release notes, liste des prérequis techniques et billet original
    Vous souhaitez participer aux rubriques Qt ou PyQt/PySide (tutoriels, FAQ, traductions, sources) ? Contactez-moi par MP.

    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  2. #2
    Invité régulier
    Inscrit en
    janvier 2009
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : janvier 2009
    Messages : 8
    Points : 7
    Points
    7

    Par défaut Le support de PostGres

    L'interface avec PostgreSQL est une très bonne chose.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •