p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Nouveau Membre du Club
    Inscrit en
    août 2010
    Messages
    126
    Détails du profil
    Informations forums :
    Inscription : août 2010
    Messages : 126
    Points : 37
    Points
    37

    Par défaut Problème déploiement projet

    Bonjour a tous, afin d'approfondir mes connaissances concerant le conteneur de servlet tomcat, j'ai voulu deployer un projet en .war sur celui ci via la page internet localhost:8080. J'ai voulu deployer un projet .war via la zone de saisie "Choisir le fichier WAR à téléverser" mais probleme, je ne sais pour quelle raison celui refuse de deployer le projet .war, voici ce que tomcat me dit :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Etat HTTP 500 - org.apache.tomcat.util.http.fileupload.FileUploadBase$IOFileUploadException: Processing of multipart/form-data request failed. C:\Program Files\Apache Software Foundation\Tomcat 7.0\work\Catalina\localhost\manager\upload_53ec536c_13a04022a50__8000_00000016.tmp (Accès refusé)

    je ne comprend pas pourquoi on m'indique ce genre de pb, j'ai beau chercher sur internet, je n'ai pas reussi à résoudre le probleme. Est ce que quelqu'un a reussi a resoudre ce genre de probleme ? Est ce lié a un probleme de droit ?

    Merci d'avance pour votre aide

  2. #2
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2006
    Messages
    228
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2006
    Messages : 228
    Points : 24
    Points
    24

    Par défaut

    Bjr,

    Il faut t'assurer que ton utilisateur Tomcat a bien les droits d'administration en mode graphique(via l'interface web).
    Sinon il faut reéditer le fichier Tomcat-user.xml et lui donner ces droits.

  3. #3
    Nouveau Membre du Club
    Inscrit en
    août 2010
    Messages
    126
    Détails du profil
    Informations forums :
    Inscription : août 2010
    Messages : 126
    Points : 37
    Points
    37

    Par défaut

    Merci pour ta réponse, malheureusement je n'ai pas eu le temps d'appliquer tes conseils car j'avais decidé de tout réinstaller et j'ai résolu mon probleme comme ceci.

    A l'avenir si j'ai le même probleme j'appliquerai tes conseils. Merci pour ton aide

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Problème déploiement projet Maven vers serveur web distant
    Par dark0502 dans le forum Développement Web en Java
    Réponses: 1
    Dernier message: 09/08/2013, 13h12
  2. Problème déploiement projet Axis 2
    Par y_chafaqi dans le forum Web Services
    Réponses: 0
    Dernier message: 02/10/2011, 10h55
  3. Problème déploiement projet JSF RichFaces
    Par ahmeddrira dans le forum JSF
    Réponses: 2
    Dernier message: 09/08/2011, 08h42
  4. Spring +tapestry+hibernate : problème déploiement projet
    Par amadoulamine1 dans le forum Spring Web
    Réponses: 1
    Dernier message: 25/02/2011, 10h01
  5. [EJB3] Problème déploiement projets Web et EJB
    Par tomy29 dans le forum Java EE
    Réponses: 0
    Dernier message: 14/12/2009, 15h44

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo