p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Futur Membre du Club
    Inscrit en
    avril 2008
    Messages
    57
    Détails du profil
    Informations forums :
    Inscription : avril 2008
    Messages : 57
    Points : 15
    Points
    15

    Par défaut Problème avec les double backslash

    Bonjour,

    J'ai une application ou je propose à l'utilisateur de donner un chemin d’accès à un fichier par la méthode "filebrowserEx". Je veux me servir de ce lien pour ouvrir le fichier en question sauf qu'il m'est donné avec un seul anti-slach pour la séparation des sous-dossiers alors qu'il en faut 2 avec la méthode "execute" pour l'ouvrir.
    Comment résoudre ce problème
    Merci pour votre aide.

  2. #2
    Membre habitué
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    108
    Détails du profil
    Informations personnelles :
    Localisation : France, Essonne (Île de France)

    Informations forums :
    Inscription : octobre 2007
    Messages : 108
    Points : 126
    Points
    126

    Par défaut

    Bonjour

    Un breakapart pour éclater la chaine sur le caractère \ puis parcours du tableau obtenu pour reconstruire la chaine en doublant l'antislash ?

  3. #3
    Membre habitué
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    108
    Détails du profil
    Informations personnelles :
    Localisation : France, Essonne (Île de France)

    Informations forums :
    Inscription : octobre 2007
    Messages : 108
    Points : 126
    Points
    126

    Par défaut

    Ou un simple balayage de la chaine caractère par caractère en doublant l'antishlash quand on le rencontre ?

    En fait le mieux est de se coder une petite fonction remplace générique !

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Problème avec les doubles liste Symfony
    Par farhaenis dans le forum symfony1
    Réponses: 1
    Dernier message: 10/08/2011, 18h15
  2. Problème avec les doubles
    Par midotoon dans le forum Jasper
    Réponses: 0
    Dernier message: 17/10/2008, 11h42
  3. Problème avec les backslashes
    Par Shuny dans le forum Regex
    Réponses: 4
    Dernier message: 25/05/2007, 23h01
  4. problème avec les doubles
    Par mahi31 dans le forum Langage
    Réponses: 1
    Dernier message: 27/04/2007, 15h37
  5. Debugger - problème avec les "double"
    Par Dev_Michael dans le forum C++Builder
    Réponses: 15
    Dernier message: 28/03/2007, 11h15

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo