Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 6 sur 6
  1. #1
    Invité de passage
    Inscrit en
    octobre 2008
    Messages
    17
    Détails du profil
    Informations forums :
    Inscription : octobre 2008
    Messages : 17
    Points : 0
    Points
    0

    Par défaut Ouverture des fichiers PHP avec PHPEclipse au lieu de PHP Editor

    Bonjour à tous,

    Je suis un peu novice avec Eclipse.

    Dans Eclipse, dans mon arborescence de projet, quand je clique sur un fichier PHP, il l'ouvre par défaut avec un PHP Editor tout moche, sans coloration syntaxique. Je peux faire un clic droit, Open With, et là choisir le PHP Editor de PHPEclipse, et tout va bien.

    Je voudrais que ce dernier exemple soit le comportement par défaut mais je n'y arrive pas. J'ai essayé de jouer avec les file associations, mais tout est "locked".

    Quelqu'un saurait-il m'expliquer comment faire ?

    Merci d'avance pour votre aide.

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro Laurent Barbareau
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 247
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Barbareau
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 247
    Points : 15 969
    Points
    15 969

    Par défaut

    Bonjour,

    Normalement il y a le bouton Default qui te permet de choisir l'association par défaut, que ce soit "locked" ou pas.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Pensez à cliquer sur le bouton une fois votre problème solutionné, merci.

  3. #3
    Invité de passage
    Inscrit en
    octobre 2008
    Messages
    17
    Détails du profil
    Informations forums :
    Inscription : octobre 2008
    Messages : 17
    Points : 0
    Points
    0

    Par défaut

    J'ai testé, et rien à faire. Il le met bien en défaut, mais quand je double clique sur un fichier php, il l'ouvre avec l'éditeur "moche", et je dois faire un clic droit pour ouvrir avec phpEdit.

    Je viens de virer tous mes réglages eclipse (suppression du dossier $HOME/.eclipse sous linux), j'ai tout réinstallé, et tout est ok maintenant, mais je n'ai pas l'explication.

  4. #4
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro Laurent Barbareau
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 247
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Barbareau
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 247
    Points : 15 969
    Points
    15 969

    Par défaut

    Une explication peut éventuellement être que, lorsque l'on double-clic sur un fichier qui a déjà été ouvert dans un éditeur spécifique, c'est le dernier éditeur qui est réutilisé, peu importe le réglage par défaut.
    Donc, normalement un fichier qui n'a jamais été ouvert précédemment, sera ouvert dans l'éditeur paramétré comme étant celui par défaut. Si ce n'est pas le cas c'est qu'il doit y avoir un bug.

    Peut-être qu'un eclipse -clean en ligne de commande aurait pu corriger ce défaut mais ce n'est pas sûr.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Pensez à cliquer sur le bouton une fois votre problème solutionné, merci.

  5. #5
    Invité de passage
    Inscrit en
    octobre 2008
    Messages
    17
    Détails du profil
    Informations forums :
    Inscription : octobre 2008
    Messages : 17
    Points : 0
    Points
    0

    Par défaut

    Je note pour la commande eclipse -clean.
    Pour le reste... maintenant ça marche, mais j'hésite à mettre un "résolu".

  6. #6
    Invité de passage
    Inscrit en
    octobre 2008
    Messages
    17
    Détails du profil
    Informations forums :
    Inscription : octobre 2008
    Messages : 17
    Points : 0
    Points
    0

    Par défaut

    Je crois que je viens de trouver ce qui déclenche ce problème : la mise en place de xDebug.
    Une fois un xDebug configuré, il revient à ce comportement qui me gêne (et le "default" n'est pas pris en compte).

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •