Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité de passage
    Inscrit en
    avril 2011
    Messages
    16
    Détails du profil
    Informations forums :
    Inscription : avril 2011
    Messages : 16
    Points : 0
    Points
    0

    Par défaut Problème avec atollic

    bonjour,

    j'utilise atollic avec la librairie de stm32 : foc sdk 3.2 pour le contrôle de moteur.
    Quand j'effectue, un contrôle, espace, le nom de la fonction apparait bien. Cependant, lorsque je compile, il m'indique l'erreur : " undefined reference to "nom de la fonction"" .

    les fichiers sources et .h sont bien intégrés au projet.

    Quelqu'un à t'il déja rencontré ce genre d'erreur avec atollic ?

    Merci d'avance

  2. #2
    Modérateur
    Avatar de Bktero
    Profil pro
    Ingénieur systèmes embarqués
    Inscrit en
    juin 2009
    Messages
    2 698
    Détails du profil
    Informations personnelles :
    Âge : 27
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Ingénieur systèmes embarqués
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juin 2009
    Messages : 2 698
    Points : 7 168
    Points
    7 168

    Par défaut

    Cela ressemble à un problème d'édition des liens et non de compilation (comme dans ma signature). Les .h sont dans le projet donc l'autocomplétion trouve le nom de fonctions, je pense. Il faut regarder les options du linker pour voir si la bibliothèque est correctement ajouté (au moins le chemin pour la trouver).
    Si Code::Blocks vous dit undefined reference to 'socket@12', cela signifie que vous avez un problème d'édition des liens. Allez dans Projects / Build Options / Linker Settings / Add et renseigner ici les .a qui vont bien. Exemple pour les sockets : C:\Program Files\CodeBlocks\MinGW\lib\libws2_32.a

    Pour les adeptes du langage SMS, allez ici et ramenez la traduction française ^^

    Pour vos problèmes d'embarqué, utilisez le forum dédié !

  3. #3
    Invité de passage
    Inscrit en
    avril 2011
    Messages
    16
    Détails du profil
    Informations forums :
    Inscription : avril 2011
    Messages : 16
    Points : 0
    Points
    0

    Par défaut Re

    Merci de votre réponse,

    Je pense avoir trouvé le problème. Quand j'ajoute la libraraie (.a) à mon projet, le compilateur m'indique l'erreur, il ne trouve pas le fichier.

    Sauriez-vous, si il y a un moyen spécial d'ajouter un fichier (.a) avec atollic ?

    Merci d'avance

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •