Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Membre régulier Avatar de bannik
    Homme Profil pro Christophe
    Chef de projet NTIC
    Inscrit en
    juillet 2003
    Messages
    164
    Détails du profil
    Informations personnelles :
    Nom : Homme Christophe
    Âge : 39
    Localisation : Belgique

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Communication - Médias

    Informations forums :
    Inscription : juillet 2003
    Messages : 164
    Points : 95
    Points
    95

    Par défaut Eclipse et Egit, commit impossible

    Bonjour,

    Je tente d'utiliser git pour un site web.

    J'ai créé un repository sur le serveur.
    J'ai installé Egit sur mon Eclipse
    J'ai réussi à me connecter au repository distant dans la vue Git Repository.

    Je tente ensuite de créer un projet basé sur ce repository.

    J'importe un projet de Git, via uri avec les infos de connexion.
    Je vois mon projet, avec les petits icônes indiquant que les sources sont linkées.
    J'en modifie un pour les test, je commite, je mets un petit message. Tout à l'air de bien se passer mais rien n'est modifié sur le serveur distant.

    J'ai l'impression qu'il crée un repository local à partir du distant et qu'ensuite Eclipse ne bosse que sur le local.

    Y a-t-il une config particulière que j'ai loupée ?

    Merci

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro Laurent Barbareau
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 246
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Barbareau
    Âge : 41
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 246
    Points : 14 831
    Points
    14 831

    Par défaut

    Bonjour,
    Citation Envoyé par bannik Voir le message
    J'en modifie un pour les tests, je commite, je mets un petit message. Tout à l'air de bien se passer mais rien n'est modifié sur le serveur distant.
    Je ne connaissais pas Git dans le détail mais visiblement c'est normal puisque c'est son fonctionnement...
    Citation Envoyé par bannik Voir le message
    J'ai l'impression qu'il crée un repository local à partir du distant et qu'ensuite Eclipse ne bosse que sur le local.
    C'est bien ça.
    Y a-t-il une config particulière que j'ai loupée ?
    A mon avis tu devrais commencer par lire un peu de documentation à son sujet !

    Tu as ceci par exemple http://blog.developpez.com/jmini/p10...ssions_de_egit qui apporte déjà quelques informations.

    Et même ceci http://djibril.developpez.com/tutori...ption/pro-git/

    Et le forum adapté pour Git est celui-ci http://www.developpez.net/forums/f14...elle/scm/dvcs/
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Pensez à cliquer sur le bouton une fois votre problème solutionné, merci.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •