Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Nouveau Membre du Club
    Profil pro
    Développeur COBOL
    Inscrit en
    mai 2009
    Messages
    30
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur COBOL
    Secteur : Finance

    Informations forums :
    Inscription : mai 2009
    Messages : 30
    Points : 26
    Points
    26

    Par défaut IEBGENER et NUMBER ON/OFF

    Bonjour

    je crée un fichier de plusieurs lignes via un IEBGENER tout simple

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    //ETA0020  EXEC PGM=IEBGENER                             
    //SYSPRINT DD  SYSOUT=*                                  
    //SYSIN    DD  DUMMY                                     
    //SYSUT1   DD  *                                         
     DSN SYSTEM(TEST)                                        
     RUN PROGRAM(JDE00324) PLAN(TESTBU1) PARM('£VAL£')      
    /*                                                       
    //SYSUT2   DD  DSN=U01WKS.$$PS01$$.AEP.AEPHBAAZ,         
    //             DISP=(,CATLG),DSORG=PS,RECFM=FB,LRECL=80, 
    //             SPACE=(CYL,(1,1),RLSE)
    Sauf que le fichier en sortie se retrouve en NUMBER ON et donc contient des informations en fin de colonne
    Code :
    1
    2
    3
    4
    ***************************** Top of Data ******************************
    -1----+----2----+----3----+----4----+----5----+----6----+----7----+----8
    TEM(TEST)                                                       00520002
    GRAM(JDE00324) PLAN(TEST1BU1) PARM('£VAL£')                     00530002
    Et cela m'embête grandement car j'ai ensuite un programme qui remplace le paramètre £VAL£ par un champ de 10 caractères
    mais le programme croit qu'il n'y a plus de place pour décaler à droite.


    Y a t-il une option sur le IEBGENER qui permettrait de créer un fichier forcé à NUMBER OFF?

  2. #2
    Invité de passage
    Inscrit en
    janvier 2005
    Messages
    3
    Détails du profil
    Informations forums :
    Inscription : janvier 2005
    Messages : 3
    Points : 2
    Points
    2

    Par défaut

    Bonjour Julien,

    Je pense que la solution pourrait être du coté de la commande unnum, tout dépend en fait de comment ton profile est défini mais aussi de comment tu récupère le fichier de sortie pour y injecter la valeur dans ta variable... la commande unnum doit être saisie au préalable sans quoi c'est la valeur par défaut de l'éditeur qui sera utilisée (dans ton cas ton identifiant RACF est configuré avec la valeur NUMBER ON ou STD)...

  3. #3
    Membre Expert Avatar de bernard59139
    Profil pro
    Administrateur de base de données
    Inscrit en
    octobre 2006
    Messages
    738
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : octobre 2006
    Messages : 738
    Points : 1 276
    Points
    1 276

    Par défaut

    bonjour

    Si tu as des "NUM" en sortie, c'est que les "NUM" sont présents dans le fichier en entrée.

    la solution ==> supprimer les NUM dans le fichier en entrée.

  4. #4
    Nouveau Membre du Club
    Profil pro
    Développeur COBOL
    Inscrit en
    mai 2009
    Messages
    30
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur COBOL
    Secteur : Finance

    Informations forums :
    Inscription : mai 2009
    Messages : 30
    Points : 26
    Points
    26

    Par défaut

    Citation Envoyé par bernard59139 Voir le message
    Si tu as des "NUM" en sortie, c'est que les "NUM" sont présents dans le fichier en entrée.
    mais quel couillon je suis!!
    J'ai honte mais j'ai honte

    Mon JCL est en NUMBER ON donc effectivement j'avais des nombres à droite de mon SYSUT1
    mais comme l'écran ne va que de des colonnes 1 à 72...

    Humm, topic résolu alors, oupss

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •