Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Invité régulier
    Homme Profil pro
    Lycéen
    Inscrit en
    août 2012
    Messages
    17
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Côte d'Or (Bourgogne)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2012
    Messages : 17
    Points : 7
    Points
    7

    Par défaut Probléme de serveur smtp

    Salut à tous

    Je viens d'installer Easyphp , je suis aller dans admnistration , fichiers locaux , puis j'ai mis le dossier de mon site comme séléction et le nom de la page contenant un formulaire . En cliquant dessus ,j'ouvre le formulaire qui cible une page de traitement une fois celui ci envoyer , cette page de traitement a pour but d'envoyer le form a mon email perso. Petit probleme: ayant correctement remplis ce formulaire la page de traitement s'affiche de la sorte : "
    Warning: mail(): Failed to connect to mailserver at "127.0.0.1" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\Documents and Settings\Administrateur\Bureau\traitement.php on line 61
    Une erreur est survenue lors de l'envoi du formulaire par email"
    la fameuse ligne en question :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
     
    //ligne 61 qui fais ***** : 
    if (mail(MAIL_DESTINATAIRE,MAIL_SUJET,$mail_corps,$mail_entete)) {
      //Le mail est bien expédié
      echo $msg_ok;
    } else {
      //Le mail n'a pas été expédié
      echo "Une erreur est survenue lors de l'envoi du formulaire par email";
    }
     
    ?>
    est le code "echo" pour dire si il a été envoyé ou non .


  2. #2
    Membre éclairé
    Homme Profil pro
    Responsable DSI interne
    Inscrit en
    juin 2011
    Messages
    197
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Responsable DSI interne
    Secteur : Tourisme - Loisirs

    Informations forums :
    Inscription : juin 2011
    Messages : 197
    Points : 314
    Points
    314

    Par défaut

    B'soir,

    Comme dis explicitement tu as un problème de configuration de ton SMTP dans php.ini...

    Je supposes que as installé WAMP sur ton poste, clic gauche sur l'icone => PHP => Php.ini

    Et rends toi à la ligne SMTP.
    "Beatus qui prodest quibus potest"

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •