+ Répondre à la discussion
Affichage des résultats 1 à 5 sur 5
  1. #1
    Invité de passage
    Homme Profil pro Kévin
    Inscrit en
    août 2012
    Messages
    3
    Détails du profil
    Informations personnelles :
    Nom : Homme Kévin
    Localisation : France, Gard (Languedoc Roussillon)

    Informations forums :
    Inscription : août 2012
    Messages : 3
    Points : 1
    Points
    1

    Par défaut Incompatibilité entre WampServer 2.2x et XP SP3?

    Bonjour à toutes et à tous,

    Je viens vers vous après deux jours de galère, moteur de recherches écumés etc...

    Voilà, je tourne sous XP pro SP3 et je souhaiterais bosser avec Symphony2, j'avoue que je connais pas les frameworks et j'aimerais bien m'y atteler.

    Symphony2 étant incompatible avec les versions antérieures à PHP5.3.2, j'ai viré WampServer 2.0 (proprement je précise, nettoyage des entrées registres invalides, désinstallation à la cool via Ccleaner....etc) pour mettre WampServer 2.2.

    J'ai testé diverses versions la 2.2a et la 2.2e si je ne m'abuse, après avoir installé la x86 de VisualC++.

    Et à chaque fois, l'installation se passe bien et quand je veut lancer wampserver.exe je me mange une jolie "Aestan Tray Menu a rencontré un problème et doit fermer..."

    Je précise tout de même que j'ai bien la version x86 de WampServer et que l’architecture est du 32 bits donc le problème ne vient pas de là. De plus j'ai lu sur divers forums que Skype sqouatté méchamment le port 80, le même qu'Apache, sauf que je n'ai pas Skype.

    Certains d'entre vous auraient-ils à leur connaissance des problèmes d'incompatibilités entre WampServer 2.2x et XP Sp3?

    ---Sinon, j'ai bien tenté d'installer une nouvelle version de PHP direct dans Wamp (/bin/php/) en modifiant les .ini et en copiant le wampserver.conf mais là quand je passe à la nouvelle version dans le menu contextuel de Wamp, l'icone se mue en un joli jaune qui veut dire "Impossible d'accéder à localhost..." BIM!
    Précisons que j'avais téléchargé la Non-Thread Safe version de PHP, je vais essayer de ce pas avec la Thread Safe....

    En tout cas merci par avance à l'attention que vous porterez à mes questionnements.
    Bonne journée.

  2. #2
    Expert Confirmé Sénior
    Avatar de Benjamin Delespierre
    Profil pro Benjamin Delespierre
    Développeur Web
    Inscrit en
    février 2010
    Messages
    3 931
    Détails du profil
    Informations personnelles :
    Nom : Benjamin Delespierre
    Âge : 27
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : février 2010
    Messages : 3 931
    Points : 8 401
    Points
    8 401

    Par défaut

    Non, ça devrait fonctionner sans problème (je l'utilise couramment sous XP SP3).
    C'est peut être un résidu de l'installation précédente, dans le doute, désinstalle tout et supprime C:/wamp avant de réinstaller.

  3. #3
    Invité de passage
    Homme Profil pro Kévin
    Inscrit en
    août 2012
    Messages
    3
    Détails du profil
    Informations personnelles :
    Nom : Homme Kévin
    Localisation : France, Gard (Languedoc Roussillon)

    Informations forums :
    Inscription : août 2012
    Messages : 3
    Points : 1
    Points
    1

    Par défaut

    Merci pour la réponse,
    Malheureusement, comme indiqué sur le post, je l'avais déjà fait. J'ai posé la question sur le forum de WampServer, il me confirme comme toi que il n'y a pas de problème d'incompatibilité;
    Mais pourquoi celà ne fonctionne pas S+£µ**&!!

  4. #4
    Invité de passage
    Homme Profil pro Kévin
    Inscrit en
    août 2012
    Messages
    3
    Détails du profil
    Informations personnelles :
    Nom : Homme Kévin
    Localisation : France, Gard (Languedoc Roussillon)

    Informations forums :
    Inscription : août 2012
    Messages : 3
    Points : 1
    Points
    1

    Par défaut

    Je suis de plus en plus dépité car impossible de faire fonctionner la PHP5.4.x avec WampServer2.0, effectivement la stack de tous les composants de la v2.2 a été compilé au VC9, à l'inverse de la 2.0, à la VC6, impossible concomitante entre ces deux éléments.
    Donc, je ne sais plus quoi faire. Éventuellement me lancer dans le codage d'un serveur local concurrent de wamp qui puisse fonctionner sur ma bécane..

    --edit !
    Réussi, la v2.2 tourne bien, en fait j'avais bien installé la VC10, mais pas la VisualC++ redistribuable de 2008 (en fait la plus part des forums et des manips parlent de la VC10, mais omelette de parler de la VC08, les deux sont indispensables à WampServer2.2 pour tourner)...et now it works.
    Merci à tous ceux qui se m'ont aidés pour mon problème.
    A bientôt

  5. #5
    Expert Confirmé Sénior
    Avatar de Benjamin Delespierre
    Profil pro Benjamin Delespierre
    Développeur Web
    Inscrit en
    février 2010
    Messages
    3 931
    Détails du profil
    Informations personnelles :
    Nom : Benjamin Delespierre
    Âge : 27
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : février 2010
    Messages : 3 931
    Points : 8 401
    Points
    8 401

    Par défaut

    Ou utiliser un VM linux

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •