Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 12 sur 12
  1. #1
    Membre Expert
    Avatar de Archimède
    Homme Profil pro anthony LAURENT
    Enseignant
    Inscrit en
    avril 2005
    Messages
    1 183
    Détails du profil
    Informations personnelles :
    Nom : Homme anthony LAURENT
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : avril 2005
    Messages : 1 183
    Points : 1 122
    Points
    1 122

    Par défaut Petits soucis en ligne

    J'ai de petit soucis qui provient, je pense d'insertion d'animations flash sous IE. j'affiche l'heure, la date, une animation avec le globe +un bandeau d'images défilantes réalisé avec un tileset...donc 4 animations...

    j'ai le problème que je soulève ici :
    http://www.developpez.net/forums/d12...s/#post6849336

  2. #2
    Expert Confirmé Sénior
    Avatar de Paul TOTH
    Homme Profil pro Paul TOTH
    Freelance
    Inscrit en
    novembre 2002
    Messages
    5 489
    Détails du profil
    Informations personnelles :
    Nom : Homme Paul TOTH
    Âge : 45
    Localisation : Réunion

    Informations professionnelles :
    Activité : Freelance
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2002
    Messages : 5 489
    Points : 14 424
    Points
    14 424

    Par défaut

    si je comprend bien tu as des liens qui ne fonctionnent plus et tu penses que c'est lié à Flash ?

    difficile à dire comme ça...ta page est-elle accessible en ligne ?

    PS: je n'ai pas compris ce que tu appelles un lien "en Flash"
    Developpez.com: Mes articles, forum FlashPascal
    Entreprise: Execute SARL
    Produits : UPnP, RemoteOffice, FlashPascal
    Embarcadero : Ile de la Réunion, Dephi, C++Builder, RADPHP...TVA à 8,5%

  3. #3
    Membre Expert
    Avatar de Archimède
    Homme Profil pro anthony LAURENT
    Enseignant
    Inscrit en
    avril 2005
    Messages
    1 183
    Détails du profil
    Informations personnelles :
    Nom : Homme anthony LAURENT
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : avril 2005
    Messages : 1 183
    Points : 1 122
    Points
    1 122

    Par défaut

    Hello, je parlais d'un lien sur une image de ce type là (déjà posté, je crois...) :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
     
    program lien;
     
    uses Flash8;
     
    {$FRAME_WIDTH  64}
    {$FRAME_HEIGHT 64}
    {$BACKGROUND  $FAEBD7}
    {$JPEG  nom 'forum.png'}
     
    type
     
      mymovie=class(movieclip)
       bmp: BitmapData;
       constructor Create;
       procedure onPress;override;
      end; 
     
     
     
     
    constructor mymovie.Create;
    begin
     inherited Create(nil,'mymovie',0); 
     bmp := loadBitmap('nom');
     attachBitmap(bmp,0);
    end;
     
     
     
    procedure mymovie.onPress;
    begin
     getURL('http://www.blabla...');
    end;
     
     
    begin
      mymovie.Create;
    end.
    J'ai d'ailleurs un petit soucis avec ce type de code uniquement sous FF et window7 sur mon portable hp. Les images de liens s'effritent en les déplaçant avec les ascenseurs d'une div et les liens sont inopérants. (pas d'ouverture).
    Sur l'ordi de mon fils avec FF et windows7 pas de problème. Sur le miien en vista, ça marche aussi.

    Je pense que les modules complémentaires installés sur mon ordi portable sont à l'origine de ce phénomène...
    Ma page est accessible en ligne, mais j'ai des informations perso que je ne tiens pas à rendre publiques...
    Cette page dans le principe reprend l'exemple que j'ai fourni sur le forum html.
    ça fonctionne avec l'exemple et j'ai 5 ou six boutons avec des liens "ancre" qui me mènent en des endroits particuliers sur ma div contenu. De là, j'ai des liens de téléchargements, d'adresses de sites...Le principe étant le même que l'exemple.

    Et lorsque je clique sur ces liens sous IE actuellement, je n'ai pas de soucis d'ouverture mais elle s'accompagne d'une remontée non désirée en haut de ma div contenu en même temps. (le lien s'ouvre et je remonte en haut de l'ascenseur de la div contenu.) curieux !
    Alors à part les fichiers swf introduits, je ne vois pas ce qui pourrait être la source de cette erreur. le code est validé W3C html5 et css3.

    voilà pour l'explication...

  4. #4
    Membre Expert
    Avatar de Archimède
    Homme Profil pro anthony LAURENT
    Enseignant
    Inscrit en
    avril 2005
    Messages
    1 183
    Détails du profil
    Informations personnelles :
    Nom : Homme anthony LAURENT
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : avril 2005
    Messages : 1 183
    Points : 1 122
    Points
    1 122

    Par défaut

    Pour FF sur mon portable, j'ai encore le même soucis que j'avais eu il y a quelques temps. Quand j'essaye d'ouvrir un fichier swf, j'ai 36 onglets qui apparaissent et pas d'ouverture.. je réinstalle ff une nouvelle fois...ça n'avait régler le problème la dernière fois...curieux.
    les modules complémentaires sont désactivés, ça ne change rien.

  5. #5
    Membre Expert
    Avatar de Archimède
    Homme Profil pro anthony LAURENT
    Enseignant
    Inscrit en
    avril 2005
    Messages
    1 183
    Détails du profil
    Informations personnelles :
    Nom : Homme anthony LAURENT
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : avril 2005
    Messages : 1 183
    Points : 1 122
    Points
    1 122

    Par défaut

    J'ai désinstallé et réinstallé FF. L'ouverture des fichiers swf est de nouveau possible. En revanche, j'observe toujours en ligne le bug des images de lien flash qui se désagrègent... ci-joint l'image :
    Rq: Avec opéra ou IE, ce bug ne se produit pas...
    Images attachées Images attachées

  6. #6
    Membre Expert
    Avatar de Archimède
    Homme Profil pro anthony LAURENT
    Enseignant
    Inscrit en
    avril 2005
    Messages
    1 183
    Détails du profil
    Informations personnelles :
    Nom : Homme anthony LAURENT
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : avril 2005
    Messages : 1 183
    Points : 1 122
    Points
    1 122

    Par défaut

    voici un exemple concret de la remontée de la div en cliquant sur le lien :
    Sur mon portable, je ne peux même pas l'ouvrir (le lien)...

    le code source pour info :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
     
    program lancement_dvp;
     
    uses Flash8;
     
    {$FRAME_WIDTH  64}
    {$FRAME_HEIGHT 64}
    {$JPEG  nom 'dvp.png'}
     
    type
     
      mymovie=class(movieclip)
       bmp: BitmapData;
       constructor Create;
       procedure onPress;override;
      end; 
     
     
     
     
    constructor mymovie.Create;
    begin
     inherited Create(nil,'mymovie',0);
     bmp := loadBitmap('nom');
     attachBitmap(bmp,0);
    end;
     
     
     
    procedure Mymovie.onPress;
    begin
     getURL('http://www.developpez.net/forums');
    end;
     
     
    begin
      mymovie.Create;
    end.
    code html :

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    129
    130
    131
    132
    133
    134
    135
    136
    137
    138
    139
    140
    141
    142
    143
    144
    145
    146
    147
    148
    149
    150
    151
    152
    153
    154
    155
    156
    157
    158
    159
    160
    161
    162
    163
    164
    165
    166
    167
    168
     
    <!doctype html>
    <html lang='fr'>
      <head>
        <meta charset="windows-1252">
        <title>essai</title>
        <Style type="text/CSS">
         .menu {
         position : absolute;
         left : 0%;
         top : 118px;
         width : 15%;
         height : 75%;
         background-color : #E1E4F2;
         }
         .bouton {
         background-color : #00BFFF;
         cursor : pointer;
         text-align : center;
         border : gray solid 1px;
         width : 100%;
         height : 7%;
         }
         .lien-bouton {
         text-decoration : none;
         font-size : 1.5em;
         color : black;
         }
         .actif:hover {
         background-color : yellow;
         }
         div#contenu {                            
         background-color : #F5F5FF;
         position : absolute;
         left : 15%;
         top : 118px;
         width : 85%;
         height : 75%;
         border : gray solid 1px;
         overflow : auto;
         margin:auto;
         }
         .police{
         font-family : Arial,Helvetica;
         font-size : 1.5em;
         color : #305ac8;
         font-weight : bold;
         text-decoration : underline;
         margin-left : 10px;
         }
         .police2 {
         font-family : Arial,Helvetica;
         font-size : 1em;
         color : #305ac8;
         font-weight : bold;
         font-style : italic;
         }
         .lien-dvp{
           font-family : Arial,Helvetica;
           font-size : 1.5em;
            margin-left : 200px;
         }
         .td-lien {
         text-align : left;
         border : #008b8b solid 1px;
         }
         .tab-lien {
         border-collapse : collapse;
         width : 414px;
         margin-left:50px;
         }
     
        </Style>  
     </head>
    <body>
    <header> </header>
    <nav > 
       <div class="menu">
         <a href="#ancre" class="lien-bouton"><div class="bouton actif">vers mon ancre</div></a>
         <a href="#debut" class="lien-bouton"><div class="bouton actif">Retour</div></a>
       </div> 
    </nav>
    <article>
       <div id="contenu" class="police">
         <a  id="debut"></a>
         <p class="police">
          début :
         </p>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <a id="ancre"></a>
         <h2 class="police">-ma destination</h2> 
         <table class="tab-lien">
         <tr>
          <td class="td-lien police2"style="width:350px;">forums developpez.com</td>
          <td class="td-lien" style="width:64px;"><embed  type="application/x-shockwave-flash" src="dvp.swf" width="64" Height="64" style="display:block; margin:auto;"></td>
         </tr>
         </table>
     </div>
    </article>
    <aside> </aside>
    <footer> </footer>
    </body>
    </html>
    vous l'avez avec le fichier mais bon...

    dites moi sous IE, ce qui se passe...
    Fichiers attachés Fichiers attachés

  7. #7
    Expert Confirmé Sénior
    Avatar de Paul TOTH
    Homme Profil pro Paul TOTH
    Freelance
    Inscrit en
    novembre 2002
    Messages
    5 489
    Détails du profil
    Informations personnelles :
    Nom : Homme Paul TOTH
    Âge : 45
    Localisation : Réunion

    Informations professionnelles :
    Activité : Freelance
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2002
    Messages : 5 489
    Points : 14 424
    Points
    14 424

    Par défaut

    alors en local déjà j'ai un message de sécurité d'Adobe qui m'indique qu'il a interrompu l'opération d'accès à www.developpez.net...

    sous Chrome j'ai des bugs d'affichage, le titre n’apparaît pas quand je clique sur "vers mon ancre" et du texte reste affiché quand je clique sur "retour"...

    je n'ai pas rencontré ce genre de problème en faisant le site FlashPascal...en même temps j'ai fait du HTML de base, sans tag spécifiques HTML 5...est-ce lié ? je ne serais le dire.
    Developpez.com: Mes articles, forum FlashPascal
    Entreprise: Execute SARL
    Produits : UPnP, RemoteOffice, FlashPascal
    Embarcadero : Ile de la Réunion, Dephi, C++Builder, RADPHP...TVA à 8,5%

  8. #8
    Membre Expert
    Avatar de Archimède
    Homme Profil pro anthony LAURENT
    Enseignant
    Inscrit en
    avril 2005
    Messages
    1 183
    Détails du profil
    Informations personnelles :
    Nom : Homme anthony LAURENT
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : avril 2005
    Messages : 1 183
    Points : 1 122
    Points
    1 122

    Par défaut

    Moi maintenant avec un lien classique html, ça fonctionne...:
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    129
    130
    131
    132
    133
    134
    135
    136
    137
    138
    139
    140
    141
    142
    143
    144
    145
    146
    147
    148
    149
    150
    151
    152
    153
    154
    155
    156
    157
    158
    159
    160
    161
    162
    163
    164
    165
    166
    167
    168
     
    <!doctype html>
    <html lang='fr'>
      <head>
        <meta charset="windows-1252">
        <title>essai</title>
        <Style type="text/CSS">
         .menu {
         position : absolute;
         left : 0%;
         top : 118px;
         width : 15%;
         height : 75%;
         background-color : #E1E4F2;
         }
         .bouton {
         background-color : #00BFFF;
         cursor : pointer;
         text-align : center;
         border : gray solid 1px;
         width : 100%;
         height : 7%;
         }
         .lien-bouton {
         text-decoration : none;
         font-size : 1.5em;
         color : black;
         }
         .actif:hover {
         background-color : yellow;
         }
         div#contenu {                            
         background-color : #F5F5FF;
         position : absolute;
         left : 15%;
         top : 118px;
         width : 85%;
         height : 75%;
         border : gray solid 1px;
         overflow : auto;
         margin:auto;
         }
         .police{
         font-family : Arial,Helvetica;
         font-size : 1.5em;
         color : #305ac8;
         font-weight : bold;
         text-decoration : underline;
         margin-left : 10px;
         }
         .police2 {
         font-family : Arial,Helvetica;
         font-size : 1em;
         color : #305ac8;
         font-weight : bold;
         font-style : italic;
         }
         .lien-dvp{
           font-family : Arial,Helvetica;
           font-size : 1.5em;
            margin-left : 200px;
         }
         .td-lien {
         text-align : left;
         border : #008b8b solid 1px;
         }
         .tab-lien {
         border-collapse : collapse;
         width : 414px;
         margin-left:50px;
         }
     
        </Style>  
     </head>
    <body>
    <header> </header>
    <nav > 
       <div class="menu">
         <a href="#ancre" class="lien-bouton"><div class="bouton actif">vers mon ancre</div></a>
         <a href="#debut" class="lien-bouton"><div class="bouton actif">Retour</div></a>
       </div> 
    </nav>
    <article>
       <div id="contenu" class="police">
         <a  id="debut"></a>
         <p class="police">
          début :
         </p>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <a id="ancre"></a>
         <h2 class="police">-ma destination</h2> 
         <table class="tab-lien">
         <tr>
          <td class="td-lien police2"style="width:350px;">forums developpez.com</td>
           <td class="td-lien" style="width:64px;"><a href="http://www.developpez.net/forums"><img src="dvp.png" alt="dvp.png, 4,3kB" title="lien_forums" height="64" width="64" style="display:block; margin:auto;" target="_Blank"></a></td>
         </tr>
         </table>
     </div>
    </article>
    <aside> </aside>
    <footer> </footer>
    </body>
    </html>
    Vous pouvez tester pour voir si ça vient du fichier swf.

    Si, ce n'est que sur les liens que ça cafouille, ce n'est pas grave...

    merci
    Images attachées Images attachées
    Fichiers attachés Fichiers attachés

  9. #9
    Expert Confirmé Sénior
    Avatar de Paul TOTH
    Homme Profil pro Paul TOTH
    Freelance
    Inscrit en
    novembre 2002
    Messages
    5 489
    Détails du profil
    Informations personnelles :
    Nom : Homme Paul TOTH
    Âge : 45
    Localisation : Réunion

    Informations professionnelles :
    Activité : Freelance
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2002
    Messages : 5 489
    Points : 14 424
    Points
    14 424

    Par défaut

    ça fonctionne...mais en remaniant ta page Flash j'ai moins de problème

    reste un affichage très bizarre quand je redimensionne la fenêtre manifestement Chrome digère mal certaines pages contenant du Flash...peut-être à cause de la taille à 75% qui rend le conteneur dynamique.

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    129
    130
    131
    132
    133
    134
    135
    136
    137
     
    <!doctype html>
    <html lang='fr'>
      <head>
        <meta charset="windows-1252">
        <title>essai</title>
        <Style type="text/CSS">
    			body, html {
    				height: 100%;
    			}
    			#main {
    				position: absolute;
         position : absolute;
         left : 0%;
         top : 118px;
         height : 75%;
    		 width: 100%;
    			}
    			#main td {
    				vertical-align: top;
    			}
         .menu {
         width : 15%;
         background-color : #E1E4F2;
         }
         .bouton {
         background-color : #00BFFF;
         cursor : pointer;
         text-align : center;
         border : gray solid 1px;
         width : 100%;
         height : 7%;
         }
         .lien-bouton {
         text-decoration : none;
         font-size : 1.5em;
         color : black;
         }
         .actif:hover {
         background-color : yellow;
         }
         #contenu {                            
         background-color : #F5F5FF;
         width : 85%;
    		 height: 100%;
         border : gray solid 1px;
         overflow : auto;
         }
         .police{
         font-family : Arial,Helvetica;
         font-size : 1.5em;
         color : #305ac8;
         font-weight : bold;
         text-decoration : underline;
         margin-left : 10px;
         }
         .police2 {
         font-family : Arial,Helvetica;
         font-size : 1em;
         color : #305ac8;
         font-weight : bold;
         font-style : italic;
         }
         .lien-dvp{
           font-family : Arial,Helvetica;
           font-size : 1.5em;
            margin-left : 200px;
         }
         .td-lien {
         text-align : left;
         border : #008b8b solid 1px;
         }
         .tab-lien {
         border-collapse : collapse;
         width : 414px;
         margin-left:50px;
         }
     
        </Style>  
     </head>
    <body>
    <table id="main"><tr>
    <td class="menu">
         <a href="#ancre" class="lien-bouton"><div class="bouton actif">vers mon ancre</div></a>
         <a href="#debut" class="lien-bouton"><div class="bouton actif">Retour</div></a>
    </td><td>
    	<div id="contenu" class="police">
         <a  id="debut"></a>
         <p class="police">
          début :
         </p>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
     
         <br>
         <a id="ancre"></a>
         <h2 class="police">-ma destination</h2> 
         <table class="tab-lien">
         <tr>
          <td class="td-lien police2" style="width:350px;">forums developpez.com</td>
          <td class="td-lien" style="width:64px;"><embed  type="application/x-shockwave-flash" src="dvp.swf" width="64" Height="64"></td>
         </tr>
         </table>
     
     </div></td>
    </tr></table>
     
     </body>
    </html>
    Developpez.com: Mes articles, forum FlashPascal
    Entreprise: Execute SARL
    Produits : UPnP, RemoteOffice, FlashPascal
    Embarcadero : Ile de la Réunion, Dephi, C++Builder, RADPHP...TVA à 8,5%

  10. #10
    Membre Expert
    Avatar de Archimède
    Homme Profil pro anthony LAURENT
    Enseignant
    Inscrit en
    avril 2005
    Messages
    1 183
    Détails du profil
    Informations personnelles :
    Nom : Homme anthony LAURENT
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : avril 2005
    Messages : 1 183
    Points : 1 122
    Points
    1 122

    Par défaut

    Citation Envoyé par Paul TOTH Voir le message
    peut-être à cause de la taille à 75% qui rend le conteneur dynamique.
    Personnelement, je ne vois de soucis particulier avec les autres animations flash sur google chrome...

    ci-joint deux animations que j'ai rajouté en haut de la div contenu à 75% :

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    129
    130
    131
    132
    133
    134
    135
    136
    137
    138
    139
    140
    141
    142
    143
    144
    145
    146
    147
    148
    149
    150
    151
    152
    153
    154
    155
    156
    157
    158
    159
    160
    161
    162
    163
    164
    165
    166
    167
     
    <!doctype html>
    <html lang='fr'>
      <head>
        <meta charset="windows-1252">
        <title>essai</title>
        <Style type="text/CSS">
         .menu {
         position : absolute;
         left : 0%;
         top : 118px;
         width : 15%;
         height : 75%;
         background-color : #E1E4F2;
         }
         .bouton {
         background-color : #00BFFF;
         cursor : pointer;
         text-align : center;
         border : gray solid 1px;
         width : 100%;
         height : 7%;
         }
         .lien-bouton {
         text-decoration : none;
         font-size : 1.5em;
         color : black;
         }
         .actif:hover {
         background-color : yellow;
         }
         div#contenu {                            
         background-color : #F5F5FF;
         position : absolute;
         left : 15%;
         top : 118px;
         width : 85%;
         height : 75%;
         border : gray solid 1px;
         overflow : auto;
         margin:auto;
         }
         .police{
         font-family : Arial,Helvetica;
         font-size : 1.5em;
         color : #305ac8;
         font-weight : bold;
         text-decoration : underline;
         margin-left : 10px;
         }
         .police2 {
         font-family : Arial,Helvetica;
         font-size : 1em;
         color : #305ac8;
         font-weight : bold;
         font-style : italic;
         }
         .lien-dvp{
           font-family : Arial,Helvetica;
           font-size : 1.5em;
            margin-left : 200px;
         }
         .td-lien {
         text-align : left;
         border : #008b8b solid 1px;
         }
         .tab-lien {
         border-collapse : collapse;
         width : 414px;
         margin-left:50px;
         }
     
        </Style>  
     </head>
    <body>
    <header> </header>
    <nav > 
       <div class="menu">
         <a href="#ancre" class="lien-bouton"><div class="bouton actif">vers mon ancre</div></a>
         <a href="#debut" class="lien-bouton"><div class="bouton actif">Retour</div></a>
       </div> 
    </nav>
    <article>
       <div id="contenu" class="police">
         <a  id="debut"></a>
          <embed  type="application/x-shockwave-flash" src="datedujour.swf"  width="400" Height="50" style=" display:block; margin:auto;">
         <br>
         <br>
         <embed  type="application/x-shockwave-flash" src="savant.swf" width="780" Height="190" style=" display:block; margin:auto;">
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <br>
         <a id="ancre"></a>
         <h2 class="police">-ma destination</h2> 
         <table class="tab-lien">
         <tr>
          <td class="td-lien police2"style="width:350px;">forums developpez.com</td>
           <td class="td-lien" style="width:64px;"><a href="http://www.developpez.net/forums"><img src="dvp.png" alt="dvp.png, 4,3kB" title="lien_forums" height="64" width="64" style="display:block; margin:auto;" target="_Blank"></a></td>
         </tr>
         </table>
     </div>
    </article>
    <aside> </aside>
    <footer> </footer>
    </body>
    </html>
    le code du bandeau défilant pour ajouter du flashpascal lol et animer un peu le forum :

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
     
    unit Udefiltil;
     
    {$FRAME_RATE 100}
    interface
    uses
      flash8;
    type
     TMovie=class(movieclip)
     private
       w,h,dx:number;
       Imageglob,Image,Mask: MovieClip;
       procedure setcharge(jpeg:string);
     public
       procedure onEnterFrame;override;
       constructor create(parent:movieclip;width,height:number);
       property chargetileset:string write setcharge;
     end;
     
    implementation
     
    constructor TMovie.create(parent:movieclip;width,height:number);
    begin
     inherited Create(parent,'movie', movieclip(parent).getNextHighestDepth());
     w:=width;
     h:=height;
     Imageglob := MovieClip.Create(Self, 'image', 0);
     Image := MovieClip.Create(imageglob, 'imageglob', 0);
     Mask  := MovieClip.Create(Self, 'mask',1);
     with Mask do
     begin
        beginFill($ffffff);
        lineTo(w, 0);
        lineTo(w,h);
        lineTo(0, h);
     end;
     dx:=0.3;
    end;
     
     
    procedure Tmovie.setcharge(jpeg:string);
    begin
     Image.attachBitmap(loadBitmap(jpeg),0,'auto',true);
     
     with imageglob do
     begin
      image._x:=-w;
      image._y:=0;
      attachBitmap(loadBitmap(jpeg),1,'auto',true);
      SetMask(Mask);
      _quality:='HIGH';
     end;
    end;
     
     
    procedure TMovie.onEnterFrame;
    begin
      Imageglob._x := Imageglob._x +dx;
      if Imageglob._x > w  then Imageglob._x :=0;
    end;
     
    end.
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
     
    program Psavant2;
     
    {$FRAME_WIDTH 780}
    {$FRAME_HEIGHT 170}
    {$BACKGROUND $FFFFFF}
     
    {$JPEG  savant 'tilsav.jpeg'}
     
    uses
      Flash8,Udefiltil;
     
    begin
     with Tmovie.Create(_root,780,170) do chargetileset:='savant';
    end.
    teste, si tu as des soucis...
    Fichiers attachés Fichiers attachés

  11. #11
    Expert Confirmé Sénior
    Avatar de Paul TOTH
    Homme Profil pro Paul TOTH
    Freelance
    Inscrit en
    novembre 2002
    Messages
    5 489
    Détails du profil
    Informations personnelles :
    Nom : Homme Paul TOTH
    Âge : 45
    Localisation : Réunion

    Informations professionnelles :
    Activité : Freelance
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2002
    Messages : 5 489
    Points : 14 424
    Points
    14 424

    Par défaut

    pas de soucis sur cette version, mais dans la première j'avais ceci quand je cliquais sur "vers mon ancre"
    bug.jpg

    par contre sur les deux versions j'ai ceci quand je double clique sur la barre de titre pour réduire la fenêtre
    bug2.jpg
    Developpez.com: Mes articles, forum FlashPascal
    Entreprise: Execute SARL
    Produits : UPnP, RemoteOffice, FlashPascal
    Embarcadero : Ile de la Réunion, Dephi, C++Builder, RADPHP...TVA à 8,5%

  12. #12
    Membre Expert
    Avatar de Archimède
    Homme Profil pro anthony LAURENT
    Enseignant
    Inscrit en
    avril 2005
    Messages
    1 183
    Détails du profil
    Informations personnelles :
    Nom : Homme anthony LAURENT
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : avril 2005
    Messages : 1 183
    Points : 1 122
    Points
    1 122

    Par défaut

    C'est pas gagné... Je vais essayé de voir ce qu'ils en pensent sur le forum html puisque je dois une réponse...

    Merci pour ton aide

    bon dimanche

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •