Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 7 sur 7
  1. #1
    Futur Membre du Club
    Homme Profil pro Aymen FATHALLAH
    Ingénieur systèmes et réseaux
    Inscrit en
    mars 2011
    Messages
    104
    Détails du profil
    Informations personnelles :
    Nom : Homme Aymen FATHALLAH
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux
    Secteur : Finance

    Informations forums :
    Inscription : mars 2011
    Messages : 104
    Points : 15
    Points
    15

    Par défaut Connexion à la base de données lente

    Bonjour,

    Mon problème c'est que depuis deux jours la connexion à mon serveur oracle devient trop lente.
    ci dessous la configuration:
    oracle 11 G
    Windows 2008 server.

    lorsque je me connecte sur mon serveur avec user/mot de passe il se connecte normale mais lorsque je met l'alias user/mot de passe@alias il prend beaucoup de temps a ce connecter.

    merci pour votre aide

  2. #2
    Rédacteur

    Profil pro
    Inscrit en
    décembre 2002
    Messages
    2 817
    Détails du profil
    Informations personnelles :
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations forums :
    Inscription : décembre 2002
    Messages : 2 817
    Points : 4 309
    Points
    4 309

    Par défaut

    Pour voir si ça ne serait pas un problème de résolution de noms, je vous suggère de comparer la vitesse de connexion en utilisant d'une part le nom DNS du serveur, et d'autre part son adresse IP.

    Ça peut se faire simplement par une syntaxe EZCONNECT.
    En supposant que la base s'appelle PROD et que le listener écoute sur le port 1521 :

    Code :
    1
    2
    3
    sqlplus utilisateur/mdp@nom_du_serveur:1521/PROD
    et
    sqlplus utilisateur/mdp@ip_du_serveur:1521/PROD
    Consultant / formateur Oracle indépendant
    Certifié OCP 12c, 11g, 10g ; sécurité 11g

  3. #3
    Futur Membre du Club
    Homme Profil pro Aymen FATHALLAH
    Ingénieur systèmes et réseaux
    Inscrit en
    mars 2011
    Messages
    104
    Détails du profil
    Informations personnelles :
    Nom : Homme Aymen FATHALLAH
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux
    Secteur : Finance

    Informations forums :
    Inscription : mars 2011
    Messages : 104
    Points : 15
    Points
    15

    Par défaut

    lorsque je fait la commande que vous avez m'envoyer j'ai toujours l'erreur suivante:

    ORA-12504: TNS : le processus d'Úcoute n'a pas obtenu de SERVICE_NAME dans
    CONNECT_DATA

  4. #4
    Rédacteur

    Profil pro
    Inscrit en
    décembre 2002
    Messages
    2 817
    Détails du profil
    Informations personnelles :
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations forums :
    Inscription : décembre 2002
    Messages : 2 817
    Points : 4 309
    Points
    4 309

    Par défaut

    Vous avez bien utilisé strictement la syntaxe que j'ai indiquée ?
    J'obtiens votre message d'erreur si j'oublie le nom de la base à la fin...

    Sinon, que donne le TNSPING ? En combien de temps répond-il ?
    Code :
    tnsping nom_de_votre_alias
    Consultant / formateur Oracle indépendant
    Certifié OCP 12c, 11g, 10g ; sécurité 11g

  5. #5
    Membre chevronné Avatar de 13thFloor
    Homme Profil pro
    DBA Oracle freelance
    Inscrit en
    janvier 2005
    Messages
    583
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France

    Informations professionnelles :
    Activité : DBA Oracle freelance

    Informations forums :
    Inscription : janvier 2005
    Messages : 583
    Points : 715
    Points
    715

    Par défaut

    Hello,
    un petit tour dans la log du listener pourrait aider.
    Aucun changement du coté des fichiers tnsnames.ora (client), sqlnet.ora et listener.ora ?

    Autre piste : un firewall dont les règles ont été modifiées (fermeture de ports par exemple).

  6. #6
    Futur Membre du Club
    Homme Profil pro Aymen FATHALLAH
    Ingénieur systèmes et réseaux
    Inscrit en
    mars 2011
    Messages
    104
    Détails du profil
    Informations personnelles :
    Nom : Homme Aymen FATHALLAH
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux
    Secteur : Finance

    Informations forums :
    Inscription : mars 2011
    Messages : 104
    Points : 15
    Points
    15

    Par défaut

    Bonjour,

    j'ai bien appliqué la commande mais toujours même erreur.
    pour la duré lorsque j’utilise tnsping c'est 35790 ms et même plus.
    coté réseau je ne rien changé.
    pour le log du listner je n'ai pas trouver, est ce que vous pouvez m’indiquer le chemin du répertoire du log du listner.

    Merci pour votre aide.

  7. #7
    Membre chevronné Avatar de 13thFloor
    Homme Profil pro
    DBA Oracle freelance
    Inscrit en
    janvier 2005
    Messages
    583
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France

    Informations professionnelles :
    Activité : DBA Oracle freelance

    Informations forums :
    Inscription : janvier 2005
    Messages : 583
    Points : 715
    Points
    715

    Par défaut

    Un lsnrctl stat sous DOS devrait indiquer l’emplacement du fichier :
    Exemple (sous unix) :
    LSNRCTL for Linux: Version 11.2.0.3.0 - Production on 16-AUG-2012 09:00:07
    ...
    Listener Parameter File /appl/grid11203/network/admin/listener.ora
    Listener Log File /appl/diag/tnslsnr/HOSTNAME/listener/alert/log.xml

    S'il y a plusieurs listeners démarrés : lsnrctl stat nom_du_listener

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •