Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Membre régulier
    Inscrit en
    décembre 2010
    Messages
    92
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 92
    Points : 90
    Points
    90

    Par défaut Ma DropDownList est vide

    Bonjour à tous,

    J'ai un problème un peu étrange...
    en fait, sur mon appli webform, sur ma page aspx, je remplis 2 dropdown grâce à de l'ajax (avec jQuery) donc c'est coté client.
    Mes deux dropdown sont bien remplis, j'ai bien des valeurs sélectionnés etc...
    mais lors que je valide ma page, j'ai une dropdown qui apparaît comme vide pour C#.

    J'essais de faire un :

    var test = madropdown.SelectedValue;
    mais c'est vide et toujours vide.
    Quand je regarde en débug, dans la ddl, il voit 0 items ! alors que coté client j'en ai une bonne 50ene.

    En fait, ce qui m’interpelle, c'est que sur mes deux dropdown, une seule a ce comportement... pour l'autre, tout est ok...

    Auriez vous une idée ?

    Coté code :

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
     
     
    // fonctionne
    <asp:DropDownList ID="DdlDepartement" runat="server">
                        <asp:ListItem Text="Choisissez..." Value="0" />
                    </asp:DropDownList>
     
    // fonctionne pas
    <asp:DropDownList ID="DdlVilles" runat="server">
                    <asp:ListItem Text="" Value="0" />
                </asp:DropDownList>
     
     
    // Coté jQuery, j'ai EXACTEMENT le même code.
    $("#<%=DdlDepartement.ClientID %>").html("");
                      $("#<%=DdlDepartement.ClientID %>").append(listeDep);
    Donc voilà, j'avoue ne pas trop avoir d'idées là...

  2. #2
    Nouveau Membre du Club
    Inscrit en
    juin 2007
    Messages
    54
    Détails du profil
    Informations forums :
    Inscription : juin 2007
    Messages : 54
    Points : 31
    Points
    31

    Par défaut

    Salut,

    est-ce que tu as essayé de mettre le contenu de ta premiere drop down sur la deuxieme ( celle qui ne fonctionne pas) juste pour isoler le probleme?

    A bientot,

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •