p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Membre habitué
    Homme Profil pro
    Étudiant
    Inscrit en
    avril 2011
    Messages
    274
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Meurthe et Moselle (Lorraine)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : avril 2011
    Messages : 274
    Points : 143
    Points
    143

    Par défaut Utilisation incompréhensible du port 81

    Bonjour à tous

    Je viens d'installer wamp et donc tous les services associés que j'ai configuré au passage, non sans s'arracher les cheveux à certains moments (notamment pour mysql).

    Je suis donc content, tout marche presque parfaitement. Presque car il subsiste une minuscule ombre au tableau tellement infime que je pourrai passer outre mais en fait cette ombre m'empêche de continuer psychologiquement .

    Voilà cette ombre : j'ai configuré apache tout à fait classiquement dans le httpd.conf, en laissant à 80 le port utilisé. Je précise que j'ai évidemment désactivé la fonctionnalité IIS de windows 7 (64 bits soit dit en passant) donc j'arrive à me connecter nomalement et à ouvrir les pages php présentes dans le dossier www avec mon (mes) navigateur(s). Lorsque je crée un dossier dans le dossier www de wamp et que je mets des fichiers dans ce dossier, je peux y accéder sans problèmes.

    SAUF si le dossier se nomme Pages, casse à respecter à la lettre. Et oui, lorsque je tente d'afficher le contenu du dossier en faisant :
    puis en cliquant sur Pages, apache utilise le port 81 pour s'y connecter : cela n'affiche donc pas la page mais un message d'erreur logique
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Petit problème... Google Chrome n'est pas parvenu à accéder à la page localhost:81.
    Or en tapant
    Le dossier est ouvert.

    De même en tapant
    A la place de localhost, puis en cliquant sur le raccourci du dossier Pages, cela marche également.

    Tout cela me paraît totalement inexplicable d'autant plus que toutes les manières d'ouvrir le contenu d'un dossier contenu dans www fonctionnent sauf si le dossier s'appelle Pages et si on utilise la page d'accueil obtenue en tapant localhost pour y accéder, auquel cas le port 81 est utilisé au lieu du port 80.

    Voila

    Je précise également que le dossier Pages est le premier dossier que j'ai copié dans www avant de faire les modifications sur la configuration du 'serveur'.

  2. #2
    Invité de passage
    Inscrit en
    janvier 2010
    Messages
    3
    Détails du profil
    Informations forums :
    Inscription : janvier 2010
    Messages : 3
    Points : 2
    Points
    2

    Par défaut Même souci de redirection incompréhensible de localhost/mon_site vers localhost:81

    les sources de mon site sont sous Zend dans le répertoire :
    C:\Users\admin\Zend\workspaces\DefaultWorkspace\mon_site
    Avec wamp j'ai crée un alias /mon_site comme ceci :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    Alias /mon_site "c:/Users/admin/Zend/workspaces/DefaultWorkspace/mon_site/" 
     
    <Directory "c:/Users/admin/Zend/workspaces/DefaultWorkspace/mon_site/">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride all
            Order allow,deny
        Allow from 127.0.0.1
    </Directory>
    mon .htaccess est :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    SetEnv REGISTER_GLOBALS 0
    RewriteEngine on
    RewriteBase /mon_site
    et après lecture de pas mal de réponse sur les forums j'ai décommenté la ligne suivante dans le httpd.conf d'apache :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    LoadModule rewrite_module modules/mod_rewrite.so
    Pour finir, lorsque je clique dans mon alias "mon_site" de Wamp il essaie d'ouvrir localhost:81 et j'obtiens naturellement le message d'erreur suivant :

    Firefox ne peut établir de connexion avec le serveur à l'adresse localhost:81
    ==> Est-ce quelqu'un aurait une idée, des pistes à explorer pour résoudre mon problème merci ?

  3. #3
    Responsable Développement Web


    Avatar de Bovino
    Homme Profil pro
    Développeur Web
    Inscrit en
    juin 2008
    Messages
    23 788
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 44
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juin 2008
    Messages : 23 788
    Points : 92 277
    Points
    92 277
    Billets dans le blog
    20

    Par défaut

    Ton port 80 est utilisé par IIS par exemple ?
    Pas de question technique par MP !
    Tout le monde peut participer à developpez.com, vous avez une idée, contactez-moi !
    Mes formations video2brain : La formation complète sur JavaScriptJavaScript et le DOM par la pratiquePHP 5 et MySQL : les fondamentaux
    Mon livre sur jQuery
    Module Firefox / Chrome d'intégration de JSFiddle et CodePen sur le forum

  4. #4
    Modérateur
    Avatar de grunk
    Homme Profil pro
    Dév. Web / Android
    Inscrit en
    août 2003
    Messages
    3 454
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Côte d'Or (Bourgogne)

    Informations professionnelles :
    Activité : Dév. Web / Android
    Secteur : Industrie

    Informations forums :
    Inscription : août 2003
    Messages : 3 454
    Points : 8 280
    Points
    8 280

    Par défaut

    Citation Envoyé par Bovino Voir le message
    Ton port 80 est utilisé par IIS par exemple ?
    Ou skype ?

    Sinon dans ton fichier host (C:\Windows\System32\drivers\etc) tu aurais pas une redirection particulière sur ce dossier Pages ?
    Pry Framework php5

Discussions similaires

  1. navigateur n'utilisant pas le port 80
    Par martinien.olinga dans le forum Internet
    Réponses: 1
    Dernier message: 23/05/2008, 05h48
  2. utilisation d'un port
    Par lince102 dans le forum Installation
    Réponses: 2
    Dernier message: 15/05/2008, 14h53
  3. Utilisation d'un port RJ45
    Par SylvainClip dans le forum Delphi
    Réponses: 6
    Dernier message: 17/04/2007, 13h54
  4. Utiliser le même port série par deux applications
    Par homeostasie dans le forum Windows
    Réponses: 1
    Dernier message: 25/01/2007, 21h42
  5. [C#] Comment utiliser tous les ports COM ?
    Par Seb.26 dans le forum C#
    Réponses: 2
    Dernier message: 10/01/2006, 16h34

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo