Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Invité régulier
    Homme Profil pro philippe sanou
    Inscrit en
    juin 2010
    Messages
    56
    Détails du profil
    Informations personnelles :
    Nom : Homme philippe sanou

    Informations forums :
    Inscription : juin 2010
    Messages : 56
    Points : 5
    Points
    5

    Par défaut difficulté à déployer une application web Asp.net

    Bonjour à tous,

    voici 3 jours que je sèche sur le déploiement d'une application web .net sur IIS7.5. j'ai suivi plusieurs tutoriels pour le déploiement.mais lorsque je fini toutes les configurations en suivant le tutoriel et que je vais dans le navigateur pour lancer l'application,il m'affiche une page blanche.franchement je ne sais quoi faire.quelques suggestions à me faire?

  2. #2
    Expert Confirmé Sénior Avatar de JML19
    Homme Profil pro Jean Michel
    Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Inscrit en
    décembre 2010
    Messages
    7 172
    Détails du profil
    Informations personnelles :
    Nom : Homme Jean Michel
    Localisation : France, Corrèze (Limousin)

    Informations professionnelles :
    Activité : Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Secteur : Transports

    Informations forums :
    Inscription : décembre 2010
    Messages : 7 172
    Points : 11 490
    Points
    11 490
    Billets dans le blog
    1

    Par défaut

    Bonjour

    Tu lances l'application depuis où ?

    Le même serveur ou une autre machine ?

  3. #3
    Invité régulier
    Homme Profil pro philippe sanou
    Inscrit en
    juin 2010
    Messages
    56
    Détails du profil
    Informations personnelles :
    Nom : Homme philippe sanou

    Informations forums :
    Inscription : juin 2010
    Messages : 56
    Points : 5
    Points
    5

    Par défaut

    je lance l'application depuis le même serveur.en faite mon serveur IIS est installé sur windows 7 professionnel et mon application est également sur la même machine.quand j'importe le zip de mon application dans IIS7 et que je tente de visualiser avec mon navigateur,il m'affiche une page blanche comme si il ne retrouvait pas l'application web.j'ai pensé que cela était dû à une erreur de code et je l'ai repris en tentant de déployer un nouveau projet d'application web basique.mais toujours la même erreur.

  4. #4
    Nouveau Membre du Club
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mars 2011
    Messages
    45
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mars 2011
    Messages : 45
    Points : 30
    Points
    30

    Par défaut

    Vu la date je sais pas si ça va encore servir mais (comme je galère moi même sur un autre problème je compatis)

    J'ai un truc qui ressemble un peu à ça y a quelque temps sur une nouvelle machine.
    Mais moi c'était les css qui ne se chargeaient pas ni les js.
    Mais sur une autre pour le même soft c'était ok

    Donc
    j'ai été dans
    - panneau de config
    - programmes et fonctionnalités
    - activer ou désactiver des fonctionnalités windows

    et la j'ai comparé les config des deux machines et les différences se situaient
    au niveau des paramètres de "IIS"
    Dans IIS toute la partie sécurité à été cochée, idem au niveau fonctionnalités HTTP commune sauf "publication web dav".
    Bon en gros y a pas de risque à tout cocher.

    et aussi des "services d'activation des processus windows" ou on a tout coché.(3 lignes)


    Dire quelle option a vraiment réglé le problème, c'était pas notre soucis on était à la bourre (et on paramétrait les deux machines de façon identique).

    Ah oui, voir aussi les règles d'autorisation .NET dans le gestionnaire de service internet (moi j'ai 1 : autoriser utilisateurs anonymes, 2 : autoriser tous les utilisateurs locaux).

    Bonne chasse au flag.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •