Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4

Discussion: Trop STRICT !(

  1. #1
    Invité de passage
    Profil pro
    Conseil - Consultant en systèmes d'information
    Inscrit en
    juillet 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations professionnelles :
    Activité : Conseil - Consultant en systèmes d'information
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : juillet 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut Trop STRICT !(

    Bonjour,

    J'ai installé WAMPserver 2.2 comme support web pour tester OpenAtrium 1.4 qui repose apparement sur Drupal 6.26 (ouf). Tout ça sur Windows 7 64bits.
    Je ne suis pas spécialiste de ces environnements basés sur PHP, mais j'ai déjà pratiqué WAMP dans une version antérieure, Apache également dans d'autres configs, et fait plusieurs tests avec divers CMS PHP (Joomla et d'autres plus primitifs ...), avec qq soucis tjrs résolus au final.

    Mon souci actuel avec OpenAtrium, c'est l'impossibilité de désactiver des messages d'erreurs inutiles liés à la condition E_STRICT qui viennent polluer toutes les pages d'OpenAtrium, le rendant de facto inutilisable.

    J'ai capté que E_STRICT est inclus dans E_ALL depuis PHP 5.4, et j'ai essayé de désactiver tout ce que je pouvais pour supprimer l'affichage de ces "erreurs", voire de toutes les erreurs, du côté des paramètres PHP (display_errors, error_reporting, etc) présents dans les fichiers php.ini, sans aucun résultat.

    J'ai donc été tenté d'en déduire qu'il y avait un paramétrage propre à OpenAtrium (ou à Drupal, sous-jacent) qui prenait le pas sur le paramétrage de base et qui forçait cet affichage, mais toutes mes recherches sont restées vaines, autant sur le net que dans le code [j'ai recherché des ini_set('...', ) relatifs aux erreurs].

    Qq'un aurait-il de l'expérience avec ces plateformes, ou saurait-il m'indiquer comment affiner mon diagnostic ? Car là j'ai vraiment l'impression de chercher à côté de la plaque

    Merci pour vos lumières, le cas échéant !

    PS
    Le PHPinfo reflète bien les changements que je fais dans les php.ini, mais les warning sont tjrs présents ... [strict warning: Non-static method view::load() ...]

  2. #2
    Modérateur

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 9 507
    Points
    9 507

    Par défaut

    dans le ini y'a disable_functions met ini_set et error_reporting, tu pourras voir ou il sont utilisés

  3. #3
    Invité de passage
    Profil pro
    Conseil - Consultant en systèmes d'information
    Inscrit en
    juillet 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations professionnelles :
    Activité : Conseil - Consultant en systèmes d'information
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : juillet 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut Moins STRICT ;)

    @stealth35 :
    Merci !!! Les messages ont bien disparus, je vais enfin pouvoir avancer.

    Mais je n'ai pas compris :
    1) pourquoi ça fonctionne; càd pourquoi qd je modifie les paramètres avec en principe les bonnes valeurs, l'effet escompté n'est pas au rendez-vous ...
    Ca voudrait potentiellement dire que ma supposition que ces valeurs sont modifiées postérieurement par Drupal ou OpenAtrium est pertinente ?
    2) "tu pourras voir où ils sont utilisés" : comment ?)
    Désolé, c'est certainement une question stupide ... mais je n'ai pas l'agilité requise en PHP pour savoir comment je pourrais en déduire où sont ces "settings" qui me pourrissaient la vue ...

    Merci pour qq lueurs supplémentaires !
    Si j'ai le choix, j'aime autant pas mourir idiot

  4. #4
    Modérateur

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 9 507
    Points
    9 507

    Par défaut

    Quand t'installes une appui regarde toujours les recommandations, visiblement c'est fais pour PHP 5.2

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •