Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 6 sur 6

Discussion: importer package mgcv

  1. #1
    Invité régulier
    Inscrit en
    mai 2012
    Messages
    13
    Détails du profil
    Informations forums :
    Inscription : mai 2012
    Messages : 13
    Points : 6
    Points
    6

    Par défaut importer package mgcv

    Bonjour,
    j'essaie de reproduire un script avec R. Arrivé à la création d'un graphique, il me manquait le package "spatstat". Je l'ai installé mais j'ai le message suivant
    "Loading required package: mgcv
    Error in dyn.load(file, DLLpath = DLLpath, ...) :
    unable to load shared object '/Library/Frameworks/R.framework/Versions/2.13/Resources/library/mgcv/libs/i386/mgcv.so':
    dlopen(/Library/Frameworks/R.framework/Versions/2.13/Resources/library/mgcv/libs/i386/mgcv.so, 6): Library not loaded: @rpath/R.framework/Versions/2.13/Resources/lib/libRlapack.dylib
    Referenced from: /Library/Frameworks/R.framework/Versions/2.13/Resources/library/mgcv/libs/i386/mgcv.so
    Reason: image not found
    In addition: Warning messages:
    1: package 'spatstat' was built under R version 2.13.2
    2: package 'mgcv' was built under R version 2.13.2
    Error: package 'mgcv' could not be loaded
    "

    Et pas moyen d'obtenir le dit package "mgcv":
    "trying URL 'http://stat.ethz.ch/CRAN/bin/macosx/leopard/contrib/2.13/mgcv_1.7-11.tgz'
    Content type 'application/x-tar' length 1494134 bytes (1.4 Mb)
    opened URL
    ==================================================
    downloaded 1.4 Mb

    tar: Failed to set default locale

    The downloaded packages are in
    /var/folders/Yv/Yvzc-4OdGjuDLqqJ1P13Bk+++TI/-Tmp-//RtmpNazwkD/downloaded_packages
    "
    Mais ça ne fonctionne toujours pas. Je l'ai aussi installé via le menu ("package & data"), importé à partir de l'adresse url donnée dans le message d'erreur, mais j'ai toujours le même message "Error: package 'mgcv' could not be loaded"

    Quelqu'un saurait-il me dire ce que j'ai loupé?

    Merci pour votre aide!

  2. #2
    Invité régulier
    Inscrit en
    mai 2012
    Messages
    13
    Détails du profil
    Informations forums :
    Inscription : mai 2012
    Messages : 13
    Points : 6
    Points
    6

    Par défaut

    Personne ne peut m'aider à installer mgcv?

  3. #3
    Inactif
    Inscrit en
    avril 2012
    Messages
    96
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 96
    Points : 67
    Points
    67

    Par défaut

    Bonjour,
    essaies simplement
    Code :
    install.packages("mgcv")
    pour voir
    Bon courage

  4. #4
    Invité régulier
    Inscrit en
    mai 2012
    Messages
    13
    Détails du profil
    Informations forums :
    Inscription : mai 2012
    Messages : 13
    Points : 6
    Points
    6

    Par défaut

    Oui, c'est ce que j'ai fait et j'ai toujours le même message d'erreur; je l'ai aussi téléchargé depuis le site "Cran", et c'est pareil. Le message d'erreur dit bien que l'élément est téléchargé (voir mon premier message), mais l'installation ne se fait pas...

  5. #5
    Inactif
    Inscrit en
    avril 2012
    Messages
    96
    Détails du profil
    Informations forums :
    Inscription : avril 2012
    Messages : 96
    Points : 67
    Points
    67

    Par défaut

    verifie ton ton libPaths() en faisant, Tu peut le regler sur
    Code :
    .libPaths("~/R/library")
    et essaies ensuite
    install.packages("package",repos="http://cran.r-project.org")

  6. #6
    Invité régulier
    Inscrit en
    mai 2012
    Messages
    13
    Détails du profil
    Informations forums :
    Inscription : mai 2012
    Messages : 13
    Points : 6
    Points
    6

    Par défaut

    Citation Envoyé par MMDM12 Voir le message
    verifie ton ton libPaths() en faisant,
    Ça a l'air en ordre, j'obtiens
    > .libPaths()
    [1] "/Library/Frameworks/R.framework/Versions/2.13/Resources/library"
    Citation Envoyé par MMDM12 Voir le message
    Tu peut le regler sur
    Code :
    .libPaths("~/R/library")
    Donc je ne l'ai pas changé;
    Citation Envoyé par MMDM12 Voir le message
    et essaies ensuite
    install.packages("package",repos="http://cran.r-project.org")
    là ça coince:
    > install.packages("mgcv",repos="http://cran.r-project.org")
    trying URL 'http://cran.r-project.org/bin/macosx/leopard/contrib/2.13/mgcv_1.7-11.tgz'
    Content type 'application/x-gzip' length 1494134 bytes (1.4 Mb)
    opened URL
    ==================================================
    downloaded 1.4 Mb

    tar: Failed to set default locale

    The downloaded packages are in
    /var/folders/Yv/Yvzc-4OdGjuDLqqJ1P13Bk+++TI/-Tmp-//RtmpnckTYh/downloaded_packages

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •