Soutenez-nous
Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 7 sur 7
  1. #1
    Invité de passage
    Inscrit en
    septembre 2006
    Messages
    17
    Détails du profil
    Informations forums :
    Inscription : septembre 2006
    Messages : 17
    Points : 2
    Points
    2

    Par défaut Problème de Listbox sur application générée

    Bonsoir,

    en mode interprété, lorsque je clique sur une list-box les valeurs s'affichent. Je compile ma base, je génère l'application et là ca ne marche plus. lorsque je clique sur la listbox il ne se passe rien.. Une idée ?

    Merci

    MacOS Lion 4D v12.4

  2. #2
    Membre expérimenté Avatar de ZeFiF
    Homme Profil pro Philippe Voisin
    Consultant informatique
    Inscrit en
    octobre 2008
    Messages
    301
    Détails du profil
    Informations personnelles :
    Nom : Homme Philippe Voisin
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Industrie Pharmaceutique

    Informations forums :
    Inscription : octobre 2008
    Messages : 301
    Points : 505
    Points
    505

    Par défaut

    Bonsoir,

    quelle version de 4D ?
    ça s'affiche ou ?
    c'est une LB tableaux ou sélection courante ?

    on est pas dans ta tête pour savoir de quoi tu parles...

  3. #3
    Membre expérimenté Avatar de ZeFiF
    Homme Profil pro Philippe Voisin
    Consultant informatique
    Inscrit en
    octobre 2008
    Messages
    301
    Détails du profil
    Informations personnelles :
    Nom : Homme Philippe Voisin
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Industrie Pharmaceutique

    Informations forums :
    Inscription : octobre 2008
    Messages : 301
    Points : 505
    Points
    505

    Par défaut

    Citation Envoyé par ZeFiF Voir le message
    Bonsoir,

    quelle version de 4D ?
    ça s'affiche ou ?
    c'est une LB tableaux ou sélection courante ?

    on est pas dans ta tête pour savoir de quoi tu parles...

    merdum 12.4...

  4. #4
    Invité de passage
    Inscrit en
    septembre 2006
    Messages
    17
    Détails du profil
    Informations forums :
    Inscription : septembre 2006
    Messages : 17
    Points : 2
    Points
    2

    Par défaut

    T'as raison, mieux vaut pas que t'y sois dans ma tête :-)))

    Bon, pour récapituler, c'est une liste déroulante dans un formulaire entrée pour lequel j'ai mis des valeurs par défaut.

    Donc quand je suis en mode interprété, pas de soucis je clique dessus et les belles petites valeurs s'affichent.

    Je compile le tout je génère l'appli finale et là plus rien... lorsque je clique dessus niente..rien du tout....

  5. #5
    Membre expérimenté Avatar de ZeFiF
    Homme Profil pro Philippe Voisin
    Consultant informatique
    Inscrit en
    octobre 2008
    Messages
    301
    Détails du profil
    Informations personnelles :
    Nom : Homme Philippe Voisin
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Industrie Pharmaceutique

    Informations forums :
    Inscription : octobre 2008
    Messages : 301
    Points : 505
    Points
    505

    Par défaut

    as tu essayé avec un tableau plutôt qu'avec des valeurs défauts ?

  6. #6
    Invité de passage
    Inscrit en
    septembre 2006
    Messages
    17
    Détails du profil
    Informations forums :
    Inscription : septembre 2006
    Messages : 17
    Points : 2
    Points
    2

    Par défaut

    C'est ce que je suis en train de faire et ca a l'air de fonctionner. J'ai compilé et généré l'appli et j'ai bien mes valeurs....

    Donc je vais modifier mon code en conséquence... Par contre c'est bizarre quand même cette histoire..

    Merci

  7. #7
    Membre expérimenté Avatar de ZeFiF
    Homme Profil pro Philippe Voisin
    Consultant informatique
    Inscrit en
    octobre 2008
    Messages
    301
    Détails du profil
    Informations personnelles :
    Nom : Homme Philippe Voisin
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Industrie Pharmaceutique

    Informations forums :
    Inscription : octobre 2008
    Messages : 301
    Points : 505
    Points
    505

    Par défaut

    ya une explication logique mais je m'en souviens plus...
    heureusement c'était resté dans ma mémoire....

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •