p
u
b
l
i
c
i
t
é
publicité

Discussion: Lighttpd et la CGI

  1. #1
    Invité de passage
    Homme Profil pro
    Développeur en systèmes embarqués
    Inscrit en
    mai 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur en systèmes embarqués
    Secteur : Service public

    Informations forums :
    Inscription : mai 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut Lighttpd et la CGI

    Bonjour,

    Je voudrais utiliser Lighttpd pour faire du CGI en shell script.

    Mon problème est que ce dernier ne semble pas être fait pour des script qui ne retournent pas de html au navigateur !? :

    j'utilise le cgi pour envoyer des commandes à mon serveur sans retour de ce dernier.
    Avec le server HTTPD tout fonctionne bien !

    Mais avec Lighttpd ca déconne car à la fin de chaque script il essaye d'envoyer du contenu à mon navigateur et comme il n'y a pas de code HTML dans ce contenu il me propose à chaque fois de télécharger un fichier portant le nom de mon script.

    Logiquement on peut terminer un script CGI avec un code d'état qui
    indique si tout se passe bien et si il ya du contenu ...

    Or avec LIGHTTPD , il semble que ces codes ne fonctionnent pas !!
    Ou bien il faut une syntaxe particulière que je n'arrive pas à trouver !

    Donc si quelqu'un à des infos sur ce sujet , je suis preneur de tout ce qui me fera avancer.
    MERCI

  2. #2
    Invité de passage
    Homme Profil pro
    Développeur en systèmes embarqués
    Inscrit en
    mai 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur en systèmes embarqués
    Secteur : Service public

    Informations forums :
    Inscription : mai 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut La reponse

    XMLHTTPrequest

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Delphi web (isapi / cgi ou autre) pour nginx ou lighttpd ?
    Par miniworker dans le forum Web & réseau
    Réponses: 0
    Dernier message: 05/05/2011, 09h21
  2. FAST CGI Perl [Lighttpd]
    Par Alexey dans le forum Web
    Réponses: 2
    Dernier message: 17/08/2009, 14h48
  3. cgi et mode __debug__ sous Lighttpd
    Par ledannois dans le forum Réseau/Web
    Réponses: 0
    Dernier message: 12/08/2009, 11h19
  4. [Kylix] [cgi] pb déploiement appli avec connexion MySQL [rés
    Par Nepomiachty Olivier dans le forum Kylix
    Réponses: 3
    Dernier message: 06/08/2002, 20h09
  5. [Kylix] [cgi] ne trouve pas libsqlmy.so.1 !
    Par Nepomiachty Olivier dans le forum Kylix
    Réponses: 3
    Dernier message: 04/07/2002, 15h15

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo