Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 6 sur 6
  1. #1
    Membre à l'essai
    Inscrit en
    mars 2007
    Messages
    68
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 68
    Points : 20
    Points
    20

    Par défaut Stockage de configuration Phpmyadmin

    Bonjour,

    J'ai actuellement le message suivant sur phpMyAdmin 3.5.1 avec Wampserver 2.2 :

    Vos préférences seront sauvegardées pour la session courante seulement. Un stockage permanent requiert l'installation de stockage de configurations phpMyAdmin.
    j'ai créé la base phpmyadmin avec les requêtes du fichier "create_tables.sql", j'ai créé l'utilisateur "pma" avec le mot de passe 'pmapass' en cochant tous les droits, et j'ai ajouté les lignes nécessaires dans le fichier config.inc.php :

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
     
    <?php
     
    /* Servers configuration */
    $i = 0;
     
    /* Server: localhost [1] */
    $i++;
    $cfg['Servers'][$i]['verbose'] = 'localhost';
    $cfg['Servers'][$i]['host'] = 'localhost';
    $cfg['Servers'][$i]['port'] = '';
    $cfg['Servers'][$i]['socket'] = '';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['extension'] = 'mysqli';
    $cfg['Servers'][$i]['auth_type'] = 'config';
    $cfg['Servers'][$i]['user'] = 'root';
    $cfg['Servers'][$i]['password'] = '123';
    $cfg['Servers'][$i]['AllowNoPassword'] = true;
     
    /*
     * phpMyAdmin configuration storage settings.
     */
     
    /* User used to manipulate with storage */
    $cfg['Servers'][$i]['controlhost'] = 'localhost';
    $cfg['Servers'][$i]['controluser'] = 'pma';
    $cfg['Servers'][$i]['controlpass'] = 'pmapass';
     
    /* Storage database and tables */
    $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
    $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
    $cfg['Servers'][$i]['relation'] = 'pma_relation';
    $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
    $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
    $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
    $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
    $cfg['Servers'][$i]['history'] = 'pma_history';
    $cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';
    $cfg['Servers'][$i]['tracking'] = 'pma_tracking';
    $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
    $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
    $cfg['Servers'][$i]['recent'] = 'pma_recent';
    $cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';
    /* Contrib / Swekey authentication */
    $cfg['Servers'][$i]['auth_swekey_config'] = '/etc/swekey-pma.conf';
     
     
    /* End of servers configuration */
     
    $cfg['DefaultLang'] = 'fr-utf-8';
    $cfg['ServerDefault'] = 1;
    $cfg['UploadDir'] = '';
    $cfg['SaveDir'] = '';
     
     
    /* rajk - for blobstreaming */
    $cfg['Servers'][$i]['bs_garbage_threshold'] = 50;
    $cfg['Servers'][$i]['bs_repository_threshold'] = '32M';
    $cfg['Servers'][$i]['bs_temp_blob_timeout'] = 600;
    $cfg['Servers'][$i]['bs_temp_log_threshold'] = '32M';
     
    ?>
    Que dois-je faire d'autres pour que ma config soit enregistrée ?


    EDIT :
    Voici le détail des infos que donne PhpMyAdmin sur ce problème :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    $cfg['Servers'][$i]['pmadb'] ... 	OK
    $cfg['Servers'][$i]['relation'] ... 	en erreur [ Documentation ]
    Fonctions relationnelles: Désactivé
     
    $cfg['Servers'][$i]['table_info'] ... 	en erreur [ Documentation ]
    Affichage infobulle: Désactivé
     
    $cfg['Servers'][$i]['table_coords'] ... 	en erreur [ Documentation ]
    $cfg['Servers'][$i]['pdf_pages'] ... 	en erreur [ Documentation ]
    Génération de schémas en PDF: Désactivé
     
    $cfg['Servers'][$i]['column_info'] ... 	en erreur [ Documentation ]
    Commentaires de colonnes: Désactivé
    Transformation: Désactivé
     
    $cfg['Servers'][$i]['bookmarktable'] ... 	en erreur [ Documentation ]
    Requêtes SQL en signets: Désactivé
     
    $cfg['Servers'][$i]['history'] ... 	en erreur [ Documentation ]
    Historique SQL: Désactivé
     
    $cfg['Servers'][$i]['designer_coords'] ... 	en erreur [ Documentation ]
    Concepteur: Désactivé
     
    $cfg['Servers'][$i]['recent'] ... 	en erreur [ Documentation ]
    Tables récemment utilisées (persistantes): Désactivé
     
    $cfg['Servers'][$i]['table_uiprefs'] ... 	en erreur [ Documentation ]
    Préférences d'interface de tables (persistantes): Désactivé
     
    $cfg['Servers'][$i]['tracking'] ... 	en erreur [ Documentation ]
    Suivi: Désactivé
     
    $cfg['Servers'][$i]['userconfig'] ... 	en erreur [ Documentation ]
    Préférences de l'utilisateur: Désactivé

  2. #2
    Membre Expert
    Avatar de gene69
    Profil pro
    Inscrit en
    janvier 2006
    Messages
    1 633
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : janvier 2006
    Messages : 1 633
    Points : 2 122
    Points
    2 122

    Par défaut

    je te propose de nous montrer ceci:
    Code sql :
    1
    2
    3
    SELECT IF( password= password('pmapass'),'oui','non') "bon mot de passe", mysql.user.* 
    FROM mysql.user 
    WHERE user="pma"

    attention pour mysql, il n'y a pas de résolution de noms, c'est à dire que localhost n'est pas égal à 127.0.0.1 (donc si dans le navigateur c'est pas localhost le nom de serveur ça ne marchera pas).

    en deux et c'était le cas dans les vieilles installes manuelles de phpmyadmin, tu n'as pas executé le script sql qui crées les tables "pma".

    Code sql :
    SHOW TABLES FROM phpmyadmin

    Edit:
    => celon ta config, la table pma est "phpmyadmin".
    PHP fait nativement la validation d'adresse électronique .
    Celui qui a inventé mysql_connect(...) or die() est déjà mort plusieurs fois.
    Soyez moderne: mysqli_connect() or throw Exception(mysqli_connect_error());

    PHP: un problème ? décrivez le avec ceci.

    Utilisez le bouton résolu!

  3. #3
    Modérateur

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 638
    Points
    10 638

    Par défaut

    les configs sont à gérer dans le setup

  4. #4
    Membre à l'essai
    Inscrit en
    mars 2007
    Messages
    68
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 68
    Points : 20
    Points
    20

    Par défaut

    Citation Envoyé par gene69 Voir le message
    je te propose de nous montrer ceci:
    Code sql :
    1
    2
    3
    SELECT IF( password= password('pmapass'),'oui','non') "bon mot de passe", mysql.user.* 
    FROM mysql.user 
    WHERE user="pma"
    Code :
    1
    2
    "oui","%","pma","*03E2854B1BC2353C7FED1F780C55F7845322DC57","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y",,,,,"0","0","0","0",,NULL
    "oui","localhost","pma","*03E2854B1BC2353C7FED1F780C55F7845322DC57","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y","Y",,,,,"0","0","0","0",,NULL
    en deux et c'était le cas dans les vieilles installes manuelles de phpmyadmin, tu n'as pas executé le script sql qui crées les tables "pma".
    Code sql :
    SHOW TABLES FROM phpmyadmin

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    Tables_in_phpmyadmin
    pma_bookmark
    pma_column_info
    pma_designer_coords
    pma_history
    pma_pdf_pages
    pma_recent
    pma_relation
    pma_table_coords
    pma_table_info
    pma_table_uiprefs
    pma_tracking
    pma_userconfig

    les configs sont à gérer dans le setup
    Qu'est-ce que tu appelle "setup" ?

  5. #5
    Membre à l'essai
    Inscrit en
    mars 2007
    Messages
    68
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 68
    Points : 20
    Points
    20

    Par défaut

    Après avoir lu ce message :

    http://forum.wampserver.com/read.php?1,70299

    j'ai compris qu'il fallait juste rebooter et/ou effacer le cache de Firefox.
    Du coup c'est réglé, merci de vos réponses !

  6. #6
    Modérateur

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 638
    Points
    10 638

    Par défaut

    Citation Envoyé par Pokerstar Voir le message
    Qu'est-ce que tu appelle "setup" ?
    phpmyadmin/setup

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •