p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Membre du Club
    Inscrit en
    juillet 2010
    Messages
    156
    Détails du profil
    Informations forums :
    Inscription : juillet 2010
    Messages : 156
    Points : 58
    Points
    58

    Par défaut Problème encodage caractères

    Bonjour,

    Récement, après avoir migré un site ASP 3.0 sur un autre serveur, tous les caractères avec accents (é,è) sont remplacés par ce genre de caractère : �.

    Ce qui est étonnant c'est que cela ne se passe que au niveau du code ASP, en HTML, "é" reste "é". Le site est assez gros, je me vois mal remplacer tous les caractères spéciaux par des &eacute, etc...

    J'ai essayé en mettant en haut de page :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
     
    CodePage="iso-8859-1"
    Response.Charset = "iso-8859-1"
    Cela ne change rien...

    En plus de cela, je n'ai pas ce problème avec un autre site en ASP sur le même serveur... donc je deviens complètement fou, si quelqu'un avait une idée à proposer, je lui en serait reconnaissant.

  2. #2
    Futur Membre du Club
    Homme Profil pro
    Développeur .NET
    Inscrit en
    novembre 2009
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 29
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2009
    Messages : 10
    Points : 16
    Points
    16

    Par défaut

    Essaye :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    Response.CharSet = "windows-1252"
    juste avant l'affichage de ton XML

Discussions similaires

  1. Problème encodage caractère
    Par Daviloppeur dans le forum PHP & MySQL
    Réponses: 3
    Dernier message: 26/02/2010, 09h28
  2. Réponses: 0
    Dernier message: 19/08/2009, 12h31
  3. Problème encodage caractère euro
    Par nuotiz dans le forum PostgreSQL
    Réponses: 4
    Dernier message: 29/05/2007, 22h06
  4. Probléme encodage caractéres spéciaux MYSQL
    Par FoxLeRenard dans le forum Installation
    Réponses: 1
    Dernier message: 20/02/2006, 12h10
  5. Réponses: 1
    Dernier message: 02/02/2006, 23h12

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo