Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Candidat au titre de Membre du Club
    Inscrit en
    avril 2008
    Messages
    54
    Détails du profil
    Informations forums :
    Inscription : avril 2008
    Messages : 54
    Points : 12
    Points
    12

    Par défaut Index is out of date

    Bonjour,

    J'ai une application paradox qui fonctionne depuis 2 ans sans problème en réseau sur plusieurs postes. Depuis peu, sur certain PC (jamais les mêmes), j'ai un message d'erreur qui me dit que "l'index is out of date" sur ma base de données principale. Je suis obligé de fermer paradox sur tous les PC pour que ça fonctionne à nouveau. Certaine fois sans rien toucher, ça re-fonctionne à nouveau. Je suis un peu perdu, pouvez-vous m'aider.

    Merci,

  2. #2
    Membre habitué
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    108
    Détails du profil
    Informations personnelles :
    Localisation : France, Essonne (Île de France)

    Informations forums :
    Inscription : octobre 2007
    Messages : 108
    Points : 113
    Points
    113

    Par défaut

    Bonjour

    Il faut passer le paramètre LOCALSHARE à True dans le fichier de configuration BDE idapi32.cfg (sur le pilote PARADOX).

    Il faut également configurer les postes pour une MAJ automatique de l'horloge sur un serveur de temps.

  3. #3
    Candidat au titre de Membre du Club
    Inscrit en
    avril 2008
    Messages
    54
    Détails du profil
    Informations forums :
    Inscription : avril 2008
    Messages : 54
    Points : 12
    Points
    12

    Par défaut

    Citation Envoyé par comico Voir le message
    Bonjour

    Il faut passer le paramètre LOCALSHARE à True dans le fichier de configuration BDE idapi32.cfg (sur le pilote PARADOX).

    Il faut également configurer les postes pour une MAJ automatique de l'horloge sur un serveur de temps.
    Merci pour votre réponse, j'ai fais ce que vous m'avez conseillé mais le problème persiste. Une filiale en Slovaquie utilise aussi cette application paradox en passant par un serveur TSE. Le problème peut-il venir de la.

    Merci

  4. #4
    Membre habitué
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    108
    Détails du profil
    Informations personnelles :
    Localisation : France, Essonne (Île de France)

    Informations forums :
    Inscription : octobre 2007
    Messages : 108
    Points : 113
    Points
    113

    Par défaut

    Bonjour

    Bien vérifier que tout le monde utilise bien le même fichier de configuration IDAPI centralisé donc (où alors répéter ce paramétrage LOCALSHARE à True dans chaque fichier idapi utilisé). Rappel on peut préciser ce fichier idapi par le paramètre -o dans la ligne de commande de lancement.

    Ce que je fais également maintenant pour le premier utilisateur qui ouvre l'application le matin (test présence date du jour dans une petite table Param) c'est de tester l'intégrité de toutes les tables (méthode isTableCorrupt) et de reconstruire tous les index (sauf pour les tables immobiles genre CodePostaux) avec la méthode tc.ReindexAll()

    Sinon j'ai un site proche dans son architecture de ce que vous décrivez (accès local + accès TSE) sans souci particulier. Mais à terme on envisage un full TSE.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •